summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-16 08:45:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-16 08:45:29 +0100
commit79851ef7da5ffce7aed667c8c49a1ce04333619e (patch)
treed02a27f205d4bf84ecc872e84d0580f49708a86c /eclass
parentdfd0139069bb79941b882fe714d38b7fc8dcdb16 (diff)
gentoo auto-resync : 16:04:2025 - 08:45:29
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin40350 -> 40337 bytes
-rw-r--r--eclass/distutils-r1.eclass37
-rw-r--r--eclass/llvm.org.eclass3
-rw-r--r--eclass/python-utils-r1.eclass8
-rw-r--r--eclass/toolchain.eclass12
5 files changed, 28 insertions, 32 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 93d7b6da8b24..aeb895364e7c 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index e1672dd3c3b0..6e477823ce02 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -154,10 +154,11 @@
# will be merged into ${D}.
# @ECLASS_VARIABLE: DISTUTILS_UPSTREAM_PEP517
+# @DEFAULT_UNSET
# @DESCRIPTION:
# Specifies the PEP517 build backend used upstream. It is used
# by the eclass to verify the correctness of DISTUTILS_USE_PEP517,
-# and matches DISTUTILS_USE_PEP517 by default. However, it can be
+# and defaults to ${DISTUTILS_USE_PEP517}. However, it can be
# overriden to workaround the eclass check, when it is desirable
# to build the wheel using other backend than the one used upstream.
#
@@ -165,7 +166,6 @@
# be subtle differences between the behavior of different PEP517 build
# backends, for example regarding finding package files. When using
# this option, please make sure that the package is installed correctly.
-: "${DISTUTILS_UPSTREAM_PEP517:=${DISTUTILS_USE_PEP517}}"
# @ECLASS_VARIABLE: DISTUTILS_USE_SETUPTOOLS
# @DEFAULT_UNSET
@@ -322,7 +322,7 @@ _distutils_set_globals() {
;;
setuptools)
bdep+='
- >=dev-python/setuptools-75.8.2[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-78.1.0[${PYTHON_USEDEP}]
'
;;
sip)
@@ -347,7 +347,7 @@ _distutils_set_globals() {
eqawarn "is enabled."
fi
else
- local setuptools_dep='>=dev-python/setuptools-75.8.2[${PYTHON_USEDEP}]'
+ local setuptools_dep='>=dev-python/setuptools-78.1.0[${PYTHON_USEDEP}]'
case ${DISTUTILS_USE_SETUPTOOLS:-bdepend} in
no|manual)
@@ -388,6 +388,11 @@ _distutils_set_globals() {
DISTUTILS_DEPS=${bdep}
readonly DISTUTILS_DEPS
fi
+ else
+ eqawarn "distutils-r1.eclass legacy mode is deprecated and will be removed."
+ eqawarn "Please migrate your ebuilds to use DISTUTILS_USE_PEP517 (common values"
+ eqawarn "are 'setuptools' for packages using setuptools/distutils,"
+ eqawarn "and 'no' for packages using non-PEP517 build systems)."
fi
if [[ ! ${DISTUTILS_OPTIONAL} ]]; then
@@ -599,7 +604,7 @@ distutils_enable_sphinx() {
#
# - pytest: dev-python/pytest
#
-# - setup.py: setup.py test (no deps included)
+# - setup.py: setup.py test (no deps included; deprecated)
#
# - unittest: for built-in Python unittest module
#
@@ -645,14 +650,10 @@ distutils_enable_tests() {
fi
;;
setup.py)
+ eqawarn "'distutils_enable_tests setup.py' is deprecated and will be removed."
+ eqawarn "Please use unittest or pytest instead."
;;
unittest)
- # unittest-or-fail is needed in py<3.12
- local test_pkgs="$(python_gen_cond_dep '
- dev-python/unittest-or-fail[${PYTHON_USEDEP}]
- ' 3.10 3.11
- )"
- [[ -n ${test_pkgs} ]] && test_deps+=" ${test_pkgs}"
;;
*)
die "${FUNCNAME}: unsupported argument: ${1}"
@@ -981,15 +982,6 @@ distutils-r1_python_prepare_all() {
if [[ ! ${DISTUTILS_USE_PEP517} ]]; then
_distutils-r1_disable_ez_setup
_distutils-r1_handle_pyproject_toml
-
- case ${DISTUTILS_USE_SETUPTOOLS} in
- no)
- eqawarn "Non-PEP517 builds are deprecated for ebuilds using plain distutils."
- eqawarn "Please migrate to DISTUTILS_USE_PEP517=setuptools."
- eqawarn "Please see Python Guide for more details:"
- eqawarn " https://projects.gentoo.org/python/guide/distutils.html"
- ;;
- esac
fi
if [[ ${DISTUTILS_IN_SOURCE_BUILD} && ! ${DISTUTILS_SINGLE_IMPL} ]]
@@ -1164,7 +1156,10 @@ _distutils-r1_get_backend() {
fi
# verify that the ebuild correctly specifies the build backend
- local expected_backend=$(_distutils-r1_key_to_backend "${DISTUTILS_UPSTREAM_PEP517}")
+ local expected_backend=$(
+ _distutils-r1_key_to_backend \
+ "${DISTUTILS_UPSTREAM_PEP517:-${DISTUTILS_USE_PEP517}}"
+ )
if [[ ${expected_backend} != ${build_backend} ]]; then
# special-case deprecated backends
case ${build_backend} in
diff --git a/eclass/llvm.org.eclass b/eclass/llvm.org.eclass
index a1e22f3203f6..34eda7eee351 100644
--- a/eclass/llvm.org.eclass
+++ b/eclass/llvm.org.eclass
@@ -72,6 +72,9 @@ if [[ -z ${_LLVM_SOURCE_TYPE+1} ]]; then
_LLVM_SOURCE_TYPE=snapshot
case ${PV} in
+ 21.0.0_pre20250415)
+ EGIT_COMMIT=1cf9f764ac41fb3492e10c78640dd50e616388db
+ ;;
21.0.0_pre20250412)
EGIT_COMMIT=fa4ac19f0fc937e30fd7711dad98d0fcdb34f8ba
;;
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index affb8e55a50d..79097765167f 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -1481,7 +1481,7 @@ epytest() {
# @FUNCTION: eunittest
# @USAGE: [<args>...]
# @DESCRIPTION:
-# Run unit tests using dev-python/unittest-or-fail, passing the standard
+# Run unit tests using unittest, passing the standard
# set of options, followed by user-specified options.
#
# This command dies on failure and respects nonfatal.
@@ -1492,11 +1492,7 @@ eunittest() {
_python_check_occluded_packages
# unittest fails with "no tests" correctly since Python 3.12
- local runner=unittest
- if _python_impl_matches "${EPYTHON}" 3.{9..11}; then
- runner=unittest_or_fail
- fi
- set -- "${EPYTHON}" -m "${runner}" discover -v "${@}"
+ set -- "${EPYTHON}" -m unittest discover -v "${@}"
echo "${@}" >&2
"${@}" || die -n "Tests failed with ${EPYTHON}"
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index d96c4acabbe2..ebb63901fba5 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -2352,7 +2352,7 @@ gcc_do_make() {
)
fi
- if is_jit ; then
+ if is_jit || _tc_use_if_iuse libgdiagnostics ; then
# TODO: docs for jit?
einfo "Building JIT"
emake -C "${WORKDIR}"/build-jit "${emakeargs[@]}"
@@ -2554,7 +2554,7 @@ toolchain_src_install() {
done < <(find gcc/include*/ -name '*.h')
fi
- if is_jit ; then
+ if is_jit || _tc_use_if_iuse libgdiagnostics ; then
# See https://gcc.gnu.org/onlinedocs/gcc-11.3.0/jit/internals/index.html#packaging-notes
# and bug #843341.
#
@@ -2781,9 +2781,11 @@ gcc_movelibs() {
# libgccjit gets installed to /usr/lib, not /usr/$(get_libdir). Probably
# due to a bug in gcc build system.
- if [[ ${PWD} == "${WORKDIR}"/build-jit ]] && is_jit ; then
- dodir "${LIBPATH#${EPREFIX}}"
- mv "${ED}"/usr/lib/libgccjit* "${D}${LIBPATH}" || die
+ if [[ ${PWD} == "${WORKDIR}"/build-jit ]] ; then
+ if is_jit || _tc_use_if_iuse libgdiagnostics ; then
+ dodir "${LIBPATH#${EPREFIX}}"
+ mv "${ED}"/usr/lib/libgccjit* "${D}${LIBPATH}" || die
+ fi
fi
# For all the libs that are built for CTARGET, move them into the