summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 21:18:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 21:18:33 +0100
commit63a4617476a3b084928b38d816b9ed6e196d62f5 (patch)
treef1c7e30e8c9b33d9f7e7b0a2e3dbd1d1121358c4 /eclass
parent662f71ae67cd775d7fbb79b5091676c0e07a992b (diff)
gentoo auto-resync : 29:05:2023 - 21:18:33
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin37808 -> 37820 bytes
-rw-r--r--eclass/distutils-r1.eclass27
-rw-r--r--eclass/multilib.eclass7
-rw-r--r--eclass/portability.eclass3
-rw-r--r--eclass/python-utils-r1.eclass6
-rw-r--r--eclass/xorg-3.eclass5
6 files changed, 23 insertions, 25 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 31d40617fea1..69b916f2aa25 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index ec1dd08b197c..0ccd59fb6c78 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -220,7 +220,7 @@ _distutils_set_globals() {
;;
hatchling)
bdep+='
- >=dev-python/hatchling-1.12.2[${PYTHON_USEDEP}]
+ >=dev-python/hatchling-1.17.0[${PYTHON_USEDEP}]
'
;;
jupyter)
@@ -230,7 +230,7 @@ _distutils_set_globals() {
;;
maturin)
bdep+='
- >=dev-util/maturin-0.14.10[${PYTHON_USEDEP}]
+ >=dev-util/maturin-0.14.17[${PYTHON_USEDEP}]
'
;;
no)
@@ -239,7 +239,7 @@ _distutils_set_globals() {
;;
meson-python)
bdep+='
- >=dev-python/meson-python-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.12.1[${PYTHON_USEDEP}]
'
;;
pbr)
@@ -249,23 +249,23 @@ _distutils_set_globals() {
;;
pdm)
bdep+='
- >=dev-python/pdm-pep517-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/pdm-pep517-1.1.4[${PYTHON_USEDEP}]
'
;;
poetry)
bdep+='
- >=dev-python/poetry-core-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/poetry-core-1.5.2[${PYTHON_USEDEP}]
'
;;
setuptools)
bdep+='
- >=dev-python/setuptools-67.2.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.38.4[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.7.2[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.40.0[${PYTHON_USEDEP}]
'
;;
sip)
bdep+='
- >=dev-python/sip-6.7.5-r1[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7.8[${PYTHON_USEDEP}]
'
;;
standalone)
@@ -600,7 +600,7 @@ distutils_enable_tests() {
test_pkg=">=dev-python/nose-1.3.7_p20221026"
;;
pytest)
- test_pkg=">=dev-python/pytest-7.2.1"
+ test_pkg=">=dev-python/pytest-7.3.1"
;;
setup.py)
;;
@@ -925,6 +925,11 @@ _distutils-r1_print_package_versions() {
dev-python/gpep517
dev-python/installer
)
+ if [[ ${DISTUTILS_EXT} ]]; then
+ packages+=(
+ dev-python/cython
+ )
+ fi
case ${DISTUTILS_USE_PEP517} in
flit)
packages+=(
@@ -1828,6 +1833,10 @@ distutils-r1_run_phase() {
if [[ ${DISTUTILS_EXT} ]]; then
local -x CPPFLAGS="${CPPFLAGS} $(usex debug '-UNDEBUG' '-DNDEBUG')"
+ # always generate .c files from .pyx files to ensure we get latest
+ # bug fixes from Cython (this works only when setup.py is using
+ # cythonize() but it's better than nothing)
+ local -x CYTHON_FORCE_REGEN=1
fi
# How to build Python modules in different worlds...
diff --git a/eclass/multilib.eclass b/eclass/multilib.eclass
index 77340a23e30f..bf9c88f7e6a4 100644
--- a/eclass/multilib.eclass
+++ b/eclass/multilib.eclass
@@ -213,7 +213,7 @@ number_abis() {
# Returns: null string (almost everywhere) || .exe (mingw*) || ...
get_exeext() {
case ${CHOST} in
- *-cygwin*|mingw*|*-mingw*) echo ".exe";;
+ mingw*|*-mingw*) echo ".exe";;
esac
}
@@ -230,11 +230,8 @@ get_libname() {
local libname
local ver=$1
case ${CHOST} in
- *-cygwin*) libname="dll.a";; # import lib
mingw*|*-mingw*) libname="dll";;
*-darwin*) libname="dylib";;
- *-mint*) libname="irrelevant";;
- hppa*-hpux*) libname="sl";;
*) libname="so";;
esac
@@ -243,9 +240,7 @@ get_libname() {
else
for ver in "$@" ; do
case ${CHOST} in
- *-cygwin*) echo ".${ver}.${libname}";;
*-darwin*) echo ".${ver}.${libname}";;
- *-mint*) echo ".${libname}";;
*) echo ".${libname}.${ver}";;
esac
done
diff --git a/eclass/portability.eclass b/eclass/portability.eclass
index f31e3fee6ca3..98e9418343d2 100644
--- a/eclass/portability.eclass
+++ b/eclass/portability.eclass
@@ -90,9 +90,8 @@ dlopen_lib() {
# - Darwin needs nothing
# - *BSD needs nothing
# - Linux needs -ldl (glibc and uclibc)
- # - Interix needs -ldl
case "${CHOST}" in
- *-linux-gnu*|*-linux-uclibc|*-interix*)
+ *-linux-gnu*|*-linux-uclibc)
echo "-ldl"
;;
esac
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 40792714cc56..52e9e061d6bd 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -441,13 +441,13 @@ _python_export() {
local d
case ${impl} in
python3.10)
- PYTHON_PKG_DEP=">=dev-lang/python-3.10.9-r1:3.10";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.10.11:3.10";;
python3.11)
- PYTHON_PKG_DEP=">=dev-lang/python-3.11.1-r1:3.11";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.11.3:3.11";;
python3.12)
PYTHON_PKG_DEP=">=dev-lang/python-3.12.0_beta1:3.12";;
pypy3)
- PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.11-r1:0=';;
+ PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.11_p1:0=';;
*)
die "Invalid implementation: ${impl}"
esac
diff --git a/eclass/xorg-3.eclass b/eclass/xorg-3.eclass
index 2faccebba16c..c3ece64ae42d 100644
--- a/eclass/xorg-3.eclass
+++ b/eclass/xorg-3.eclass
@@ -130,7 +130,6 @@ fi
# Set up autotools shared dependencies
# Remember that all versions here MUST be stable
-XORG_EAUTORECONF_ARCHES="x86-winnt"
EAUTORECONF_DEPEND+="
>=sys-devel/libtool-2.2.6a
sys-devel/m4"
@@ -139,10 +138,6 @@ if [[ ${PN} != util-macros ]] ; then
# Required even by xorg-server
[[ ${PN} == "font-util" ]] || EAUTORECONF_DEPEND+=" >=media-fonts/font-util-1.2.0"
fi
-for arch in ${XORG_EAUTORECONF_ARCHES}; do
- EAUTORECONF_DEPENDS+=" ${arch}? ( ${EAUTORECONF_DEPEND} )"
-done
-unset arch XORG_EAUTORECONF_ARCHES
BDEPEND+=" ${EAUTORECONF_DEPENDS}"
[[ ${XORG_EAUTORECONF} != no ]] && BDEPEND+=" ${EAUTORECONF_DEPEND}"
unset EAUTORECONF_DEPENDS