summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /eclass
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin37101 -> 37110 bytes
-rw-r--r--eclass/aspell-dict-r1.eclass62
-rw-r--r--eclass/emboss-r2.eclass52
-rw-r--r--eclass/myspell-r2.eclass34
4 files changed, 80 insertions, 68 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index a6e1a64e3a41..ebbf98283f44 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/aspell-dict-r1.eclass b/eclass/aspell-dict-r1.eclass
index 89f7b954dd68..4d0e64ed4e79 100644
--- a/eclass/aspell-dict-r1.eclass
+++ b/eclass/aspell-dict-r1.eclass
@@ -3,36 +3,40 @@
# @ECLASS: aspell-dict-r1.eclass
# @MAINTAINER:
-# maintainer-needed@gentoo.org
+# Conrad Kostecki <conikost@gentoo.org>
# @AUTHOR:
-# Original author: Seemant Kulleen
-# -r1 author: David Seifert
+# Seemant Kulleen <seemant@gentoo.org> (original author)
+# David Seifert <soap@gentoo.org> (-r1 author)
# @SUPPORTED_EAPIS: 7
-# @BLURB: An eclass to streamline the construction of ebuilds for new aspell dicts
+# @BLURB: An eclass to streamline the construction of ebuilds for new Aspell dictionaries.
# @DESCRIPTION:
-# The aspell-dict-r1 eclass is designed to streamline the construction of
-# ebuilds for the new aspell dictionaries (from gnu.org) which support
-# aspell-0.50. Support for aspell-0.60 has been added by Sergey Ulanov.
+# The aspell-dict-r1 eclass is designed to streamline the construction of ebuilds for
+# the new Aspell dictionaries (from gnu.org) which support aspell-0.60.
+# Support for aspell-0.60 has been added by Sergey Ulanov.
# @ECLASS-VARIABLE: ASPELL_LANG
# @REQUIRED
# @DESCRIPTION:
-# Pure cleartext string that is included into DESCRIPTION. This is the name
-# of the language, for instance "Hungarian". Needs to be defined before
-# inheriting the eclass.
+# Pure cleartext string that is included into DESCRIPTION.
+# This is the name of the language, for instance "Hungarian".
+# Needs to be defined before inheriting the eclass.
+
+# @ECLASS-VARIABLE: ASPELL_SPELLANG
+# @DESCRIPTION:
+# Short (readonly) form of the language code, generated from ${PN}
+# For instance, 'aspell-hu' yields the value 'hu'.
+readonly ASPELL_SPELLANG=${PN/aspell-/}
# @ECLASS-VARIABLE: ASPELL_VERSION
# @DEFAULT_UNSET
# @DESCRIPTION:
-# What major version of aspell is this dictionary for? Valid values are 5, 6 or undefined.
-# This value is used to construct SRC_URI and *DEPEND strings. If defined to 6,
-# >=app-text/aspell-0.60 will be added to DEPEND and RDEPEND, otherwise,
-# >=app-text/aspell-0.50 is added to DEPEND and RDEPEND. If the value is to be overridden,
-# it needs to be overridden before inheriting the eclass.
+# What major version of Aspell is this dictionary for? Valid values are 5, 6 or undefined.
+# This value is used to construct SRC_URI strings.
+# If the value needs to be overridden, it needs to be overridden before inheriting the eclass.
case ${EAPI:-0} in
[0-6])
- die "aspell-dict-r1.eclass is banned in EAPI ${EAPI:-0}"
+ die "${ECLASS} is banned in EAPI ${EAPI:-0}"
;;
7)
;;
@@ -46,36 +50,30 @@ EXPORT_FUNCTIONS src_configure src_install
if [[ ! ${_ASPELL_DICT_R1} ]]; then
_ASPELL_DICT_R1=1
-# aspell packages have an idiosyncratic versioning scheme, that is
-# the last separating version separator is replaced by a '-'.
-_ASPELL_P=aspell${ASPELL_VERSION}-${PN/aspell-/}-${PV%.*}-${PV##*.}
-S="${WORKDIR}/${_ASPELL_P}"
-
-# @ECLASS-VARIABLE: ASPELL_SPELLANG
-# @DESCRIPTION:
-# Short (readonly) form of the language code, generated from ${PN}
-# For instance, 'aspell-hu' yields the value 'hu'.
-readonly ASPELL_SPELLANG=${PN/aspell-/}
+# Most of those aspell packages have an idiosyncratic versioning scheme,
+# where the last separating version separator is replaced by a '-'.
+_ASPELL_P=aspell${ASPELL_VERSION}-${ASPELL_SPELLANG}-${PV%.*}-${PV##*.}
-DESCRIPTION="${ASPELL_LANG} language dictionary for aspell"
+DESCRIPTION="Aspell (${ASPELL_LANG}) language dictionary"
HOMEPAGE="http://aspell.net"
SRC_URI="mirror://gnu/aspell/dict/${ASPELL_SPELLANG}/${_ASPELL_P}.tar.bz2"
+S="${WORKDIR}/${_ASPELL_P}"
unset _ASPELL_P
SLOT="0"
-_ASPELL_MAJOR_VERSION=${ASPELL_VERSION:-5}
-[[ ${_ASPELL_MAJOR_VERSION} != [56] ]] && die "${ASPELL_VERSION} is not a valid version"
-
-RDEPEND=">=app-text/aspell-0.${_ASPELL_MAJOR_VERSION}0"
+RDEPEND="app-text/aspell"
DEPEND="${RDEPEND}"
+
+_ASPELL_MAJOR_VERSION=${ASPELL_VERSION:-6}
+[[ ${_ASPELL_MAJOR_VERSION} != [56] ]] && die "Unsupported ASPELL_VERSION=${ASPELL_VERSION}"
unset _ASPELL_MAJOR_VERSION
# @FUNCTION: aspell-dict-r1_src_configure
# @DESCRIPTION:
# The aspell-dict-r1 src_configure function which is exported.
aspell-dict-r1_src_configure() {
- # non-autoconf based script, cannot be used with econf
+ # Since it's a non-autoconf based script, 'econf' cannot be used.
./configure || die
}
diff --git a/eclass/emboss-r2.eclass b/eclass/emboss-r2.eclass
index ef240889c04a..1f09805f8541 100644
--- a/eclass/emboss-r2.eclass
+++ b/eclass/emboss-r2.eclass
@@ -9,12 +9,10 @@
# Original author: Author Olivier Fisette <ofisette@gmail.com>
# Next gen author: Justin Lecher <jlec@gentoo.org>
# Next gen author: Ted Tanberry <ted.tanberry@gmail.com>
-# @SUPPORTED_EAPIS: 6 7
+# @SUPPORTED_EAPIS: 7
# @BLURB: Use this to easy install EMBOSS and EMBASSY programs (EMBOSS add-ons).
# @DESCRIPTION:
-# The inheriting ebuild must set at least EAPI=6 and provide EBO_DESCRIPTION before the inherit line.
-# KEYWORDS should be set. Additionally "(R|P)DEPEND"encies and other standard
-# ebuild variables can be extended (FOO+=" bar").
+# The inheriting ebuild must provide EBO_DESCRIPTION before the inherit line.
#
# Example:
#
@@ -27,7 +25,7 @@
# @ECLASS-VARIABLE: EBO_DESCRIPTION
# @DEFAULT_UNSET
# @DESCRIPTION:
-# Should be set. Completes the generic description of the embassy module as follows:
+# Completes the generic description of the embassy module as follows:
#
# EMBOSS integrated version of ${EBO_DESCRIPTION}, e.g.
#
@@ -35,22 +33,24 @@
#
# Defaults to the upstream name of the module.
-if [[ ! ${_EMBOSS_R2} ]]; then
-
case ${EAPI:-0} in
- [67]) ;;
- *) die "EAPI=${EAPI} is not supported" ;;
+ [0-6]) die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}" ;;
+ 7) ;;
+ *) die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}" ;;
esac
-inherit autotools flag-o-matic
-
EXPORT_FUNCTIONS src_prepare src_configure src_install
+if [[ ! ${_EMBOSS_R2_ECLASS} ]]; then
+_EMBOSS_R2_ECLASS=1
+
+inherit autotools flag-o-matic
+
HOMEPAGE="http://emboss.sourceforge.net/"
LICENSE="LGPL-2 GPL-2"
SLOT="0"
-IUSE="mysql pdf png postgres static-libs X"
+IUSE="mysql pdf png postgres X"
RDEPEND="
dev-libs/expat
@@ -75,7 +75,7 @@ if [[ ${PN} == embassy-* ]]; then
DESCRIPTION="EMBOSS integrated version of ${EBO_DESCRIPTION}"
SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/${EF}.tar.gz -> embassy-${EN}-${PV}.tar.gz"
- RDEPEND+=" >=sci-biology/emboss-6.6.0-r1[mysql=,pdf=,png=,postgres=,static-libs=,X=]"
+ RDEPEND+=" >=sci-biology/emboss-6.6.0-r1[mysql=,pdf=,png=,postgres=,X=]"
S="${WORKDIR}/${EF}"
fi
@@ -93,10 +93,8 @@ DEPEND="${RDEPEND}"
# Does the following things
#
# 1. Renames configure.in to configure.ac, if possible
-# 2. Calls default_src_prepare (i.e.
-# applies Gentoo and user patches in EAPI>=6)
+# 2. Calls default_src_prepare (i.e. applies Gentoo and user patches)
# 3. If EBO_EAUTORECONF is set, run eautoreconf
-#
emboss-r2_src_prepare() {
if [[ -e configure.in ]]; then
@@ -112,7 +110,7 @@ emboss-r2_src_prepare() {
# runs econf with following options.
#
# --enable-shared
-# $(use_enable static-libs static)
+# --disable-static
# $(use_with X x)
# $(use_with png pngdriver)
# $(use_with pdf hpdf)
@@ -123,17 +121,17 @@ emboss-r2_src_prepare() {
# --enable-systemlibs
#
# can be appended to like econf, e.g.
-# emboss-r2_src_configure --disable-shared
+# emboss-r2_src_configure --enable-foo
emboss-r2_src_configure() {
local myconf=(
--enable-shared
- $(use_enable static-libs static)
+ --disable-static
$(use_with X x)
- $(use_with png pngdriver "${EPREFIX}/usr")
- $(use_with pdf hpdf "${EPREFIX}/usr")
- $(use_with mysql mysql "${EPREFIX}/usr/bin/mysql_config")
- $(use_with postgres postgresql "${EPREFIX}/usr/bin/pg_config")
+ $(use_with png pngdriver "${EPREFIX}"/usr)
+ $(use_with pdf hpdf "${EPREFIX}"/usr)
+ $(use_with mysql mysql "${EPREFIX}"/usr/bin/mysql_config)
+ $(use_with postgres postgresql "${EPREFIX}"/usr/bin/pg_config)
--enable-large
--without-java
--enable-systemlibs
@@ -147,17 +145,13 @@ emboss-r2_src_configure() {
# @FUNCTION: emboss-r2_src_install
# @DESCRIPTION:
-# Installs the package into the staging area and removes
-# extraneous .la files, if USE="-static-libs"
+# Installs the package into the staging area and removes unnecessary .la files.
emboss-r2_src_install() {
default
# delete .la files
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
+ find "${ED}" -name '*.la' -delete || die
}
-_EMBOSS_R2=1
fi
diff --git a/eclass/myspell-r2.eclass b/eclass/myspell-r2.eclass
index 2de8d14c78b1..e4d9ae69af3a 100644
--- a/eclass/myspell-r2.eclass
+++ b/eclass/myspell-r2.eclass
@@ -1,15 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: myspell-r2.eclass
# @MAINTAINER:
-# maintainer-needed@gentoo.org
+# Conrad Kostecki <conikost@gentoo.org>
# @AUTHOR:
# Tomáš Chvátal <scarabeus@gentoo.org>
-# @BLURB: An eclass to ease the construction of ebuilds for myspell dicts
+# @SUPPORTED_EAPIS: 5 6 7
+# @BLURB: An eclass to streamline the construction of ebuilds for new Myspell dictionaries.
# @DESCRIPTION:
-
-EXPORT_FUNCTIONS src_unpack src_install
+# The myspell-r2 eclass is designed to streamline the construction of ebuilds for
+# the new Myspell dictionaries which support hunspell.
# @ECLASS-VARIABLE: MYSPELL_DICT
# @DEFAULT_UNSET
@@ -18,20 +19,39 @@ EXPORT_FUNCTIONS src_unpack src_install
# MYSPELL_DICT=( "file.dic" "dir/file2.aff" )
# @ECLASS-VARIABLE: MYSPELL_HYPH
+# @DEFAULT_UNSET
# @DESCRIPTION:
# Array variable containing list of all hyphenation files.
# MYSPELL_HYPH=( "file.dic" "dir/file2.dic" )
# @ECLASS-VARIABLE: MYSPELL_THES
+# @DEFAULT_UNSET
# @DESCRIPTION:
# Array variable containing list of all thesarus files.
# MYSPELL_THES=( "file.dat" "dir/file2.idx" )
+case ${EAPI:-0} in
+ [0-4])
+ die "${ECLASS} is banned in EAPI ${EAPI:-0}"
+ ;;
+ [5-7])
+ ;;
+ *)
+ die "Unknown EAPI ${EAPI:-0}"
+ ;;
+esac
+
+EXPORT_FUNCTIONS src_unpack src_install
+
# Basically no extra deps needed.
# Unzip is required for .oxt libreoffice extensions
# which are just fancy zip files.
-DEPEND="app-arch/unzip"
-RDEPEND=""
+if [[ ${EAPI:-0} == 7 ]]; then
+ BDEPEND="app-arch/unzip"
+else
+ DEPEND="app-arch/unzip"
+ RDEPEND=""
+fi
# by default this stuff does not have any folder in the pack
S="${WORKDIR}"