summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /eclass
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin37125 -> 37116 bytes
-rw-r--r--eclass/acct-group.eclass6
-rw-r--r--eclass/acct-user.eclass12
-rw-r--r--eclass/cmake-utils.eclass4
-rw-r--r--eclass/kde5.eclass7
-rw-r--r--eclass/qt5-build.eclass36
6 files changed, 32 insertions, 33 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 0aff012ab8c4..642a542e4f4d 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/acct-group.eclass b/eclass/acct-group.eclass
index 7fe9f19effc7..9eab00db690f 100644
--- a/eclass/acct-group.eclass
+++ b/eclass/acct-group.eclass
@@ -70,7 +70,6 @@ readonly ACCT_GROUP_NAME
# << Boilerplate ebuild variables >>
: ${DESCRIPTION:="System group: ${ACCT_GROUP_NAME}"}
-: ${HOMEPAGE:=https://www.gentoo.org/}
: ${SLOT:=0}
: ${KEYWORDS:=alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris}
S=${WORKDIR}
@@ -105,7 +104,7 @@ acct-group_pkg_pretend() {
elif [[ -n ${group_by_name} ]]; then
eerror "The requested group exists already with wrong GID."
eerror " groupname: ${ACCT_GROUP_NAME}"
- eerror " requested UID: ${ACCT_GROUP_ID}"
+ eerror " requested GID: ${ACCT_GROUP_ID}"
eerror " current entry: ${group_by_name}"
die "Group ${ACCT_GROUP_NAME} exists with wrong GID"
fi
@@ -118,7 +117,8 @@ acct-group_pkg_pretend() {
acct-group_pkg_preinst() {
debug-print-function ${FUNCNAME} "${@}"
- enewgroup -F "${ACCT_GROUP_NAME}" "${ACCT_GROUP_ID}"
+ enewgroup ${ACCT_GROUP_ENFORCE_ID:+-F} "${ACCT_GROUP_NAME}" \
+ "${ACCT_GROUP_ID}"
}
fi
diff --git a/eclass/acct-user.eclass b/eclass/acct-user.eclass
index 1b8a0bf94a62..60009643c144 100644
--- a/eclass/acct-user.eclass
+++ b/eclass/acct-user.eclass
@@ -109,7 +109,6 @@ readonly ACCT_USER_NAME
# << Boilerplate ebuild variables >>
: ${DESCRIPTION:="System user: ${ACCT_USER_NAME}"}
-: ${HOMEPAGE:=https://www.gentoo.org/}
: ${SLOT:=0}
: ${KEYWORDS:=alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris}
S=${WORKDIR}
@@ -326,8 +325,9 @@ acct-user_pkg_preinst() {
debug-print-function ${FUNCNAME} "${@}"
local groups=${ACCT_USER_GROUPS[*]}
- enewuser -F -M "${ACCT_USER_NAME}" "${ACCT_USER_ID}" \
- "${ACCT_USER_SHELL}" "${ACCT_USER_HOME}" "${groups// /,}"
+ enewuser ${ACCT_USER_ENFORCE_ID:+-F} -M "${ACCT_USER_NAME}" \
+ "${ACCT_USER_ID}" "${ACCT_USER_SHELL}" "${ACCT_USER_HOME}" \
+ "${groups// /,}"
if [[ ${ACCT_USER_HOME} != /dev/null ]]; then
# default ownership to user:group
@@ -363,6 +363,12 @@ acct-user_pkg_prerm() {
debug-print-function ${FUNCNAME} "${@}"
if [[ -z ${REPLACED_BY_VERSION} ]]; then
+ if [[ -z $(egetent passwd "${ACCT_USER_NAME}") ]]; then
+ ewarn "User account not found: ${ACCT_USER_NAME}"
+ ewarn "Locking process will be skipped."
+ return
+ fi
+
esetshell "${ACCT_USER_NAME}" -1
esetcomment "${ACCT_USER_NAME}" \
"$(egetcomment "${ACCT_USER_NAME}"); user account removed @ $(date +%Y-%m-%d)"
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index d01a64d014af..ea1858e9735f 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -420,10 +420,10 @@ _cmake_modify-cmakelists() {
# Comment out all set (<some_should_be_user_defined_variable> value)
find "${CMAKE_USE_DIR}" -name CMakeLists.txt -exec sed \
- -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_BUILD_TYPE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
+ -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_BUILD_TYPE\([[:space:]].*)\|)\)/I{s/^/#_cmake_modify_IGNORE /g}' \
-e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_COLOR_MAKEFILE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
-e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_INSTALL_PREFIX[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
- -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_VERBOSE_MAKEFILE[[:space:]].*)/I{s/^/#G_cmake_modify_IGNORE /g}' \
+ -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_VERBOSE_MAKEFILE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
-i {} + || die "${LINENO}: failed to disable hardcoded settings"
local x
for x in $(find "${CMAKE_USE_DIR}" -name CMakeLists.txt -exec grep -l "^#_cmake_modify_IGNORE" {} +;); do
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 4f38f47d60be..f58d991bc584 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -262,7 +262,7 @@ case ${EAPI} in
6) DEPEND+=" ${BDEPEND}" ;;
esac
-DEPEND+=" ${COMMONDEPEND} dev-util/desktop-file-utils"
+DEPEND+=" ${COMMONDEPEND}"
RDEPEND+=" ${COMMONDEPEND}"
unset COMMONDEPEND
@@ -495,7 +495,10 @@ kde5_src_prepare() {
fi
# enable only the requested translations when required
- if [[ -v LINGUAS ]] ; then
+ # always install unconditionally for kconfigwidgets - if you use language
+ # X as system language, and there is a combobox with language names, the
+ # translated language name for language Y is taken from /usr/share/locale/Y/kf5_entry.desktop
+ if [[ -v LINGUAS && ${PN} != kconfigwidgets ]] ; then
local po
for po in ${KDE_PO_DIRS}; do
if [[ -d ${po} ]] ; then
diff --git a/eclass/qt5-build.eclass b/eclass/qt5-build.eclass
index d4f4678eed07..b22124100d3e 100644
--- a/eclass/qt5-build.eclass
+++ b/eclass/qt5-build.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: qt5-build.eclass
@@ -6,7 +6,7 @@
# qt@gentoo.org
# @AUTHOR:
# Davide Pesavento <pesa@gentoo.org>
-# @SUPPORTED_EAPIS: 6
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: Eclass for Qt5 split ebuilds.
# @DESCRIPTION:
# This eclass contains various functions that are used when building Qt5.
@@ -17,7 +17,8 @@ if [[ ${CATEGORY} != dev-qt ]]; then
fi
case ${EAPI} in
- 6) : ;;
+ 6) inherit eapi7-ver ;;
+ 7) : ;;
*) die "qt5-build.eclass: unsupported EAPI=${EAPI:-0}" ;;
esac
@@ -57,7 +58,7 @@ esac
# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
: ${VIRTUALX_REQUIRED:=manual}
-inherit eapi7-ver estack flag-o-matic toolchain-funcs virtualx
+inherit estack flag-o-matic toolchain-funcs virtualx
HOMEPAGE="https://www.qt.io/"
LICENSE="|| ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3"
@@ -113,10 +114,13 @@ IUSE="debug test"
[[ ${QT5_BUILD_TYPE} == release ]] && RESTRICT+=" test" # bug 457182
-DEPEND="
+BDEPEND="
dev-lang/perl
virtual/pkgconfig
"
+case ${EAPI} in
+ 6) DEPEND+=" ${BDEPEND}" ;;
+esac
if [[ ${PN} != qttest ]]; then
DEPEND+=" test? ( ~dev-qt/qttest-${PV} )"
fi
@@ -178,12 +182,6 @@ qt5-build_src_prepare() {
sed -i -e "/^QMAKE_CONF_COMPILER=/ s:=.*:=\"$(tc-getCXX)\":" \
configure || die "sed failed (QMAKE_CONF_COMPILER)"
- if [[ ${QT5_MINOR_VERSION} -lt 12 ]]; then
- # Don't add -O3 to CXXFLAGS (bug 549140)
- sed -i -e '/CONFIG\s*+=/ s/optimize_full//' \
- src/{corelib/corelib,gui/gui}.pro || die "sed failed (optimize_full)"
- fi
-
# Respect build variables in configure tests (bug #639494)
sed -i -e "s|\"\$outpath/bin/qmake\" \"\$relpathMangled\" -- \"\$@\"|& $(qt5_qmake_args) |" configure || die
fi
@@ -256,10 +254,6 @@ qt5-build_src_install() {
popd >/dev/null || die
- if [[ ${QT5_MINOR_VERSION} -lt 12 ]]; then
- docompress -x "${QT5_DOCDIR#${EPREFIX}}"/global
- fi
-
# install an empty Gentoo/gentoo-qconfig.h in ${D}
# so that it's placed under package manager control
> "${T}"/gentoo-qconfig.h
@@ -416,11 +410,7 @@ qt5_prepare_env() {
QT5_IMPORTDIR=${QT5_ARCHDATADIR}/imports
QT5_QMLDIR=${QT5_ARCHDATADIR}/qml
QT5_DATADIR=${QT5_PREFIX}/share/qt5
- if [[ ${QT5_MINOR_VERSION} -lt 12 ]]; then
- QT5_DOCDIR=${QT5_PREFIX}/share/doc/qt-${PV}
- else
- QT5_DOCDIR=${QT5_PREFIX}/share/qt5-doc
- fi
+ QT5_DOCDIR=${QT5_PREFIX}/share/qt5-doc
QT5_TRANSLATIONDIR=${QT5_DATADIR}/translations
QT5_EXAMPLESDIR=${QT5_DATADIR}/examples
QT5_TESTSDIR=${QT5_DATADIR}/tests
@@ -579,8 +569,7 @@ qt5_base_configure() {
-no-freetype -no-harfbuzz
-no-openssl -no-libproxy
-no-xcb-xlib
- $([[ ${QT5_MINOR_VERSION} -lt 12 ]] && echo -no-xinput2 -no-xkbcommon-x11 -no-xkbcommon-evdev)
- $([[ ${QT5_MINOR_VERSION} -ge 12 ]] && echo -no-xcb-xinput -no-xkbcommon) # bug 672340
+ -no-xcb-xinput -no-xkbcommon # bug 672340
# cannot use -no-gif because there is no way to override it later
#-no-gif
@@ -623,7 +612,8 @@ qt5_base_configure() {
$(tc-ld-is-gold && echo -use-gold-linker || echo -no-use-gold-linker)
# disable all platform plugins by default, override in qtgui
- -no-xcb -no-eglfs -no-kms -no-gbm -no-directfb -no-linuxfb -no-mirclient
+ -no-xcb -no-eglfs -no-kms -no-gbm -no-directfb -no-linuxfb
+ $([[ ${QT5_MINOR_VERSION} -lt 14 ]] && echo -no-mirclient)
# disable undocumented X11-related flags, override in qtgui
# (not shown in ./configure -help output)