summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /eclass
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin37101 -> 37107 bytes
-rw-r--r--eclass/distutils-r1.eclass2
-rw-r--r--eclass/elisp-common.eclass4
-rw-r--r--eclass/meson.eclass2
4 files changed, 6 insertions, 2 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index fe5c3cb63be4..8c9c20d40a3a 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 780becc3ace9..ca2ed98c8e8c 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -88,7 +88,7 @@ esac
# - rdepend -- add it to BDEPEND+RDEPEND (when using entry_points)
# - pyproject.toml -- use pyproject2setuptools to install a project
# using pyproject.toml (flit, poetry...)
-# - manual -- do not add the depedency and suppress the checks
+# - manual -- do not add the dependency and suppress the checks
# (assumes you will take care of doing it correctly)
#
# This variable is effective only if DISTUTILS_OPTIONAL is disabled.
diff --git a/eclass/elisp-common.eclass b/eclass/elisp-common.eclass
index 66a3a325e673..be8d0fa3b304 100644
--- a/eclass/elisp-common.eclass
+++ b/eclass/elisp-common.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: elisp-common.eclass
@@ -234,6 +234,8 @@ elisp-emacs-version() {
rm -f "${T}"/emacs-version.el
if [[ ${ret} -ne 0 ]]; then
eerror "elisp-emacs-version: Failed to run ${EMACS}"
+ [[ $(realpath ${EMACS} 2>/dev/null) == */emacs* ]] \
+ || eerror "This package needs GNU Emacs"
return ${ret}
fi
if [[ -z ${version} ]]; then
diff --git a/eclass/meson.eclass b/eclass/meson.eclass
index 67b7ca831fd2..d0ce5adb3558 100644
--- a/eclass/meson.eclass
+++ b/eclass/meson.eclass
@@ -169,6 +169,7 @@ _meson_create_cross_file() {
llvm-config = '$(tc-getPROG LLVM_CONFIG llvm-config)'
nm = $(_meson_env_array "$(tc-getNM)")
objc = $(_meson_env_array "$(tc-getPROG OBJC cc)")
+ objcopy = $(_meson_env_array "$(tc-getOBJCOPY)")
objcpp = $(_meson_env_array "$(tc-getPROG OBJCXX c++)")
pkgconfig = '$(tc-getPKG_CONFIG)'
strip = $(_meson_env_array "$(tc-getSTRIP)")
@@ -220,6 +221,7 @@ _meson_create_native_file() {
llvm-config = '$(tc-getBUILD_PROG LLVM_CONFIG llvm-config)'
nm = $(_meson_env_array "$(tc-getBUILD_NM)")
objc = $(_meson_env_array "$(tc-getBUILD_PROG OBJC cc)")
+ objcopy = $(_meson_env_array "$(tc-getBUILD_OBJCOPY)")
objcpp = $(_meson_env_array "$(tc-getBUILD_PROG OBJCXX c++)")
pkgconfig = '$(tc-getBUILD_PKG_CONFIG)'
strip = $(_meson_env_array "$(tc-getBUILD_STRIP)")