summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-14 11:49:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-14 11:49:05 +0000
commit349911d45bc38140a6a32c0971e0ab5cdc4de9ac (patch)
tree6be26514b76fa6ab52d7ce4ffc496443f1847170 /eclass
parentf6dd50974cd0831c02d82dbd391432ed0127589e (diff)
gentoo auto-resync : 14:12:2023 - 11:49:05
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin38930 -> 38937 bytes
-rw-r--r--eclass/distutils-r1.eclass6
-rw-r--r--eclass/flag-o-matic.eclass4
-rw-r--r--eclass/python-utils-r1.eclass24
4 files changed, 14 insertions, 20 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 3fa5700dcbff..598b6aa7242a 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 0a7b18e4a1a4..0a9815f2d459 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -50,6 +50,7 @@ case ${EAPI} in
esac
# @ECLASS_VARIABLE: DISTUTILS_EXT
+# @PRE_INHERIT
# @DEFAULT_UNSET
# @DESCRIPTION:
# Set this variable to a non-null value if the package (possibly
@@ -1806,6 +1807,11 @@ distutils-r1_run_phase() {
tc-export AR CC CPP CXX
if [[ ${DISTUTILS_EXT} ]]; then
+ if [[ ${BDEPEND} == *dev-python/cython* ]] ; then
+ # Workaround for https://github.com/cython/cython/issues/2747 (bug #918983)
+ local -x CFLAGS="${CFLAGS} $(test-flags-CC -Wno-error=incompatible-pointer-types)"
+ fi
+
local -x CPPFLAGS="${CPPFLAGS} $(usex debug '-UNDEBUG' '-DNDEBUG')"
# always generate .c files from .pyx files to ensure we get latest
# bug fixes from Cython (this works only when setup.py is using
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 40662f4f7d7b..0e427649c015 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -115,6 +115,10 @@ _setup-allowed-flags() {
-mlittle-endian -mbig-endian -EL -EB -fPIC -mlive-g0 '-mcmodel=*'
-mstack-bias -mno-stack-bias -msecure-plt '-m*-toc' '-mfloat-abi=*'
+ # This is default on for a bunch of arches except amd64 in GCC
+ # already, and amd64 itself is planned too.
+ '-mtls-dialect=*'
+
# MIPS errata
-mfix-24k -mno-fix-24k -mfix-r4000 -mno-fix-r4000
-mfix-r4400 -mno-fix-r4400 -mfix-r5900 -mno-fix-r5900
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 394f64a5d139..abb55bd2e942 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -153,17 +153,6 @@ _python_set_impls() {
done
fi
- if [[ -n ${obsolete[@]} && ${EBUILD_PHASE} == setup ]]; then
- # complain if people don't clean up old impls while touching
- # the ebuilds recently. use the copyright year to infer last
- # modification
- # NB: this check doesn't have to work reliably
- if [[ $(head -n 1 "${EBUILD}" 2>/dev/null) == *2022* ]]; then
- eqawarn "Please clean PYTHON_COMPAT of obsolete implementations:"
- eqawarn " ${obsolete[*]}"
- fi
- fi
-
local supp=() unsupp=()
for i in "${_PYTHON_ALL_IMPLS[@]}"; do
@@ -1336,15 +1325,8 @@ epytest() {
_python_check_EPYTHON
_python_check_occluded_packages
- local color
- case ${NOCOLOR} in
- true|yes)
- color=no
- ;;
- *)
- color=yes
- ;;
- esac
+ local color=yes
+ [[ ${NO_COLOR} ]] && color=no
local args=(
# verbose progress reporting and tracebacks
@@ -1389,6 +1371,8 @@ epytest() {
-p no:pytest-describe
-p no:plus
-p no:tavern
+ # does something to logging
+ -p no:salt-factories
)
fi