summaryrefslogtreecommitdiff
path: root/eclass/xorg-3.eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /eclass/xorg-3.eclass
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'eclass/xorg-3.eclass')
-rw-r--r--eclass/xorg-3.eclass18
1 files changed, 9 insertions, 9 deletions
diff --git a/eclass/xorg-3.eclass b/eclass/xorg-3.eclass
index d5dadbad3f54..e908d51c669f 100644
--- a/eclass/xorg-3.eclass
+++ b/eclass/xorg-3.eclass
@@ -42,7 +42,7 @@ if [[ ${CATEGORY} = media-fonts ]]; then
esac
fi
-# @ECLASS-VARIABLE: XORG_MULTILIB
+# @ECLASS_VARIABLE: XORG_MULTILIB
# @PRE_INHERIT
# @DESCRIPTION:
# If set to 'yes', the multilib support for package will be enabled. Set
@@ -68,21 +68,21 @@ EXPORT_FUNCTIONS ${EXPORTED_FUNCTIONS}
IUSE=""
-# @ECLASS-VARIABLE: XORG_EAUTORECONF
+# @ECLASS_VARIABLE: XORG_EAUTORECONF
# @PRE_INHERIT
# @DESCRIPTION:
# If set to 'yes' and configure.ac exists, eautoreconf will run. Set
# before inheriting this eclass.
: ${XORG_EAUTORECONF:="no"}
-# @ECLASS-VARIABLE: XORG_BASE_INDIVIDUAL_URI
+# @ECLASS_VARIABLE: XORG_BASE_INDIVIDUAL_URI
# @PRE_INHERIT
# @DESCRIPTION:
# Set up SRC_URI for individual modular releases. If set to an empty
# string, no SRC_URI will be provided by the eclass.
: ${XORG_BASE_INDIVIDUAL_URI="https://www.x.org/releases/individual"}
-# @ECLASS-VARIABLE: XORG_MODULE
+# @ECLASS_VARIABLE: XORG_MODULE
# @PRE_INHERIT
# @DESCRIPTION:
# The subdirectory to download source from. Possible settings are app,
@@ -103,7 +103,7 @@ if [[ ${XORG_MODULE} == auto ]]; then
esac
fi
-# @ECLASS-VARIABLE: XORG_PACKAGE_NAME
+# @ECLASS_VARIABLE: XORG_PACKAGE_NAME
# @PRE_INHERIT
# @DESCRIPTION:
# For git checkout the git repository might differ from package name.
@@ -112,7 +112,7 @@ fi
HOMEPAGE="https://www.x.org/wiki/ https://gitlab.freedesktop.org/xorg/${XORG_MODULE}${XORG_PACKAGE_NAME}"
-# @ECLASS-VARIABLE: XORG_TARBALL_SUFFIX
+# @ECLASS_VARIABLE: XORG_TARBALL_SUFFIX
# @PRE_INHERIT
# @DESCRIPTION:
# Most X11 projects provide tarballs as tar.bz2 or tar.xz. This eclass defaults
@@ -162,7 +162,7 @@ if [[ ${FONT} == yes ]]; then
>=x11-apps/mkfontscale-1.2.0"
BDEPEND+=" x11-apps/bdftopcf"
- # @ECLASS-VARIABLE: FONT_DIR
+ # @ECLASS_VARIABLE: FONT_DIR
# @PRE_INHERIT
# @DESCRIPTION:
# If you're creating a font package and the suffix of PN is not equal to
@@ -179,7 +179,7 @@ if [[ ${FONT} == yes ]]; then
fi
BDEPEND+=" virtual/pkgconfig"
-# @ECLASS-VARIABLE: XORG_DRI
+# @ECLASS_VARIABLE: XORG_DRI
# @PRE_INHERIT
# @DESCRIPTION:
# Possible values are "always" or the value of the useflag DRI capabilities
@@ -213,7 +213,7 @@ if [[ ${PN} == xf86-video-* || ${PN} == xf86-input-* ]]; then
fi
-# @ECLASS-VARIABLE: XORG_DOC
+# @ECLASS_VARIABLE: XORG_DOC
# @PRE_INHERIT
# @DESCRIPTION:
# Possible values are "always" or the value of the useflag doc packages