summaryrefslogtreecommitdiff
path: root/eclass/distutils-r1.eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
commit69051588e2f955485fe5d45d45e616bc60a2de57 (patch)
treeef8699cca7ce3773b1de747b167ceeacdc60cb92 /eclass/distutils-r1.eclass
parentd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (diff)
gentoo resync : 31.01.2021
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass12
1 files changed, 6 insertions, 6 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index c5c954f49250..07ded8516fdc 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -550,11 +550,11 @@ esetup.py() {
# For most of the packages, tests built in BUILD_DIR are good enough.
#
# The function supports two install modes. The current default is
-# the legacy --via-home mode. However, it has problems with newer
-# versions of setuptools (50.3.0+). The --via-root mode generally
-# works for these packages, and it will probably become the default
-# in the future, once we test all affected packages. Please note
-# that proper testing sometimes requires unmerging the package first.
+# --via-root mode. Previously, the function defaulted to --via-home
+# mode but it has been broken by new versions of setuptools (50.3.0+).
+# If you find that --via-root does not work but --via-home does, please
+# file a bug to let us know. Please note that proper testing sometimes
+# requires unmerging the package first.
distutils_install_for_testing() {
debug-print-function ${FUNCNAME} "${@}"
@@ -575,7 +575,7 @@ distutils_install_for_testing() {
PATH=${bindir}:${PATH}
PYTHONPATH=${libdir}:${PYTHONPATH}
- local install_method=home
+ local install_method=root
case ${1} in
--via-home)
install_method=home