summaryrefslogtreecommitdiff
path: root/eclass/cmake.eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
commitcaf79cb4f7c4d5f7cce488d8f50dfb98ddbd09ab (patch)
tree4fb39a9252efabe8f160ef46b7b3be2f52af25aa /eclass/cmake.eclass
parent3606ceecb950b302a6ba2a9882aeeff2a851e5dc (diff)
gentoo auto-resync : 10:12:2022 - 03:19:26
Diffstat (limited to 'eclass/cmake.eclass')
-rw-r--r--eclass/cmake.eclass5
1 files changed, 2 insertions, 3 deletions
diff --git a/eclass/cmake.eclass b/eclass/cmake.eclass
index bd7e64cfe6c7..094b6d706bc2 100644
--- a/eclass/cmake.eclass
+++ b/eclass/cmake.eclass
@@ -15,8 +15,7 @@
# @DESCRIPTION:
# The cmake eclass makes creating ebuilds for cmake-based packages much easier.
# It provides all inherited features (DOCS, HTML_DOCS, PATCHES) along with
-# out-of-source builds (default), in-source builds and an implementation of the
-# well-known use_enable function for CMake.
+# out-of-source builds (default) and in-source builds.
case ${EAPI} in
7|8) ;;
@@ -355,7 +354,7 @@ cmake_src_prepare() {
default_src_prepare
- # check if CMakeLists.txt exist and if no then die
+ # check if CMakeLists.txt exists and if not then die
if [[ ! -e ${CMAKE_USE_DIR}/CMakeLists.txt ]] ; then
eerror "Unable to locate CMakeLists.txt under:"
eerror "\"${CMAKE_USE_DIR}/CMakeLists.txt\""