summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-vcs
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin11672 -> 11683 bytes
-rw-r--r--dev-vcs/gitstats/Manifest3
-rw-r--r--dev-vcs/gitstats/files/gitstats-0_pre20201124-py312.patch44
-rw-r--r--dev-vcs/gitstats/gitstats-0_pre20201124.ebuild9
-rw-r--r--dev-vcs/pre-commit/Manifest6
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.7.1.ebuild2
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.8.0.ebuild (renamed from dev-vcs/pre-commit/pre-commit-3.6.0.ebuild)56
7 files changed, 92 insertions, 28 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index 75f518ac4932..31ee97a1862a 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/gitstats/Manifest b/dev-vcs/gitstats/Manifest
index ebbb60fd343e..c2af931f0d49 100644
--- a/dev-vcs/gitstats/Manifest
+++ b/dev-vcs/gitstats/Manifest
@@ -1,3 +1,4 @@
+AUX gitstats-0_pre20201124-py312.patch 1365 BLAKE2B aaebcd8fbb1b12d4bee2b9902fccb4e69274828956a1504224ba735f0e54c2fe0c1f639f1aa10c5391bad5af1b5d740cc1a9d34f78d1ef8438f19586b39483a5 SHA512 45c01ee73812e299870ce778fa83b5b8cd7bae4be250fa1e2821b1e2a48c5e8ed46c2074f514c909e9f35ccd639c02c2b539fa8f37cc39f3f1128c7ed9ab12db
DIST gitstats-0_pre20201124.tar.gz 37097 BLAKE2B 8ed3f7a157d3a1edbf6f880c491e8b4fec351a0dc3b7212e5bb0eb3e509ae4002fe407267da17bea775d154e38d8ca43eec00e504b614fd8a7d42b6151de43f2 SHA512 98c0a5a67d5daebf951f2e0568182ab65e1077026facc1eef38a35df8411b1356258034fea009c5a15b7e77d17240e02c5a565f0f39d497a45846d5a8cb570ae
-EBUILD gitstats-0_pre20201124.ebuild 1013 BLAKE2B 0ec9c285638f1f502dc211c2aa24987c2f0f681b49bdbd23300964f27d77c98e670efe9223bbf00915b38a914e60c76fcf6df2ba7b8d66a325a387a88d33393b SHA512 18c4cf6dcaea2292b25d0bc0dd2c1d8ccc45ab266fe70f579f540c00bd6a9d9a218845b55dc24d48454bd3a48336b2a721f1dca933bb011b801ca358753a6f83
+EBUILD gitstats-0_pre20201124.ebuild 1055 BLAKE2B a4cfe44b7c428725d8810e51b231e358b15ec195562eb889e1d05c0ba2ffdff7908b86e4da02671a0ab1ec769e2cf0b7b0c75b306722599891234401323a5f4c SHA512 eb554dd52a152e6bfac13fcaecf9f77e8c1d6f0a12c5226e04fc1b22e87a012275d7268504f95410e50544ad7bcbe979708008a5fdc3e6ae880f5b726492cae6
MISC metadata.xml 440 BLAKE2B 520392ad03ea173e2f01774ad3d706ae27036ef8564b1e18ab70d11f735b83797d631003fa8ec19123cf1e4f9452663b2262f112b0063ebccce485244d0df34c SHA512 442983496e87440cdeabd9f1fc0a4de96f2851485e5ed5ea35373734eff6969bc5d26746062e1d078295d1224c4a0b5727838bebb1c155c689eb340af109cd06
diff --git a/dev-vcs/gitstats/files/gitstats-0_pre20201124-py312.patch b/dev-vcs/gitstats/files/gitstats-0_pre20201124-py312.patch
new file mode 100644
index 000000000000..3896fd87e937
--- /dev/null
+++ b/dev-vcs/gitstats/files/gitstats-0_pre20201124-py312.patch
@@ -0,0 +1,44 @@
+From 4743c3fe184ce6e10d145c536af5b3689b069fc2 Mon Sep 17 00:00:00 2001
+From: Bryan Gardiner <bog@khumba.net>
+Date: Fri, 14 Jun 2024 19:13:32 -0700
+Subject: [PATCH] Use raw strings for regexs to fix new SyntaxWarnings in
+ Python 3.12.
+
+---
+ gitstats | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/gitstats b/gitstats
+index 9f14a0f..37005f3 100755
+--- a/gitstats
++++ b/gitstats
+@@ -96,7 +96,7 @@ def getkeyssortedbyvaluekey(d, key):
+ return [el[1] for el in sorted([(d[el][key], el) for el in list(d.keys())])]
+
+ def getstatsummarycounts(line):
+- numbers = re.findall('\d+', line)
++ numbers = re.findall(r'\d+', line)
+ if len(numbers) == 1:
+ # neither insertions nor deletions: may probably only happen for "0 files changed"
+ numbers.append(0);
+@@ -322,7 +322,7 @@ class GitDataCollector(DataCollector):
+ continue
+ prev = tag
+ for line in output.split('\n'):
+- parts = re.split('\s+', line, 2)
++ parts = re.split(r'\s+', line, 2)
+ commits = int(parts[1])
+ author = parts[2]
+ self.tags[tag]['commits'] += commits
+@@ -485,7 +485,7 @@ class GitDataCollector(DataCollector):
+ for line in lines:
+ if len(line) == 0:
+ continue
+- parts = re.split('\s+', line, 4)
++ parts = re.split(r'\s+', line, 4)
+ if parts[0] == '160000' and parts[3] == '-':
+ # skip submodules
+ continue
+--
+2.44.2
+
diff --git a/dev-vcs/gitstats/gitstats-0_pre20201124.ebuild b/dev-vcs/gitstats/gitstats-0_pre20201124.ebuild
index 9dfd0467a905..ce08093e401a 100644
--- a/dev-vcs/gitstats/gitstats-0_pre20201124.ebuild
+++ b/dev-vcs/gitstats/gitstats-0_pre20201124.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit python-r1
@@ -30,9 +30,12 @@ BDEPEND="
DOCS=( doc/{AUTHOR,README,TODO.txt} )
src_prepare() {
+ eapply "${FILESDIR}/${P}-py312.patch"
+
sed \
-e "s:basedirs = \[binarypath, secondarypath, '/usr/share/gitstats'\]:basedirs = \['${EPREFIX}/usr/share/gitstats'\]:g" \
-i gitstats || die "failed to fix static files path"
+
default
}
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 96681b93b40d..c1b1799e9c7d 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,8 +1,8 @@
AUX pre-commit-3.1.1-tests_git_file_transport.patch 1527 BLAKE2B 18d047f3b8a6fdc3da77aa5b8d9f60970ab5b69adc3790489ceffc17839a4cd21ed46428c5e2e98b50278b2c4dc49e35a09dd778000546828327ae96f910f95b SHA512 36cb194250dc0fefad2900452447ab590f678e6cd5edf07a7f072363733c263b7cb1167297c465a9372d4a38ab77a6c057046c66b872a958132a97d1a937d029
-DIST pre-commit-3.6.0.gh.tar.gz 268891 BLAKE2B 42c52bcd320defe877fdce51af972e177e26956c2baba5e04e9441d7a99fcdc6467dc7913b21f9300efe9ca821c7d06c8d972f3fb79f10f2212dbecb3299040a SHA512 4997dfe15d262b8d0c6de711b2543162fffe14f24ce41d3a3ba2014354861ef72eb3a9cc115125ed57ef3c25a12886f858189d684d343252ad8f46cc0c364935
DIST pre-commit-3.7.0.gh.tar.gz 269999 BLAKE2B 9ca1b2279e1ed753a09c3da83f6de19fc9b36821ba6f642962b9be1da29894e3260c48a2cdb582eb5331543fa6c7e9065d799fde7ab4e84dd54032c2ff84e4a7 SHA512 2a238e74ce2f080914e4403b7ce7b8dbd2a257a736d8292e2ec299c8015d3c4611e51f4be1a95ff2bd29db4888f6997e335346931567e943a8b5d78be7c14725
DIST pre-commit-3.7.1.gh.tar.gz 270138 BLAKE2B da21e8c05b722985273554bd455d2ea0c113206eb4924c826532b5135805eca143441a237e516fad1275b4c9886d53cb3757d5fefd53613e1f1a1b4da8d7847d SHA512 ffb7606b1706d5e9f46bdffbe20420e6fd4241f6a402740e02f6d8a0e87f29201a20ab92d89fd7ed77f3df31ada6f157837beac9defab7f35ebabf85d47399e8
-EBUILD pre-commit-3.6.0.ebuild 1945 BLAKE2B 67edbe26415c84be705bdebe1e909951b116cb53b6d9296a7794114bfce325016892d9219c463930eb6ba014ac899e02c2977652d081cce34b685a9afde98566 SHA512 56ef1fc5575dd90736494acdc267355fe30814bc91f190aa306c77aa3247dda2010b42abccd769a19e42b5e1da571b2712df02a81d3bc98860c9c989a1b2c065
+DIST pre-commit-3.8.0.gh.tar.gz 270925 BLAKE2B febb7b6bb2e43aec096e454b064b01b0973cd9d04b2d792a4ce7cef9df4f9c9c2e3bf1200f584e163c829c12ca17f57761375b297ab5c3d97dce569d5c219bdd SHA512 b6970ac00c5033938462675c20ea5e13c0439dc4f70cd627f11b22b0f87fb0a3590e9b3e9c677bfb66e4b3420f40de66ca7ccbc969847ee5fa8994532a558cd1
EBUILD pre-commit-3.7.0.ebuild 1945 BLAKE2B 67edbe26415c84be705bdebe1e909951b116cb53b6d9296a7794114bfce325016892d9219c463930eb6ba014ac899e02c2977652d081cce34b685a9afde98566 SHA512 56ef1fc5575dd90736494acdc267355fe30814bc91f190aa306c77aa3247dda2010b42abccd769a19e42b5e1da571b2712df02a81d3bc98860c9c989a1b2c065
-EBUILD pre-commit-3.7.1.ebuild 2134 BLAKE2B ac4d8ac2977878a3bf1958135f387249683c329ebde3bf98dc9efc3c625ebe8b42a6f8afad96abdfd74ad4ba9f98e2259fb677378679cfc94fd217a090f96cf4 SHA512 116196a6fcba5415f2f1a20a5f9ab83cc9d76301d11ec62d812834e5230015224df9ad823af66143c7455244892ba79b7a56eef6ca141ace6c93b80386e0b5e5
+EBUILD pre-commit-3.7.1.ebuild 2132 BLAKE2B e30f0fcdf0327f291bde8a0d06ca31fa1b2a1586ae32654c88f1a39197055bed1e7b7c8c3890b843546b63c0871a3c748cf47f56a0623835eb1eb7da50fef4d1 SHA512 fb1bd07604a887da9afa1a6d593a76dcd458fac42c05f4ed8143e3e9b8c143e9da0561fa2f146644baa66b2a795ea8d947ef304a7fec989f787cba3dc30adf17
+EBUILD pre-commit-3.8.0.ebuild 2134 BLAKE2B ac4d8ac2977878a3bf1958135f387249683c329ebde3bf98dc9efc3c625ebe8b42a6f8afad96abdfd74ad4ba9f98e2259fb677378679cfc94fd217a090f96cf4 SHA512 116196a6fcba5415f2f1a20a5f9ab83cc9d76301d11ec62d812834e5230015224df9ad823af66143c7455244892ba79b7a56eef6ca141ace6c93b80386e0b5e5
MISC metadata.xml 391 BLAKE2B 08aea5db96326e51f252d2392f655100d2721dfa8eedfbb361221d92b0b0e0645152b8e1c2ccc11e8b50f24b59869fa2e1fc7dfaa42fdb23614ddbc963e9f102 SHA512 799e0df03afd4baef6296590b9133b45487d1e41f09e933a738367f0bcb3c6510ec8e26547b16ea5c07525d99b026ba1848d21e4001505c33a564b14746897c6
diff --git a/dev-vcs/pre-commit/pre-commit-3.7.1.ebuild b/dev-vcs/pre-commit/pre-commit-3.7.1.ebuild
index 88174070951e..078bf861234b 100644
--- a/dev-vcs/pre-commit/pre-commit-3.7.1.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-3.7.1.ebuild
@@ -22,7 +22,7 @@ else
SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
-> ${P}.gh.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm64 ~hppa ~ppc ~ppc64 x86"
fi
LICENSE="MIT"
diff --git a/dev-vcs/pre-commit/pre-commit-3.6.0.ebuild b/dev-vcs/pre-commit/pre-commit-3.8.0.ebuild
index 90ea7eb7e160..88174070951e 100644
--- a/dev-vcs/pre-commit/pre-commit-3.6.0.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-3.8.0.ebuild
@@ -3,55 +3,71 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL="ON"
+DISTUTILS_USE_PEP517="setuptools"
inherit distutils-r1
DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="https://pre-commit.com/
+ https://github.com/pre-commit/pre-commit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ~hppa ~ppc ~ppc64 x86"
-RDEPEND="dev-vcs/git
+RDEPEND="
+ dev-vcs/git
$(python_gen_cond_dep '
>=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
>=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
>=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
- ')"
-# coreutils requirement: see Bug #885559
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
')
+"
+# coreutils requirement, see bug #885559
+BDEPEND="
sys-apps/coreutils[-multicall]
-)"
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ )
+"
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
-)
+PATCHES=( "${FILESDIR}/${PN}-3.1.1-tests_git_file_transport.patch" )
DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
EPYTEST_DESELECT=(
- # All of these require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
- # and while some of them do include "skip if not found" logic, most of them do not.
+ # All of these require a boatload of dependencies (e.g. Conda, Go, R and
+ # more) in order to run and while some of them do include
+ # "skip if not found" logic, most of them do not.
tests/languages/
tests/repository_test.py
+
# These three consistently fail with
- # Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+ # Calling "git rev-parse" fails with "fatal:
+ # not a git repository (or any of the parent directories): .git".
# including with the sandbox disabled.
tests/main_test.py::test_all_cmds
tests/main_test.py::test_hook_stage_migration
tests/main_test.py::test_try_repo
+
# These two fail if pre-commit is already installed (Bug #894502)
tests/commands/install_uninstall_test.py::test_environment_not_sourced
tests/commands/install_uninstall_test.py::test_installed_from_venv