summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-08 19:07:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-08 19:07:58 +0000
commit8edd4a48a39640822abe6ddb7b2a1d5b2da4ea70 (patch)
treedd40a3ea9cdcc06c8c63bd2ee71c2c2c0ea11549 /dev-vcs
parent7825305c5ddf11fffe24fa30453c4e8468f64305 (diff)
gentoo auto-resync : 08:03:2024 - 19:07:58
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin11504 -> 11503 bytes
-rw-r--r--dev-vcs/git-big-picture/Manifest2
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.3.0.ebuild41
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index 09cad777ee70..a42ac671f475 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
index 8f2adc38e127..8ea2af0bd4e1 100644
--- a/dev-vcs/git-big-picture/Manifest
+++ b/dev-vcs/git-big-picture/Manifest
@@ -1,5 +1,7 @@
DIST git-big-picture-1.2.2.tar.gz 2964564 BLAKE2B 39971b21a9c9a0a8d1bf41f37350a158b634d2eaa0add460c1c18b70f643ab226736d53a337d4ed2583903a5d6c3188ab7a1b06f48a3f354e28d57ec74441599 SHA512 62c43727bb688d6572e7caafe9c5da3b782504738dd0d83d5df675ba757e8be22a8630ec1863c07f0fd2e54549b2ccbd1250ba8f367a6f840afa7b8962c487e8
+DIST git-big-picture-1.3.0.tar.gz 2965335 BLAKE2B 07e7485259c63d4826bc73280d41c4f64abf526f817213f81d8de5318cbdae6b348589028b82c961b06806137cd6dd265bfb0ff4df55cd1eeb418cb7bd7b8f67 SHA512 8e0a6c821308fe54b2924b6dd1f7294f205e301c20cb9d43837a16e9b2848a5476497e3868b3b96e512f3b8cf8f20639f07932b26f3507d77a2a9bae01707de7
EBUILD git-big-picture-1.2.2-r1.ebuild 946 BLAKE2B d13138ecce59bd926e705a0dc804929e50c6b8f0bb7a4097aa506a07ffd94c602e4cca31d2fb4a810176fb8d255a3949fcc1343afa59fc935340f2534e333e4a SHA512 ca6c462dff061ad399c1a5324c4ee62b6ef7cbfee6f81f21e3e449cc174b57d901e4879997c6f44e977a7cdbe962130cb9c32cc916f405cb879d7f7ac90f6625
EBUILD git-big-picture-1.2.2-r2.ebuild 971 BLAKE2B 9018a6dcdb2a9261c3491a509f979c0602f516070848300c37e79c1bd728dd19c25305abb5e4b429ab98542854e328b50fb9a8db2287eaeb3912d4aac9b36f12 SHA512 338de26ef03ed0b400aba478cd6eba55c4d227b4a0aec37c5b83198e30e3f7127e55d79c4cb4cac85680524de898009d352cc223ce77f3ee2f7f440f90223362
EBUILD git-big-picture-1.2.2-r3.ebuild 972 BLAKE2B 65b679f7a851faea0f31966115be4ae024559b2f309d5ec4b27c4ef9b89ddf848a9be446fc2a27ea44ed259fe5547a7f32d26042fdfea7a419bacddf39126908 SHA512 b79a5a16c04b9346c031d1faad5fc0171d91a8c1323e18d5e85a2e742913ab7db73d706578e2e2415d65a9597dcadf8b074195ad700af31326545b18d914a5c1
+EBUILD git-big-picture-1.3.0.ebuild 984 BLAKE2B 962d55b0d04f3eb756681ac3d3b5c7b6e3784f1f818a6aefbb6ab658f5dc1e0d8dc6ba446e38c22d185e2e0b237751ee1848c11f54908facf792fa570080eeaf SHA512 fd1a507e4185d23d94f45bfcb4efadeccafb297cba56b42ee6c78eb34bbd97aa7acc5402be2a2b548f7f05e2de8e1bf225e246808a8891b298f3f2496607128f
MISC metadata.xml 399 BLAKE2B 5e912fe66108f5588e14b1766b905e2c19aa6bc8529ac855be153efa928222bd455eec6c21cbefbfa62fa005732356f0368b47eebd4bb91cfbb77ba427dbe356 SHA512 790e96e16572a401754dc67f30fd2bca0a1cf11ef95afca4cab8379fc1b2684389a73ce118e05c062c9ec768c0098240ab7ec1cda40e7ed1a81c0a3525ea1ba3
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.3.0.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.3.0.ebuild
new file mode 100644
index 000000000000..c0662dc77cf1
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# NOTE: dev-util/cram explictly does not need [${PYTHON_USEDEP}]
+# since test.cram is a shell session and not Python code
+DEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram
+ )
+"
+# NOTE: No need for "[python]" or "[${PYTHON_USEDEP}]" with any of
+# these since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}