summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /dev-vcs
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.7.2.ebuild40
-rw-r--r--dev-vcs/hg-evolve/hg-evolve-9.0.0.ebuild39
-rw-r--r--dev-vcs/svneverever/svneverever-1.3.2.ebuild20
3 files changed, 99 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/git-lfs-2.7.2.ebuild b/dev-vcs/git-lfs/git-lfs-2.7.2.ebuild
new file mode 100644
index 000000000000..ed1c9a5d2cb1
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-build golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-build golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+DEPEND="doc? ( app-text/ronn )"
+
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ golang-build_src_compile
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin git-lfs
+ use doc && doman docs/man/*.1
+}
diff --git a/dev-vcs/hg-evolve/hg-evolve-9.0.0.ebuild b/dev-vcs/hg-evolve/hg-evolve-9.0.0.ebuild
new file mode 100644
index 000000000000..a89ef7e4eea3
--- /dev/null
+++ b/dev-vcs/hg-evolve/hg-evolve-9.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="enables the changeset evolution feature of Mercurial"
+HOMEPAGE="https://www.mercurial-scm.org/doc/evolution/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-vcs/mercurial-4.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_prepare_all() {
+ rm hgext3rd/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r html/
+ fi
+}
diff --git a/dev-vcs/svneverever/svneverever-1.3.2.ebuild b/dev-vcs/svneverever/svneverever-1.3.2.ebuild
new file mode 100644
index 000000000000..3366239c35e0
--- /dev/null
+++ b/dev-vcs/svneverever/svneverever-1.3.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Tool collecting path entries across SVN history"
+HOMEPAGE="https://github.com/hartwork/svneverever"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/pysvn[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"