summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-vcs
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin13618 -> 13802 bytes
-rw-r--r--dev-vcs/hg-evolve/Manifest3
-rw-r--r--dev-vcs/hg-evolve/hg-evolve-8.3.1.ebuild39
-rw-r--r--dev-vcs/hg-evolve/metadata.xml10
-rw-r--r--dev-vcs/hub/Manifest2
-rw-r--r--dev-vcs/hub/metadata.xml4
-rw-r--r--dev-vcs/mercurial/Manifest4
-rw-r--r--dev-vcs/mercurial/mercurial-4.7.1-r1.ebuild2
-rw-r--r--dev-vcs/mercurial/mercurial-4.7.2.ebuild2
-rw-r--r--dev-vcs/qgit/Manifest5
-rw-r--r--dev-vcs/qgit/files/qgit-2.7-highdpi-support.patch51
-rw-r--r--dev-vcs/qgit/files/qgit-2.7-qt-5.11.patch24
-rw-r--r--dev-vcs/qgit/qgit-2.7-r1.ebuild32
-rw-r--r--dev-vcs/qgit/qgit-2.7.ebuild27
-rw-r--r--dev-vcs/stgit/Manifest2
-rw-r--r--dev-vcs/stgit/stgit-0.19.ebuild83
16 files changed, 142 insertions, 148 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index bb7dbbf64434..10733e0268b9 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/hg-evolve/Manifest b/dev-vcs/hg-evolve/Manifest
new file mode 100644
index 000000000000..f0c947a20608
--- /dev/null
+++ b/dev-vcs/hg-evolve/Manifest
@@ -0,0 +1,3 @@
+DIST hg-evolve-8.3.1.tar.gz 732554 BLAKE2B 8b93609dab6d2cefd450064e2eb50109cc6184cd5c72452c1eaf3027649b40add283109ede9ba05bd0e7710a53ec7424335147c01fae9384445360bec8bbdf89 SHA512 05fe8dffe624fa32d913f02a801e4abbffe83a6d1fe7589e9fc76c62d504c23942080dea278024eafccbfcfdb17e59ae75f4ebd5afb7838676015fa99deb894c
+EBUILD hg-evolve-8.3.1.ebuild 749 BLAKE2B 169226b35c8bd4a7c061b51b85b309b8fbf67fcf7977d1a9d22f7c66d28c448a4388d753f9c7876cd49acecd5b626a2d1918573917b90d9e386e3f537d93f171 SHA512 76922991a5290ab3bc524ffbc28e57cadcb76d709b0a55d6b0d83ce9606609e4d1447afa5b997903b261336f10dad7def6a7bd5a133effd590773250a44fdc79
+MISC metadata.xml 323 BLAKE2B 960bd09bae7474d94c2d986fe304708d0bf4f4bbd6deed930a539d521f20bdd6664934ac2999dab925fabd9ab4e298a343405d976a8bb6865e6be8aed7eb11d2 SHA512 92404b3c82702ad0876850c003dddf1dcb01cb03e4b573cd0e04dc276db0a89adbc5f83f8fcab0ff5e7bfaf767080d8b41a2916aeeed6e7f70afab477a67c63a
diff --git a/dev-vcs/hg-evolve/hg-evolve-8.3.1.ebuild b/dev-vcs/hg-evolve/hg-evolve-8.3.1.ebuild
new file mode 100644
index 000000000000..018094011080
--- /dev/null
+++ b/dev-vcs/hg-evolve/hg-evolve-8.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="enables the changeset evolution feature of Mercurial"
+HOMEPAGE="https://www.mercurial-scm.org/doc/evolution/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-vcs/mercurial-4.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_prepare_all() {
+ rm hgext3rd/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r html/
+ fi
+}
diff --git a/dev-vcs/hg-evolve/metadata.xml b/dev-vcs/hg-evolve/metadata.xml
new file mode 100644
index 000000000000..b5f8063588b3
--- /dev/null
+++ b/dev-vcs/hg-evolve/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cedk@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ This package supplies the evolve extension for Mercurial
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-vcs/hub/Manifest b/dev-vcs/hub/Manifest
index 413c4aa3d02e..dd42703e2339 100644
--- a/dev-vcs/hub/Manifest
+++ b/dev-vcs/hub/Manifest
@@ -1,3 +1,3 @@
DIST hub-2.2.9.tar.gz 318275 BLAKE2B 731c3bb4cc4d92082f93bba94a5cc7ba31fc436479655fa19ffa8078416cedd814d2667589af9d6eed59a0be0c8b38963779429838d8dbaab8a628f838a5915c SHA512 69d69683eb5f1c881b15c9b3294878c35edc51f9b7d568a3e0609c3d77cebf5c1be5c7c018b0356bdd68cf3f56691a860381a53f3e016b28b9f95ab0b852d9f9
EBUILD hub-2.2.9.ebuild 905 BLAKE2B f71ee495cb55cf5a7f64f643f7a8e79a9604f4b7dffeb94226bf3feda1759667e5d93d645239c6ad3a97e3ea2ab1c75be2d3e1aeddda59e400199ec7e37d0208 SHA512 51c336022318210fe0a37615f92f61842da7a2d4d76005c61d5b86ebdc5f0f44dbf47874f2811f6f7870cd592bf118545c48c7e32c02a11dfcd40c26050e45dd
-MISC metadata.xml 459 BLAKE2B ea97b6ea14e01abac1128117c1fd4a3b500e58c7821584de640c32168319a0fbd5c431f139e624a372866e845d3c4c8d09bb4aee68f42103ebe5e174641b1eb8 SHA512 2f87715926a447fc6a3a036a713a054f785d3918b40ef2502940a99afeb8f897402bb7698a05ffa26f1e99704f6dcadac8f41d5bea2b6c7ba41a58b9e4c3dc53
+MISC metadata.xml 339 BLAKE2B 3d41b73f4895b4a644e27d91fe3ca4e4b139a1ed65606feb2bd07e900d82ba2db79a524bbdbcb8f0f3cd701c5b2a49ef38c1492218f9c0ba8ffc84766f30d914 SHA512 9beed675598c4d8591b5f6a18030e84db9e211b445c221fb979fdd2a9c7d6b44de098d03a494fb2633a26bb0f57c8b44a427f34325fd74db39504ef96dacc7c2
diff --git a/dev-vcs/hub/metadata.xml b/dev-vcs/hub/metadata.xml
index a0b5847fbe06..6b740fb77166 100644
--- a/dev-vcs/hub/metadata.xml
+++ b/dev-vcs/hub/metadata.xml
@@ -2,10 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>vikraman@gentoo.org</email>
- <name>Vikraman Choudhury</name>
- </maintainer>
- <maintainer type="person">
<email>junghans@gentoo.org</email>
<name>Christoph Junghans</name>
</maintainer>
diff --git a/dev-vcs/mercurial/Manifest b/dev-vcs/mercurial/Manifest
index 72600c408c12..e674470170bd 100644
--- a/dev-vcs/mercurial/Manifest
+++ b/dev-vcs/mercurial/Manifest
@@ -7,8 +7,8 @@ DIST mercurial-4.7.1.tar.gz 6480135 BLAKE2B de34cdd34d5fa2a6f4e1f24730c99b5764b9
DIST mercurial-4.7.2.tar.gz 6481684 BLAKE2B 1006e541b52148f44b14767a738f4add4d03c719bc6f96f3f245f6bfd401223b1e7444216304fba749b88611cd031cb14089d9938a5533477160226286dd401d SHA512 e8742e9555a6b57e96e61091757b4bcb574605c49082874bd4edb9114a70e5cb024c1360a75c24f1a9ae3bca3205316e6a264ae18d3c9946248bc1d2b042ad43
EBUILD mercurial-4.5.2.ebuild 3536 BLAKE2B 6ad1f105178987b408397b9593ac8c980435363597625402a0e67afdc10d55cc4477ca85dea764d860cecdb8bd68ee13afc66cf6203ae96f1a3b5363b93e0e74 SHA512 766576864da5700f107a530f1a06fbf33d1d593597ad236ad841d3ba59774c4aedf3e43dda00a86b1894f99c03f7af228d8026363d81a2c3b0b8ab98f22c246a
EBUILD mercurial-4.6.2.ebuild 3537 BLAKE2B 7f4c2e4c579ab768dd629d53b2fdf1062980405242376c727b05a8a474d6bc8afb4db0f82e22252dde24b6909f9ab87d8650ed73600e6dc01ae4ef2fdcfc71cd SHA512 1549175116f2496ae8bac35360b142c9ae95d458b764496648eeb9165fd79fd030bfcb0386df61a568a7d8536f8e846a9b127f22fe2937ccac5982135e89cf14
-EBUILD mercurial-4.7.1-r1.ebuild 3645 BLAKE2B 0a89f10a7205aaedd01be6efc216f7b6e3a9da54d02ff1d32a9f3b7bdfd2eb1491a854c2ac7447f43da71a8d045aaf48f811ac28458208c85a57d8834b72a55f SHA512 06d522f750227739d3f283a3805c92da5f42709cb289a543cdb319e6f386b990439086925015a7ab14b02dfe4e55914446b42de4c89f53e124693cfc2fcb8e91
+EBUILD mercurial-4.7.1-r1.ebuild 3652 BLAKE2B df9c9e9124b3553912e333facfa872fe4f99d0b53dec7442f4629af5670728920bb85b87cbb02c72c9a0a6fb1c3ea644b7f8d8b92b07372f21efdb8ef831fc0d SHA512 a6d70c84d5a93bc5b5d796919c2aa4b0a7ca6140e0fd91c40ec3ed9c74bd1ca847326a3a5fbbcc8208c4e00aff1c3601085391e548b512ab3fc5b8fd39ec5673
EBUILD mercurial-4.7.1.ebuild 3493 BLAKE2B 9145b0af45da7e9ec4f78e470928a77f0a6aa553283873e406a07940221d386aa95b4b43c0c1a79930d447fd215bcdf8422494e1e6e4f94bce8399d363050011 SHA512 00baba63605300fa052f578186a2e061d98058b59d75b2ed5394af398c8afa86209f450612ea3d39bc3da17111dffea5bd6bb02ddcd21d47f32dc0ec86f937a2
-EBUILD mercurial-4.7.2.ebuild 3758 BLAKE2B 7ba054412e16e6b2966a4152e8821e01f5541d49f4a8f31455bfa4e0cf45ab3f329cfc64e5d0a75f8bca86237bc692033e9f350575d3840fd75f8f8a301822cc SHA512 809dee48bb4d6f2bc1ce7925eb31d6709f15df740f13070872b23ec71e9a85f39d8aedb254c09cbca63e206b6ff38244109c82e390484a873f0d201ed6224ef2
+EBUILD mercurial-4.7.2.ebuild 3765 BLAKE2B 9137eb5e7fee6a5a3d10ef6839fa8277f83cebb0013599d6688aeb4c56dcc76ab3d80ab91c48a19e82d31dd74bbee26c70d30928293257b2792955f4e46e948e SHA512 a12be602080e091e040f7cae1226faaebc46ff041d0c59b6b9cdd7cd6456d8168c02914411bfe888c746acebd5112237f93ea2c7c3bd6da70cd8923f7f240a67
EBUILD mercurial-9999.ebuild 4131 BLAKE2B 55328bbb7ccca04843b595d18c44dbbf5a51e4808a4e9d517355c38f89270551017fdeca45471972210e7246aa970dfa4ae4f5951cd4ff5d33e9ae696ef45b41 SHA512 0f6ee4a02c89c9e08e0a18e1f11169836eb336cf18af01df22d0a8b189c8fa61f0de5fd0b28105f83df55b23f840ad4ea934fac779c64ba5156c042106169c08
MISC metadata.xml 456 BLAKE2B d824c2b22d9785c268cfadaa4456794cf423ef6df69767577c4df16e6cebe3bc3c02f40ec7dd799eaaf6bac5754bee28b6b923b11d40f628fcb4a4f85a849de9 SHA512 2bf62b3a98e71ff5acba09c06cc1f29a2cb24d6634a384ff800bb10ab6f5de71a5db440b0fa8a5183db95eafc6ad98444a817c23887baf0dc59f6260402574b1
diff --git a/dev-vcs/mercurial/mercurial-4.7.1-r1.ebuild b/dev-vcs/mercurial/mercurial-4.7.1-r1.ebuild
index 17e3450e659a..57d23f39153f 100644
--- a/dev-vcs/mercurial/mercurial-4.7.1-r1.ebuild
+++ b/dev-vcs/mercurial/mercurial-4.7.1-r1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bugzilla emacs gpg test tk"
RDEPEND="app-misc/ca-certificates
diff --git a/dev-vcs/mercurial/mercurial-4.7.2.ebuild b/dev-vcs/mercurial/mercurial-4.7.2.ebuild
index 60e5ed59b655..03aa5b03efb2 100644
--- a/dev-vcs/mercurial/mercurial-4.7.2.ebuild
+++ b/dev-vcs/mercurial/mercurial-4.7.2.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bugzilla emacs gpg test tk"
RDEPEND="app-misc/ca-certificates
diff --git a/dev-vcs/qgit/Manifest b/dev-vcs/qgit/Manifest
index 735683605b18..f8f9892f2e3a 100644
--- a/dev-vcs/qgit/Manifest
+++ b/dev-vcs/qgit/Manifest
@@ -1,8 +1,3 @@
-AUX qgit-2.7-highdpi-support.patch 1558 BLAKE2B 0dcf7aedacbb054bbb2868aeb69835c6b091d9a5c54e4937eb49fca5a7cc183fda22a9eb5ac1125ad2831c1ed59d1724090816be16f00b607671c2f1c66d88c2 SHA512 179e58795c6023b3f344ed7a5f03a36d38f0e1e364fe497608a2651f0c71e30cf56de934f48ac437c0cf0794b50e7673ae9199e231e533324c87d65706401817
-AUX qgit-2.7-qt-5.11.patch 590 BLAKE2B 42d45014c3f630d72509a79f598945b4ebc253d0c89f36fd09560b9e4aff5cd71863e68a9915a08dc0ccde98ab50de50a71b1576556d81f0ec276044486e4e8f SHA512 46360172f9d22927910f6f238c0963c6cf9c55909d53944583b2c1316484fce5c21f7f76797bd8a43a0bdb2885239dd1940b71e8a08800666ec9de436a100f48
-DIST qgit-2.7.tar.gz 259624 BLAKE2B 48c5b7bd7da6b037b4be103a7de32375128311200ab98956edb1ac269fd46d6f4ec93049d86ce92fa009999e87bb8df6706f44847f795d993c829ee9d117ce69 SHA512 024fd825aaec64301f0bcbe0ca1d02eb8da0d754d79d09075b1cd87a507d44c97092b824949f2637b37f0e71b36723cad6963cd00dcb2f7597832aba3a5ab842
DIST qgit-2.8.tar.gz 260236 BLAKE2B eb6dfc83891a8598c31c4711dfcfca1952abfdd8d2e54ce295260674b63bb90ec84fc582f8b045342640e3aed1aab0f000ec89e47a9147e98d1274540a744b2e SHA512 9845064a3f0b2e48b7bb1cbe8f252eaa4e4174cfd2e270ba6c746f0200847ee4d3cdded7f9550849743781669bd7f6f1afe1e83a918b2863a915876b27a3e42a
-EBUILD qgit-2.7-r1.ebuild 605 BLAKE2B af3a5c65f6852b68af8cf99ecd36c49ef33cef461f0e0cd6447bcc68cbbb64857198d80589e1ae2a9576c7fbd4b0a077eff6abcc1da9902608174f90030fdb06 SHA512 6d85689071c4ea8550e7d8308b21ea6ddc449cb3f63628234361312caac0813af0cfefc5f87f4ab0a78e09f9a846f047d11069becc2192cca04d8a8ab63310d5
-EBUILD qgit-2.7.ebuild 514 BLAKE2B a87270e53ba783cf6c30a9d80a34988d15e9fe8f5ac988e31afe7aea94b645dad99e460ca4c97fe4b5e40398d3f226a3801d9c36fccc0eb263b2b5a542018c7a SHA512 333220a77d749fb3ee5f32a845acebf30a69247c7605237e8a5f27d21fc6ea9fe611f5ff5107f44c3585cc9fb540d5ee8d18f4a16b8ca87472a61f00669222a2
EBUILD qgit-2.8.ebuild 497 BLAKE2B 172e0b528fb09725d91d583d7e448c1190a70c3520616bcdf16c42ed47d527ac6ba910a1457d4fc363245b944ee846abccdd7fe82c0a8f8c56b6a55fab3277c3 SHA512 4690a884bdd5b5abf605c1c76e242437b6477c9323ccfeda5c0c295959832b19dd251f0085027e28b3753b259bd48d8413de50c93b3d115b1ba5b098aa4a5154
MISC metadata.xml 324 BLAKE2B 1046f76dc321a6155b49edb4972d9d353d47e4103a0356cc83f459faac05985e201daef4197420cadb19f50c37eb528b990c8d9d93537822fbf0698501b3fb5c SHA512 e4e0bbc60b8af9512584b93e60d29ac47a4150691ea46bb3281c6d99acf119d0c6717497286c324a9ccc91624bbd56211a513c1fd675ec89603d431b9b052248
diff --git a/dev-vcs/qgit/files/qgit-2.7-highdpi-support.patch b/dev-vcs/qgit/files/qgit-2.7-highdpi-support.patch
deleted file mode 100644
index 17f940aa23b7..000000000000
--- a/dev-vcs/qgit/files/qgit-2.7-highdpi-support.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From e60ae49271e06384163afa1ebd1e562eb7c520ed Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Thu, 15 Feb 2018 17:39:22 +0000
-Subject: [PATCH] Add high DPI support
-
----
- src/listview.cpp | 11 ++++++++++-
- src/qgit.cpp | 5 ++++-
- 2 files changed, 14 insertions(+), 2 deletions(-)
-
-diff --git a/src/listview.cpp b/src/listview.cpp
-index dd6a8cb..e4f094e 100644
---- a/src/listview.cpp
-+++ b/src/listview.cpp
-@@ -884,7 +884,16 @@ void ListViewDelegate::addTextPixmap(QPixmap** pp, SCRef txt, const QStyleOption
- int pw = fm.boundingRect(txt).width() + 2 * spacing;
- int ph = fm.height();
-
-- QPixmap* newPm = new QPixmap(ofs + pw, ph);
-+ QSize pixmapSize(ofs + pw, ph);
-+
-+#if QT_VERSION >= QT_VERSION_CHECK(5,6,0)
-+ qreal dpr = qApp->devicePixelRatio();
-+ QPixmap* newPm = new QPixmap(pixmapSize * dpr);
-+ newPm->setDevicePixelRatio(dpr);
-+#else
-+ QPixmap* newPm = new QPixmap(pixmapSize);
-+#endif
-+
- QPainter p;
- p.begin(newPm);
- if (!pm->isNull()) {
-diff --git a/src/qgit.cpp b/src/qgit.cpp
-index 266a7b8..b01c49e 100644
---- a/src/qgit.cpp
-+++ b/src/qgit.cpp
-@@ -18,7 +18,10 @@ using namespace QGit;
- int main(int argc, char* argv[]) {
-
- QApplication app(argc, argv);
-- QCoreApplication::setOrganizationName(ORG_KEY);
-+#if QT_VERSION >= QT_VERSION_CHECK(5,6,0)
-+ app.setAttribute(Qt::AA_UseHighDpiPixmaps, true);
-+#endif
-+ QCoreApplication::setOrganizationName(ORG_KEY);
- QCoreApplication::setApplicationName(APP_KEY);
-
- /* On Windows msysgit exec directory is set up
---
-2.15.1
-
diff --git a/dev-vcs/qgit/files/qgit-2.7-qt-5.11.patch b/dev-vcs/qgit/files/qgit-2.7-qt-5.11.patch
deleted file mode 100644
index a92e1e50f726..000000000000
--- a/dev-vcs/qgit/files/qgit-2.7-qt-5.11.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 563bc3ab3f928a3ba1c22e5e62ab8cbe15c6bc15 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Tue, 17 Apr 2018 13:28:19 +0200
-Subject: [PATCH] Fix build with Qt 5.11 (missing header)
-
----
- src/patchview.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/patchview.cpp b/src/patchview.cpp
-index 5e3765d..afa796e 100644
---- a/src/patchview.cpp
-+++ b/src/patchview.cpp
-@@ -6,6 +6,7 @@
- Copyright: See COPYING file that comes with this distribution
-
- */
-+#include <QButtonGroup>
- #include <QScrollBar>
- #include "common.h"
- #include "git.h"
---
-2.17.0
-
diff --git a/dev-vcs/qgit/qgit-2.7-r1.ebuild b/dev-vcs/qgit/qgit-2.7-r1.ebuild
deleted file mode 100644
index b7930738acae..000000000000
--- a/dev-vcs/qgit/qgit-2.7-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Qt GUI for git repositories"
-HOMEPAGE="http://libre.tibirna.org/projects/qgit/wiki/QGit"
-SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
-"
-RDEPEND="${DEPEND}
- dev-vcs/git
- !dev-vcs/qgit:2
-"
-
-S=${WORKDIR}/${PN}-${P}
-
-PATCHES=(
- "${FILESDIR}/${P}-highdpi-support.patch"
- "${FILESDIR}/${P}-qt-5.11.patch"
-)
diff --git a/dev-vcs/qgit/qgit-2.7.ebuild b/dev-vcs/qgit/qgit-2.7.ebuild
deleted file mode 100644
index 9ac66aa17552..000000000000
--- a/dev-vcs/qgit/qgit-2.7.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Qt GUI for git repositories"
-HOMEPAGE="http://libre.tibirna.org/projects/qgit/wiki/QGit"
-SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
-IUSE=""
-
-DEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
-"
-RDEPEND="${DEPEND}
- dev-vcs/git
- !dev-vcs/qgit:2
-"
-
-S=${WORKDIR}/${PN}-${P}
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index 0dfd8b2acc67..c32c74ef6e90 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -3,6 +3,8 @@ AUX stgit-0.16-man-linkfix.patch 429 BLAKE2B 11cd98b7a58a55fed445be700bc492a4fd9
DIST stgit-0.16-missing-patches.tar.gz 1667 BLAKE2B 3aa26305b948c49bde0aec71e9698f9c1822c26e1f15ceba99c4725eaa35eee6a7a5335f0bfe6e43e89be62c304e1eebe2ffdaa0a5b7fdc0da3e13244505abaf SHA512 29d4c3e68121654153b4e5142dd70d818737b09bbc8371d644a36dd9d18afaf78fdda91bc16f953c330bcbae19084384d8bcd216cdfe674df784e33165186db1
DIST stgit-0.16.tar.gz 362687 BLAKE2B 4d6579d39d8a22929d70268ae07bf7c5ac17eae21c615aac0ae8e9adb146aa87a3f7d1b057fd7269175c363ef5057f4ce24f6ef1087f54dfb1165f2800a813cf SHA512 782de3d5855aad4f5d040478745990517ebe2b26dc315a3ed41db95399bb46e075d63a70baa0e3aa2ab1012b59e6ad1f5940a904f296ef09d6bca60f66e417dd
DIST stgit-0.18.tar.gz 235852 BLAKE2B ff35856c1f20a6a611a2faa22ba573b1c33636c9e913322456011c4c5a73c3207ddbd8bfe41cb81b11dffe8db8b89594c1598989ae9fb896cd686594a21d96b2 SHA512 5820cc1a8cdd5183fbe309b4b80568098844ff57934c75a43263b5cfcdac4b64e015abc9ed6a53dd856236d76bd0ebeec31e87561bca0d0d82a6e5ec7a10745f
+DIST stgit-0.19.tar.gz 246256 BLAKE2B ece625a0f78f4a80a9a20b25d0638ee71475029ebd861b28dccc444a70d631e687372031c2dee03faebc8890b8742674d6fd7c2ee1794e8a2d7044721a254847 SHA512 0edad0c600145fc779262ddae4300d4718fd04316face62cb1fb5c01e39cb0824355091863aae8d5b14bee9ebb36ac591e5e0dc9fe343c12a7c781227cac6330
EBUILD stgit-0.16-r2.ebuild 1732 BLAKE2B 2be40c1d991060b15413ae0c718b7b8793c1f8458fa0c52fc45e2e62568566975ac2c15c12b1f8065b475d9753f39dd92ae8095ee8c971c638d008da64ab82d3 SHA512 015a83ab10571d9000f0394c2173a56feac071ca6680ec9b4ee6b6e7c4be3a6e098a231be71bac87ddec9dfc415808f0a86dd30c4bb142493358d8558810cc0a
EBUILD stgit-0.18.ebuild 1883 BLAKE2B 1ccceee2fb9c6b039ac956ef85444fdca246aacb75ff5a55c6351faf909a09d6148b173eba6cd7c0b0b5f54271050b83cd059979619036b9eb703c8c8b2de837 SHA512 2557043aa518718bc489ac2004a69f155a913c9bc38520cfec8c22daf2629a76d14baf6bd4cf8fc4ade0c2ee0c35974f5f33c5bc715aee1119791d26dbe7224e
+EBUILD stgit-0.19.ebuild 1901 BLAKE2B a1de9f4320ba6f5c6b626c5bd256d1e1187b8d05714246b4817738ddf993971200c071d427aef2c038f6d7bebaf14f160845837ee9fb5af49ac38538726e2388 SHA512 2f7d22cbaba918cc475fe5621b4b31d37b1bce0d026391386f17aa11c5f0051b06579573b9f68d1079f546f941cdf9e9f762ab7958d782af4afda1b14101611c
MISC metadata.xml 240 BLAKE2B bd240e0175a0c9b3a954ded560844811f58403fcf0fd6474dde32d571e7c3f22424ae8de719a4adad492b6d5f4df7d3198f5a5f65f2c21ca8f05274a9f979f85 SHA512 923a0a24ce7efb7b5c6e6561521def809a20d77a8dca21ca55c1bd8e0e34139c0d5d6ec683180f0b97ddb809ea124765eba82f1135abe08c93f4dfb353d18da8
diff --git a/dev-vcs/stgit/stgit-0.19.ebuild b/dev-vcs/stgit/stgit-0.19.ebuild
new file mode 100644
index 000000000000..cba2edd82da2
--- /dev/null
+++ b/dev-vcs/stgit/stgit-0.19.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.16-man-linkfix.patch"
+)
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp stgit-completion.bash 'stg'
+}