summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 10:16:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 10:16:02 +0100
commit02fbebe9426ee05ab39e9b5a56e3529e64160ef6 (patch)
tree4c2a5db6966711f46fbc73aece931b17625e27b7 /dev-vcs
parentb052fbf151106a4f47cac7fdf0ffff983decb773 (diff)
gentoo auto-resync : 02:09:2022 - 10:16:01
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin11160 -> 11159 bytes
-rw-r--r--dev-vcs/pre-commit/Manifest4
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.19.0.ebuild52
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.20.0.ebuild2
4 files changed, 2 insertions, 56 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index 5540ef345a30..7586e15b37c9 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 02b712248174..eba830d49063 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,5 +1,3 @@
-DIST pre-commit-2.19.0.tar.gz 266117 BLAKE2B d2105fb9aa64e63c7d93142228545e3597eb4a1637f850ce5d3f14b0826bdfb8a8d971779690c4fda6823fa1915fc57f9c86b9ffae48dbe39e7a225123304f5c SHA512 9cc28c5e9ce4be87e09e7be01138c35bbe954efb6c1400e92b1a6b5f50e426b59d74651802359015840d5ec4a5583bf8f579bf7f08eb778d5950c8c8dfe4c80c
DIST pre-commit-2.20.0.tar.gz 266604 BLAKE2B 470f032e6d5bfcdd9ac8ba8f37d4323b601da0c82bcd524ffc575dc688fe81ad326a1f6a8ddd03da6e37130319ee40070c03d9789cd6e0e4b427a1d6e646416e SHA512 b1da558a0e5d8f2f655427089f1d0b11b01ad7513ece7a0b3b67c33529cf3584edba558c78704e6da6ca18876b1d6c0fa8698e01fd7c2439b8d4dc0a93961e52
-EBUILD pre-commit-2.19.0.ebuild 1644 BLAKE2B 24cc7660399918058adedae779a17925b76cb07f82186b7b011514b15d0abbcabeccd4814260243d44b48257600744e46f9c2b851c04f952ec66aa297324ae0c SHA512 2336a641068cf6e0acf2bc5e8404d0be1204fa4edfc4cdaeee5417f1e3c0a77def2317b6de6c96be1f2db5001421717792fe9e40f4689939480d644a49034644
-EBUILD pre-commit-2.20.0.ebuild 1600 BLAKE2B 1702744f98ed787a82ef94ed7946d0836f89ff8b89c61767de40883ce4d1d5b0f69b723eff45d16e95d6cd284f3ab1b352391fd9ceb0fcda735bf402140e0cc3 SHA512 8833a96ef20784d1bed9f13a632b2d71f4da20c58a7920d274120f71c1322ccdc963972fefe5e597c10dd4d2f6b7dedade354f28545382884caec426fbb27ffa
+EBUILD pre-commit-2.20.0.ebuild 1598 BLAKE2B 3b12bd2c4b0813038c689ea053600bdca89409f34e86cad85dd6646dc8c0ed71689a4c1fbb7928a810b7f3543768d472e43173bca9311d05089b8b765de23335 SHA512 595a35b0592aa24a59568b2c146e6bd7fc96f42ab86a4f27f92cc8c069154387efe9469f89407c85dec340952fe6e6713f84f9e7636be25a445da90b0822986f
MISC metadata.xml 380 BLAKE2B 99842a97367e91700c6f714f427b7b3d4b7212c401abae5ab715dfaa724776f02fe250184a33504d3433bb58cd5679af59a32ec21a7e7432481160dab36a4d95 SHA512 45330930d1e58fc1de0fd0ba55cd488dee96579ceab3be5073b91ff8f4f2b9adefff533dbfa5b0e8b23fbb648d45c0b7b4073a1ec57b586600cc2bf6347e0bbb
diff --git a/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild
deleted file mode 100644
index 6697add00888..000000000000
--- a/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Many test failures with py3.11 as of 2.19.0
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
- ')"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
-)"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled and when run manually with tox.
-EPYTEST_DESELECT=(
- tests/languages/
- tests/repository_test.py
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_try_repo
-)
-
-distutils_enable_tests pytest
diff --git a/dev-vcs/pre-commit/pre-commit-2.20.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.20.0.ebuild
index 1d5c06e1e2a7..3cba2d94f066 100644
--- a/dev-vcs/pre-commit/pre-commit-2.20.0.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-2.20.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
RDEPEND="dev-vcs/git
$(python_gen_cond_dep '