summaryrefslogtreecommitdiff
path: root/dev-vcs/topgit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/topgit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/topgit')
-rw-r--r--dev-vcs/topgit/Manifest4
-rw-r--r--dev-vcs/topgit/metadata.xml8
-rw-r--r--dev-vcs/topgit/topgit-0.9-r1.ebuild33
-rw-r--r--dev-vcs/topgit/topgit-0.9.ebuild33
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-vcs/topgit/Manifest b/dev-vcs/topgit/Manifest
new file mode 100644
index 000000000000..95745577aeb6
--- /dev/null
+++ b/dev-vcs/topgit/Manifest
@@ -0,0 +1,4 @@
+DIST topgit-0.9.tar.gz 37025 BLAKE2B e28b0fd4cdf4cf063bad939c712fc9354ffc2d9c5e431f637e8306454d7a871268902253a1d2c59afa94406223b1fdc1627f3dda04586c88c0b609a72a1eaa87 SHA512 15b4ec44fb1711273155350924806f9ddce330251d3f300f5d2ecf445f4822c40b5c7309429876746ed8226c00f74292956f51f9126c8c359c3f4d589c73791c
+EBUILD topgit-0.9-r1.ebuild 697 BLAKE2B d2403274c59bea10d676003f7e307b7f2138264693fff979257ebdc7eb157a0e88d945bfea3fd0b1c5ef1cabbb3d5dc57ad196d782fad4b5b8d94feb7f4fabf6 SHA512 171f8e2c67a2ab9605385c8f6241c192f78bc571451a99994cd53e1817eb58e91e2fd4a5a15774286b60c9e761e4ec68ce42cfeb5bbea38244d1e9dd46b2c015
+EBUILD topgit-0.9.ebuild 695 BLAKE2B 0e0c9bc9bd63eb09a5809b82831d25cd577f580655823aacac354609cc270a833fcc9f6b8a4702c37fcb590cc7623a906cd059eb8a5c72ac90b5ed5df4c0923e SHA512 7fc7ce4938c1b881d4a8724901b93789c05e21c78b1729d5db68eccae6d06284ff79769fb0b4755b81154acc1f6410f256a4cf73d1be57029aa48db89e6760de
+MISC metadata.xml 246 BLAKE2B f9d665b30ee34751053156150dfc0251a79530710ce6db75be5f79bf681bbab29d630af66d390be6870a424eeff55679e2ad226f9d268d1ba4261381a5708262 SHA512 453ca444336afd5e9a05f704cb9228b1415a4440aeb43847b80bfbdfacc3a21bf4706efc408acbb692b5a9130051c802d23b04791cfa0d84f499a8b359c393ce
diff --git a/dev-vcs/topgit/metadata.xml b/dev-vcs/topgit/metadata.xml
new file mode 100644
index 000000000000..a4bff25eb375
--- /dev/null
+++ b/dev-vcs/topgit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">greenrd/topgit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/topgit/topgit-0.9-r1.ebuild b/dev-vcs/topgit/topgit-0.9-r1.ebuild
new file mode 100644
index 000000000000..85d51d45244a
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://github.com/greenrd/topgit"
+SRC_URI="https://github.com/greenrd/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" sharedir="${D}/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}
diff --git a/dev-vcs/topgit/topgit-0.9.ebuild b/dev-vcs/topgit/topgit-0.9.ebuild
new file mode 100644
index 000000000000..e7df0c5baa14
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://github.com/greenrd/topgit"
+SRC_URI="https://github.com/greenrd/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" sharedir="${D}/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}