summaryrefslogtreecommitdiff
path: root/dev-vcs/topgit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-vcs/topgit
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-vcs/topgit')
-rw-r--r--dev-vcs/topgit/Manifest4
-rw-r--r--dev-vcs/topgit/metadata.xml11
-rw-r--r--dev-vcs/topgit/topgit-0.19.12.ebuild32
3 files changed, 44 insertions, 3 deletions
diff --git a/dev-vcs/topgit/Manifest b/dev-vcs/topgit/Manifest
index f23d318b4916..e847adc02ba9 100644
--- a/dev-vcs/topgit/Manifest
+++ b/dev-vcs/topgit/Manifest
@@ -1,3 +1,5 @@
+DIST topgit-0.19.12.tar.gz 302492 BLAKE2B 5691823e58774883d33bc96e5d10b871a40224c97e3deb90f4fef051dbcecd6a7d3c979fe6b7e6c9aac64d485b9c4324b4d666a7ae64cb82cd325498d33e0cae SHA512 cb9245fbec7a4a15822a5b70d7052be200aa8b574b528dd929121597eb7dcec97532b0fd4d6a4d6bb63676194ed0ab2129e106fb88f63561187620ec431f9efb
DIST topgit-0.9.tar.gz 37025 BLAKE2B e28b0fd4cdf4cf063bad939c712fc9354ffc2d9c5e431f637e8306454d7a871268902253a1d2c59afa94406223b1fdc1627f3dda04586c88c0b609a72a1eaa87 SHA512 15b4ec44fb1711273155350924806f9ddce330251d3f300f5d2ecf445f4822c40b5c7309429876746ed8226c00f74292956f51f9126c8c359c3f4d589c73791c
+EBUILD topgit-0.19.12.ebuild 748 BLAKE2B a4aecf5eca106139cd3343ec418a1852a534dbef94a5655e99a92aec6b052a60f03dfecaed4767abf01502fcf932e9201665df1fe106b1ed57e8a2e5a7bba498 SHA512 3e2de52d6d464c1eb5d00cc0da38f806b7aacbc08670675c423c2611a0199726147f98cf928a78c32c96d627b1329b38cbc7c9633a7c994c5fdde6ef54c96c97
EBUILD topgit-0.9-r1.ebuild 692 BLAKE2B d604f1d2800d5953d2d7f296b5596fee898b95d51eedb80dda8d121dbad3c3611f4ecb40a2e5f22e8143981961639f68d5086539fe08a9d0e8e67940fc5df08d SHA512 2984e19bb3c22e8d83b0c8ad85b8c9939c3dddec3844ffeffd5e5cb6b2d857c3da9e214a3e89fe16acaede8aecf20c820b68c5793080d87476bb3bf40d90f996
-MISC metadata.xml 246 BLAKE2B f9d665b30ee34751053156150dfc0251a79530710ce6db75be5f79bf681bbab29d630af66d390be6870a424eeff55679e2ad226f9d268d1ba4261381a5708262 SHA512 453ca444336afd5e9a05f704cb9228b1415a4440aeb43847b80bfbdfacc3a21bf4706efc408acbb692b5a9130051c802d23b04791cfa0d84f499a8b359c393ce
+MISC metadata.xml 455 BLAKE2B 6928af22b505988592f48120217cf6c8a9e5f4fd0a0d2040126bb730f3a4dc7b1a5d428d00ffe6fcf0abc5b00cf5c4eb847e5d4ff3288f38b79483708980aa08 SHA512 12408a1b03499ee4718189bec87eb725462c8e2d279bcaef81b18f411f86d0588bffb145dbc793fb9fb9419f7644ff2529a03db636443b157f55b2d7a9c6594e
diff --git a/dev-vcs/topgit/metadata.xml b/dev-vcs/topgit/metadata.xml
index a4bff25eb375..1c551510bec0 100644
--- a/dev-vcs/topgit/metadata.xml
+++ b/dev-vcs/topgit/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
- <remote-id type="github">greenrd/topgit</remote-id>
+ <remote-id type="github">mackyle/topgit</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-vcs/topgit/topgit-0.19.12.ebuild b/dev-vcs/topgit/topgit-0.19.12.ebuild
new file mode 100644
index 000000000000..eab7ae62e258
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.19.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://mackyle.github.io/topgit/topgit.html https://github.com/mackyle/topgit"
+SRC_URI="https://github.com/mackyle/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND=">=dev-vcs/git-2.10.0"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" sharedir="/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}