summaryrefslogtreecommitdiff
path: root/dev-vcs/svn2cl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/svn2cl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/svn2cl')
-rw-r--r--dev-vcs/svn2cl/Manifest4
-rw-r--r--dev-vcs/svn2cl/files/0.9-wrapper.patch20
-rw-r--r--dev-vcs/svn2cl/metadata.xml5
-rw-r--r--dev-vcs/svn2cl/svn2cl-0.12.ebuild40
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-vcs/svn2cl/Manifest b/dev-vcs/svn2cl/Manifest
new file mode 100644
index 000000000000..66529183ddf2
--- /dev/null
+++ b/dev-vcs/svn2cl/Manifest
@@ -0,0 +1,4 @@
+AUX 0.9-wrapper.patch 531 BLAKE2B c4540c9768cfa687d39b1193d59e0426c238f7c9aa71b3b4e80113e31700e64cd3bd2c50f86f5d5825c2e668081e385502ca5973eb4a9a24d150fe67affc3208 SHA512 8e36433178d68e6e1c0f7d1259c8aecb1ee70f04fc47033f5e7c58b0aa273fcdf20aa425bce673bea3c36d8374da8ef35f4e0854fc6f62a3c0f36b414ff21610
+DIST svn2cl-0.12.tar.gz 18171 BLAKE2B 88e66d4bcc3e05132462d1c9794846a644f121876d36dc1b42ef0cb7bf8481536d62a6d764e92edc670c149fbe5702a46b02d875ad1cd477a05b497780232296 SHA512 c84f0f67b34d615b1732cd03ecbdb6d3bb082677145acf2f32f74518306347eb984d65d4837f2463b369cd7a8a7443d2cfba589c531b46f423870c55b0b48aa2
+EBUILD svn2cl-0.12.ebuild 968 BLAKE2B a48d2df2292210fbd4b94424d4818912f0aad5137f59cfd8476cfba5d905061de629947e3e3ca2a43e846d7cde9619fb0c2084e15a43d035b1b5f7d8fc2e8f17 SHA512 959120933c895f6a99ca6db51de2763cc94a7f5abd7bc2128bd093dce788acc0331ed74131ea701b227c746efcc589ecdc265eafbe8ca7a7db3feb805f53bf10
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-vcs/svn2cl/files/0.9-wrapper.patch b/dev-vcs/svn2cl/files/0.9-wrapper.patch
new file mode 100644
index 000000000000..478b2a032d2a
--- /dev/null
+++ b/dev-vcs/svn2cl/files/0.9-wrapper.patch
@@ -0,0 +1,20 @@
+--- svn2cl.sh 2006-10-18 23:38:06.000000000 +0200
++++ svn2cl.sh.1 2006-11-12 01:41:05.000000000 +0100
+@@ -234,16 +234,7 @@
+ esac
+ done
+
+-# find the directory that this script resides in
+-prog="$0"
+-while [ -h "$prog" ]
+-do
+- dir=`dirname "$prog"`
+- prog=`ls -ld "$prog" | sed "s/^.*-> \(.*\)/\1/;/^[^/]/s,^,$dir/,"`
+-done
+-dir=`dirname "$prog"`
+-dir=`cd "$dir" && pwd`
+-XSL="$dir/svn2${OUTSTYLE}.xsl"
++XSL="/usr/share/svn2cl/svn2${OUTSTYLE}.xsl"
+
+ # check if the authors file is formatted as a legacy
+ # colon separated file
diff --git a/dev-vcs/svn2cl/metadata.xml b/dev-vcs/svn2cl/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/dev-vcs/svn2cl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/dev-vcs/svn2cl/svn2cl-0.12.ebuild b/dev-vcs/svn2cl/svn2cl-0.12.ebuild
new file mode 100644
index 000000000000..1591242a7069
--- /dev/null
+++ b/dev-vcs/svn2cl/svn2cl-0.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output"
+HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt
+ dev-vcs/subversion"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # the wrapper script looks for the xsl files in the
+ # same directory as the script.
+ epatch "${FILESDIR}"/0.9-wrapper.patch
+}
+
+src_install() {
+ newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl svn2html.xsl || die
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css || die
+ doman svn2cl.1 || die
+}
+
+pkg_postinst() {
+ einfo "You can find samples of svn2html.css and authors.xml in"
+ einfo "/usr/share/doc/${PF}/"
+ einfo "Read man page for details."
+}