summaryrefslogtreecommitdiff
path: root/dev-vcs/repo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /dev-vcs/repo
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'dev-vcs/repo')
-rw-r--r--dev-vcs/repo/Manifest3
-rw-r--r--dev-vcs/repo/metadata.xml10
-rw-r--r--dev-vcs/repo/repo-1.26.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
new file mode 100644
index 000000000000..250963c13400
--- /dev/null
+++ b/dev-vcs/repo/Manifest
@@ -0,0 +1,3 @@
+DIST repo-1.26 29829 BLAKE2B c5dc74214d404e6c11189a3d34c9a771ed5689da14e64588b5db144b6ea3ec38a727238d7dc6e609a22edb5b84d350210564615016f6b36599cf9e3fc3b34ef9 SHA512 1398fab95b4fb4a24fda93d4054384a801b5b70e3dca3a794f458d8e19582ef833ef5a3a0f3a571121d2d9172ce0e70f8b3c6719f6c2f47643ffe6de181e34b4
+EBUILD repo-1.26.ebuild 847 BLAKE2B a86153526d1ecec7490c7a58eef44754d089dda05e9e3840d15a4747da659221f58d5b1d9fe5dbd9f2276c2e35d1022f05132324028d02ae9d4bc5cbb05097cc SHA512 0d5ecc7a9004fedb6d91693234d56d222cf0190cc4ee8c44e8a3ba3592d658f1dd54850af314db22d3a372fe69eb6e2b07651b4700aca76d365c274b33142d2a
+MISC metadata.xml 338 BLAKE2B 49e4b3e3767754bb7a0661cb388f3e18b372fa713d0e3b92c742cddb2fe21e384b1689fd72b23865d7b363ab01bae90a5a11956593eccc915f1b6c99e52c2718 SHA512 0a83263d882281636f6925d20c9e8b991267a1b7d73d7bd6e545c77372424fd602e28d6c9a82668d0a73500bcb8dd8287f7891b66e3fe1517907001f3fb43cd4
diff --git a/dev-vcs/repo/metadata.xml b/dev-vcs/repo/metadata.xml
new file mode 100644
index 000000000000..de0e9961d994
--- /dev/null
+++ b/dev-vcs/repo/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>vapier@gentoo.org</email>
+</maintainer>
+<longdescription>
+Tool for managing multiple git repositories. From Google, useful for building Android.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-vcs/repo/repo-1.26.ebuild b/dev-vcs/repo/repo-1.26.ebuild
new file mode 100644
index 000000000000..d1563fd6addb
--- /dev/null
+++ b/dev-vcs/repo/repo-1.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. They are confusingly different currently.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}