summaryrefslogtreecommitdiff
path: root/dev-vcs/repo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-vcs/repo
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-vcs/repo')
-rw-r--r--dev-vcs/repo/Manifest4
-rw-r--r--dev-vcs/repo/repo-1.26.ebuild2
-rw-r--r--dev-vcs/repo/repo-2.0.ebuild32
3 files changed, 36 insertions, 2 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index 250963c13400..c467039d4d55 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,3 +1,5 @@
DIST repo-1.26 29829 BLAKE2B c5dc74214d404e6c11189a3d34c9a771ed5689da14e64588b5db144b6ea3ec38a727238d7dc6e609a22edb5b84d350210564615016f6b36599cf9e3fc3b34ef9 SHA512 1398fab95b4fb4a24fda93d4054384a801b5b70e3dca3a794f458d8e19582ef833ef5a3a0f3a571121d2d9172ce0e70f8b3c6719f6c2f47643ffe6de181e34b4
-EBUILD repo-1.26.ebuild 847 BLAKE2B a86153526d1ecec7490c7a58eef44754d089dda05e9e3840d15a4747da659221f58d5b1d9fe5dbd9f2276c2e35d1022f05132324028d02ae9d4bc5cbb05097cc SHA512 0d5ecc7a9004fedb6d91693234d56d222cf0190cc4ee8c44e8a3ba3592d658f1dd54850af314db22d3a372fe69eb6e2b07651b4700aca76d365c274b33142d2a
+DIST repo-2.0 30067 BLAKE2B 23aaae97c8512e329a4293d82c4e65583861d515dc079fdddbb73473ea0aeb3951315fa7595c70695cf94f030ed2bc97b134ff2aafe774b552132ac8cf4f4045 SHA512 a83525fa87a3fba8d78af1305dd92f5e51f58430bff20f63b8b743ad94d382ecf3edc1888c78f9da4be4d379bfa3ccde79aae5c1d8c173f928d3593ea42156bb
+EBUILD repo-1.26.ebuild 841 BLAKE2B b0c6dd45b5752a9b0d0af84f1d7c2e22a3556cfbec3cbe9aecaf22faadf34fb986c8ee520a8e18a979eb6d8058238a80195577aab3edccf584ae2d3c7f031250 SHA512 e844150bfcfac200304383c0b0f3ea9f77295ebc709b131546637fef96b1af3639cba783208cf0130311c53b2394153b894f2e7f34843f7c89cddecfe080e1f1
+EBUILD repo-2.0.ebuild 868 BLAKE2B 979642b6415c18093ad405a459dcc4431c3758e9d16e1c5e0fe12e88106680f57957975a5ffd8eae5f681d5f0e4c85ffd478c0f3df68cdd0d90f712102e2d01a SHA512 11fe9e4b77479d136d0b0f85751da243fa0bbc419a9ea3caacfb4e8eb55d8503b6019b822504c034debf715c64f9701297500d8415eb42f54ef9d1c886cebbd9
MISC metadata.xml 338 BLAKE2B 49e4b3e3767754bb7a0661cb388f3e18b372fa713d0e3b92c742cddb2fe21e384b1689fd72b23865d7b363ab01bae90a5a11956593eccc915f1b6c99e52c2718 SHA512 0a83263d882281636f6925d20c9e8b991267a1b7d73d7bd6e545c77372424fd602e28d6c9a82668d0a73500bcb8dd8287f7891b66e3fe1517907001f3fb43cd4
diff --git a/dev-vcs/repo/repo-1.26.ebuild b/dev-vcs/repo/repo-1.26.ebuild
index d1563fd6addb..9d2c58695f06 100644
--- a/dev-vcs/repo/repo-1.26.ebuild
+++ b/dev-vcs/repo/repo-1.26.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sh ~sparc x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/dev-vcs/repo/repo-2.0.ebuild b/dev-vcs/repo/repo-2.0.ebuild
new file mode 100644
index 000000000000..1632716eecc8
--- /dev/null
+++ b/dev-vcs/repo/repo-2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}