summaryrefslogtreecommitdiff
path: root/dev-vcs/repo/repo-2.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
commitc92d0cd2b34d17bce6d5bb4e3a4fc00af4193c99 (patch)
tree517559f918260cf91e7bdd4e484aa6fe9085cb9f /dev-vcs/repo/repo-2.30.ebuild
parenta59ffccce3bf214fae9932cc42400eeeaec25c6c (diff)
gentoo auto-resync : 24:11:2022 - 13:10:39
Diffstat (limited to 'dev-vcs/repo/repo-2.30.ebuild')
-rw-r--r--dev-vcs/repo/repo-2.30.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-vcs/repo/repo-2.30.ebuild b/dev-vcs/repo/repo-2.30.ebuild
new file mode 100644
index 000000000000..1eaf21021d74
--- /dev/null
+++ b/dev-vcs/repo/repo-2.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}
+ https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S="${WORKDIR}/git-${P}"
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+ newbashcomp completion.bash ${PN}
+ doman man/*.[0-9]
+}