summaryrefslogtreecommitdiff
path: root/dev-vcs/rcs/rcs-5.10.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
commit1d18b53ed419c49eb3f71637ccd58a431c1368d4 (patch)
treeeb3671b1209855aa64534ee96262d06bcda99d74 /dev-vcs/rcs/rcs-5.10.1-r1.ebuild
parentfdca6388cf31827202fae75cae067c695bd09339 (diff)
gentoo auto-resync : 14:04:2023 - 05:44:49
Diffstat (limited to 'dev-vcs/rcs/rcs-5.10.1-r1.ebuild')
-rw-r--r--dev-vcs/rcs/rcs-5.10.1-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-vcs/rcs/rcs-5.10.1-r1.ebuild b/dev-vcs/rcs/rcs-5.10.1-r1.ebuild
new file mode 100644
index 000000000000..8040c42241d1
--- /dev/null
+++ b/dev-vcs/rcs/rcs-5.10.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic unpacker
+
+DESCRIPTION="Revision Control System"
+HOMEPAGE="https://www.gnu.org/software/rcs/"
+SRC_URI="mirror://gnu/rcs/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="doc"
+
+RDEPEND="sys-apps/diffutils
+ sys-apps/ed"
+DEPEND="${RDEPEND}"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.10.1-configure-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e '/gets is a security hole/d' \
+ lib/stdio.in.h || die
+
+ # Drop when clang 16 patch isn't needed anymore
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -std=gnu99
+
+ econf
+}
+
+src_test() {
+ # Tests attempt to call rcs commands on /dev/null and /tmp.
+ # https://bugs.gentoo.org/840173
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ if use doc; then
+ emake -C doc html
+ mv doc/rcs.html doc/html || die
+ dodoc -r doc/html/
+ fi
+}