summaryrefslogtreecommitdiff
path: root/dev-vcs/rcs/rcs-5.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-vcs/rcs/rcs-5.10.0.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-vcs/rcs/rcs-5.10.0.ebuild')
-rw-r--r--dev-vcs/rcs/rcs-5.10.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-vcs/rcs/rcs-5.10.0.ebuild b/dev-vcs/rcs/rcs-5.10.0.ebuild
new file mode 100644
index 000000000000..4bd994b8b2e8
--- /dev/null
+++ b/dev-vcs/rcs/rcs-5.10.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Revision Control System"
+HOMEPAGE="https://www.gnu.org/software/rcs/"
+SRC_URI="mirror://gnu/rcs/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="doc"
+
+RDEPEND="
+ sys-apps/diffutils
+ sys-apps/ed"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc-2.34.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e '/gets is a security hole/d' \
+ lib/stdio.in.h || die
+}
+
+src_configure() {
+ append-flags -std=gnu99
+ econf
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ if use doc; then
+ emake -C doc html
+ rm -R "${ED}/usr/share/doc/rcs"
+ mv doc/rcs.html doc/html
+ dodoc -r doc/html/
+ fi
+}