summaryrefslogtreecommitdiff
path: root/dev-vcs/qgit/qgit-2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-vcs/qgit/qgit-2.9.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-vcs/qgit/qgit-2.9.ebuild')
-rw-r--r--dev-vcs/qgit/qgit-2.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-vcs/qgit/qgit-2.9.ebuild b/dev-vcs/qgit/qgit-2.9.ebuild
new file mode 100644
index 000000000000..e0301f093c7f
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt GUI for git repositories"
+HOMEPAGE="https://github.com/tibirna/qgit"
+SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+ !dev-vcs/qgit:2
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+DOCS=( README.adoc )