summaryrefslogtreecommitdiff
path: root/dev-vcs/python-gitlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /dev-vcs/python-gitlab
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'dev-vcs/python-gitlab')
-rw-r--r--dev-vcs/python-gitlab/Manifest2
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index ebdaff1a3f59..c72c4ca177f5 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1,5 +1,7 @@
DIST python-gitlab-1.7.0.tar.gz 110657 BLAKE2B 1003d3373d3ef5474b1d5c10b1c6af57e7467cec432fc1eb75b4e1ba7766361641f25461ac2bf1b7692dab855d4e5cbc204240ede3568e71ed1af75682807fb0 SHA512 ad50d989e27948ff5188f4191ad3b7f1e1b45608627b2042bf02d635b2aa8da0a24f6b0383f483a01df54e4ab14576e7e4252576b9c2bdf67a187ae6aad69d53
DIST python-gitlab-1.8.0.tar.gz 115603 BLAKE2B 8ebebc1735e5531b4f95d82122b6ecf78fd541bce503f0cdf8c47b2ec2edab89efcad6c0ab39d82b57ffb8c3e341cb2160916b7df6c4886465e90557db3141c3 SHA512 4843aefb7cd363520e9065cfc08b81ec2c5c2c9cbdb5d6adbd35ec0f615bafd40e66746739c910b5e7e041f06e2aa9dc8beb8a884a714e6837cd5fb6fefb53be
+DIST python-gitlab-1.9.0.tar.gz 116460 BLAKE2B f0a0d9679e4e742d966c678f8dcc6b2464e5ae8a013038221b3c484e6bb6ae23c166f82fec85c3560ebbce3cf80bc23657b1b906d8c6f284a64589545acdb035 SHA512 cb0d58896f55837f7088ab08551f2e9f9f82e8a04c19979a69bc042c95cdb2d04174dec49a236ddcf1344c50e9ffc6f929750b008bf6e619225c80bf9490afaa
EBUILD python-gitlab-1.7.0.ebuild 1033 BLAKE2B b2aa8e06cd851f080922700d542e31ef7a9fa7f032096d5bfb10eb6f5fee2dd57da20b17e0f36e2eac69b56c0afd0a90712bc99fcba8dc2529fdf53f5d20bc3e SHA512 8860df6dfb71ebca1f93aead4cd72f40f922775468a153124c8a757fa94d5da1d23612879aa8e012466801af7e26f1aec0eb07ca9026f35f3a92e104ecf1feea
EBUILD python-gitlab-1.8.0.ebuild 1033 BLAKE2B b2aa8e06cd851f080922700d542e31ef7a9fa7f032096d5bfb10eb6f5fee2dd57da20b17e0f36e2eac69b56c0afd0a90712bc99fcba8dc2529fdf53f5d20bc3e SHA512 8860df6dfb71ebca1f93aead4cd72f40f922775468a153124c8a757fa94d5da1d23612879aa8e012466801af7e26f1aec0eb07ca9026f35f3a92e104ecf1feea
+EBUILD python-gitlab-1.9.0.ebuild 1033 BLAKE2B b2aa8e06cd851f080922700d542e31ef7a9fa7f032096d5bfb10eb6f5fee2dd57da20b17e0f36e2eac69b56c0afd0a90712bc99fcba8dc2529fdf53f5d20bc3e SHA512 8860df6dfb71ebca1f93aead4cd72f40f922775468a153124c8a757fa94d5da1d23612879aa8e012466801af7e26f1aec0eb07ca9026f35f3a92e104ecf1feea
MISC metadata.xml 248 BLAKE2B 5d9c3678c604aac0f24c5d5015e28f02b9ce83bb6a179755a44adeb3d69e4dd50be4acc30a6317649f5be23bcf13ac210bbe4712aa403e9c4cf2de351b39c941 SHA512 dc5b06a888be6367909895d5891a08189f4657bcee602e5ff0021be2ad3677e58ec7387ff244625be66a142138666e7eac790d2a7b1e298f0ad644725b5e57e0
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild
new file mode 100644
index 000000000000..2ee27c73fd03
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testrepository[${PYTHON_USEDEP}]
+ dev-python/hacking[${PYTHON_USEDEP}]
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3
+ dev-python/sphinx_rtd_theme )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}