summaryrefslogtreecommitdiff
path: root/dev-vcs/pre-commit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-vcs/pre-commit
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest4
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.12.1.ebuild2
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.13.0.ebuild59
3 files changed, 63 insertions, 2 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 18483fecfa3f..17e119013a84 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,3 +1,5 @@
DIST pre-commit-2.12.1.tar.gz 246313 BLAKE2B 45ee7c8217f88eeaa2e9eb11efd79291d6577134799b328f252bd4d4283c11754b36ffeedf045a5101c6edc8cdf330d566e404ae34f1a831a830e8e0346337e9 SHA512 6dbd804e1001276e6e8cea7c31b321a05798b38c59f37d5900317c3a9ceccf5103afcbdfd29f9438be3595a18ae15eb09dd222c91c439da47d7728a0e0a55c70
-EBUILD pre-commit-2.12.1.ebuild 1712 BLAKE2B 33a7360f824846898a5d4ee580b99ac1e274e6fe5cca49c94b99178313db0efbbce4b15250d8a83962e391d1ca8231f71b6c1373b0eb5702d17dd3105d59037a SHA512 e62620084bb56f228c0b5f50419324a504988d32def557e6c62a29da9c609430c02193cdd777c920738880ee2805c15d1497441c6d200d92f674d4b3bc89147a
+DIST pre-commit-2.13.0.tar.gz 252631 BLAKE2B 7e6b3af46dfaf9928d2cb2aa6cad05423bf6e417e2324af71b241e1aaa2eec6fcb271869f98c040cd4fb8c608a1fabd244c8286864f469a06c44684cd2bf33eb SHA512 5dfc297b3f900afef8f1c355b38ce086af7c836d1e577af8ec95ffb30e82df8b866131da4ff12933339bda63e4a90833c3852265d4f2d4a59bf92bce2b972a5e
+EBUILD pre-commit-2.12.1.ebuild 1711 BLAKE2B f21a7772ffedf6cfffcebae0c6e57e90c4e94e7818d210b6d961f653f2e262e75e957b4bf5ebc9e826a2ed7876dcefdf6096b0eec84008d316ad655295d6860b SHA512 f3149dde9bb2242abe4ffa32be2e3cac7041c6d36644568e98fec98c0de189ece1b4002fe14d127f34d3cbedb8b960c07d582a543986ca68394aee897f4047a4
+EBUILD pre-commit-2.13.0.ebuild 2066 BLAKE2B ae99b4039b7b06cbd36879a928d7ca55a911accdae6099d7c2f8a4fb9ea4d86fbd2ecfed615012817ec50d27f857b769d0963ffa065cf3f0238705c8a8f52847 SHA512 6876cd8807b5fc714d601065f27d8736717ca79a6d172b9464d73f11dbbfadf9b0a5321bbcfe7dfbe3caf12b83bc587d823a344c92229c22b0975887643d87f7
MISC metadata.xml 379 BLAKE2B 6224574b28f758241c6ad965ad59a423db76bd21c64c3577691104a8f45a4ee9b570f9cf1557f2ce17f00bf496b9eeb83741679dc0d6e1bb23c421f90fe9070f SHA512 f14032e386c2bb591390034086c7d4a2e8ce9aacc536574c517dff4691aa8c39bc966307ee91a5f76708f14601312fd16528a676e1918d82b2761185bc27df9f
diff --git a/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild b/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild
index 5a4c4ea945f6..1dd37b2abb3b 100644
--- a/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
# TODO: figure out why these tests - all of which invoke git - fail:
# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall]
diff --git a/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild
new file mode 100644
index 000000000000..d2e6b60c37b1
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: figure out why these tests - all of which invoke git - fail:
+# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall],
+# tests/main_test.py::test_try_repo:
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# NOT a sandbox issue it seems, as disabling it does not help.
+# - tests/commands/install_uninstall_test.py::test_environment_not_sourced:
+# Unexpected error "/usr/bin/env: 'python3.8': No such file or directory" - but only if pre-commit
+# has previously been installed.
+# - tests/commands/install_uninstall_test.py::test_installed_from_venv:
+# the function invoking "git commit" returns 1 instead of 0, no details.
+RESTRICT="test"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ dev-python/cfgv[${PYTHON_USEDEP}]
+ dev-python/identify[${PYTHON_USEDEP}]
+ dev-python/nodeenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+)"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ default
+
+ # These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+ # and while some of them do include "skip if not found" logic, most of them do not.
+ rm -rf tests/languages tests/repository_test.py
+}