summaryrefslogtreecommitdiff
path: root/dev-vcs/pre-commit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-vcs/pre-commit
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest6
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.17.0.ebuild51
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.18.1.ebuild51
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.19.0.ebuild2
4 files changed, 2 insertions, 108 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 8f56324c5285..420a08de360c 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,7 +1,3 @@
-DIST pre-commit-2.17.0.tar.gz 261131 BLAKE2B 114fac379690ee4c1c60970a1b0fbcd20faea785837c174514c3fc3d247ec79f52fb5f14c96a762921395d682017a9cc406dc59b3042fc955cd65019fb781a3f SHA512 54b5af9088083ad0c57fab09c06c35bd5921b29348454fc8fc16081d3c6a2e0add13f8a18f06b7408a0e06babc5e15659b37ab53797edd3514d516059e2343a8
-DIST pre-commit-2.18.1.tar.gz 263642 BLAKE2B 0ddd0e8bc7450c6bce2080155851c4b8d7e81fe1683dbea389d24e79906b52850ca8cc16b57a4b6192a389a10f8e9d0dfeaa23deaf59027093dc4db61b4533c1 SHA512 38ad176675b40eb4fd2475e51f3079cff5d84733401592a8a00021cba6656f01a38c5835298db50607fd8d188728c127600c731795fbc149436a5e4aada94fc1
DIST pre-commit-2.19.0.tar.gz 266117 BLAKE2B d2105fb9aa64e63c7d93142228545e3597eb4a1637f850ce5d3f14b0826bdfb8a8d971779690c4fda6823fa1915fc57f9c86b9ffae48dbe39e7a225123304f5c SHA512 9cc28c5e9ce4be87e09e7be01138c35bbe954efb6c1400e92b1a6b5f50e426b59d74651802359015840d5ec4a5583bf8f579bf7f08eb778d5950c8c8dfe4c80c
-EBUILD pre-commit-2.17.0.ebuild 1598 BLAKE2B 4ce3456da8315ca58792da3ad9d78ee0395d2090b02e505fb43a1ed6a87f1d5ac7a73ce5bc2e27063a045acebc4c1593cd20b0490c25779b3ac3b5f5b2ac5552 SHA512 d2a746ce673958c7985531299281b4b475db2c46edc17716ac72ee3f513deefa15185bd48a6532cdffaefd09ecf8743b42b4dad273f4e54cbf8caec7399dac94
-EBUILD pre-commit-2.18.1.ebuild 1600 BLAKE2B 6b9a7d9e7e640ffa62a7f797cfc8fec15e4cfb9fe1fe207694e67920f723eb4471f980d0b7a8b71776ec914fdba7d5c417db01384f63e075492ba6d8ddd94de3 SHA512 3ac9c85151f10089e0170ac8e922bba85eb71701b020890d03e8e0ed0c08de40058af7de73eb96ba3e73b680384436ca0164bfcb00affed9d807013fa84b682e
-EBUILD pre-commit-2.19.0.ebuild 1646 BLAKE2B 47a35f1c7439bd568556d2b81813d3516ba68f6e8ea4d6169bb448131b4e3fc3342605f882e1278fd9ff73949ac0fb5af16f3068a5663d9facac3f2037a3cf91 SHA512 58f97c33db011542c8c084f1ae470813713e8def4550d73220e53d6087400388f6fbefe976dd0e4c3c90e4fc3d28a1f5bbc99e063dbd409544e557d49254e481
+EBUILD pre-commit-2.19.0.ebuild 1644 BLAKE2B 24cc7660399918058adedae779a17925b76cb07f82186b7b011514b15d0abbcabeccd4814260243d44b48257600744e46f9c2b851c04f952ec66aa297324ae0c SHA512 2336a641068cf6e0acf2bc5e8404d0be1204fa4edfc4cdaeee5417f1e3c0a77def2317b6de6c96be1f2db5001421717792fe9e40f4689939480d644a49034644
MISC metadata.xml 380 BLAKE2B 99842a97367e91700c6f714f427b7b3d4b7212c401abae5ab715dfaa724776f02fe250184a33504d3433bb58cd5679af59a32ec21a7e7432481160dab36a4d95 SHA512 45330930d1e58fc1de0fd0ba55cd488dee96579ceab3be5073b91ff8f4f2b9adefff533dbfa5b0e8b23fbb648d45c0b7b4073a1ec57b586600cc2bf6347e0bbb
diff --git a/dev-vcs/pre-commit/pre-commit-2.17.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.17.0.ebuild
deleted file mode 100644
index 3d2b9177deee..000000000000
--- a/dev-vcs/pre-commit/pre-commit-2.17.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
- ')"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
-)"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled and when run manually with tox.
-EPYTEST_DESELECT=(
- tests/languages/
- tests/repository_test.py
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_try_repo
-)
-
-distutils_enable_tests pytest
diff --git a/dev-vcs/pre-commit/pre-commit-2.18.1.ebuild b/dev-vcs/pre-commit/pre-commit-2.18.1.ebuild
deleted file mode 100644
index 2794cad11571..000000000000
--- a/dev-vcs/pre-commit/pre-commit-2.18.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
- ')"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
-)"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled and when run manually with tox.
-EPYTEST_DESELECT=(
- tests/languages/
- tests/repository_test.py
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_try_repo
-)
-
-distutils_enable_tests pytest
diff --git a/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild
index b30bc1b3b4b9..6697add00888 100644
--- a/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
RDEPEND="dev-vcs/git
$(python_gen_cond_dep '