summaryrefslogtreecommitdiff
path: root/dev-vcs/notify-webhook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/notify-webhook
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/notify-webhook')
-rw-r--r--dev-vcs/notify-webhook/Manifest3
-rw-r--r--dev-vcs/notify-webhook/metadata.xml17
-rw-r--r--dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild28
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/notify-webhook/Manifest b/dev-vcs/notify-webhook/Manifest
new file mode 100644
index 000000000000..fa2e2d5c9cff
--- /dev/null
+++ b/dev-vcs/notify-webhook/Manifest
@@ -0,0 +1,3 @@
+DIST notify-webhook-0.1.0.tar.gz 17525 BLAKE2B 947027414bd30f96c9e27ca8b7f965a077792a6b8962180094df6bdeef8261140c063041f1b6598c518edfd3b6807da5020a4640aadbddb202887bac91d3b51d SHA512 1694f32b1263baecac473ffa49e6e7f9cbfdb73d1abaa88e228771e28a5ed915d9f5f21ab26b05934bdcd8694b4c4f1506763dd2f0c89c35ffa51e1d1b7d03b4
+EBUILD notify-webhook-0.1.0.ebuild 655 BLAKE2B 8102f5779b6d32c70c40d61af786d7a26be8dea3f76de42e81afd28f250aee524c573f75dfcf27e779d752ffc904af4e9202edef0403a94c8739aa8fc9321fa7 SHA512 16ba094c3d211d3551a6296fe9788ccb2f7d61b1d7e1dcd7efba8115da3082e734d75ec706f0801b6c3983b5854b7d2e8babbb58bec1ff4ffd5e00ae4441ea13
+MISC metadata.xml 598 BLAKE2B d3cb099dbdcb844e0158112eaa1748c9587f88241860f1a862d852a96b1ea6fd01fd0e3555442cb6fbe066da5c61722c443f482f26154679fbbd0ac29c9fff3e SHA512 c4c8fd71b9c15c14f397a6bf65dab33907ba702d021315605dcebdbe565671b5e0a2df38d5166ef6ace416fbd0e2a03334b9525c450c2d9e726b194ca63ebf5e
diff --git a/dev-vcs/notify-webhook/metadata.xml b/dev-vcs/notify-webhook/metadata.xml
new file mode 100644
index 000000000000..92ad1c0ab0df
--- /dev/null
+++ b/dev-vcs/notify-webhook/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ notify-webhook is a git post-receive hook script that posts JSON data to a
+ webhook capable server.
+
+ This implements the GitHub Web hooks API as closely as possible. It allows
+ arbitrary git repositories to use webhook capable services.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">metajack/notify-webhook</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild b/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
new file mode 100644
index 000000000000..5b121749659c
--- /dev/null
+++ b/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5} pypy3 )
+
+DESCRIPTION="Git post-receive web hook notifier in Python."
+HOMEPAGE="https://github.com/metajack/notify-webhook"
+#COMMIT='c571160f155122446e97bb01c1150b4d14ea69d6'
+SRC_URI="https://github.com/metajack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/simplejson"
+RDEPEND="${DEPEND}"
+
+#MY_P="${PN}-${COMMIT}"
+#S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc *markdown
+ exeinto /usr/libexec/githook/$PN/
+ doexe notify-webhook.py
+}