summaryrefslogtreecommitdiff
path: root/dev-vcs/notify-webhook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-vcs/notify-webhook
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-vcs/notify-webhook')
-rw-r--r--dev-vcs/notify-webhook/Manifest5
-rw-r--r--dev-vcs/notify-webhook/metadata.xml17
-rw-r--r--dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild28
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-vcs/notify-webhook/Manifest b/dev-vcs/notify-webhook/Manifest
new file mode 100644
index 000000000000..431d978bb4e4
--- /dev/null
+++ b/dev-vcs/notify-webhook/Manifest
@@ -0,0 +1,5 @@
+DIST notify-webhook-0.1.0.tar.gz 17525 SHA256 3782f588e75872e7dd25656279bab154102c476dd3b1fa24fb3af66475960d55 SHA512 1694f32b1263baecac473ffa49e6e7f9cbfdb73d1abaa88e228771e28a5ed915d9f5f21ab26b05934bdcd8694b4c4f1506763dd2f0c89c35ffa51e1d1b7d03b4 WHIRLPOOL 908e3b7e61ac8893c064d95566ee504bea1689f227ca900c27e3189e4e5be0fbe1409b24c3002feb1ee05aa85364cd2fcb620f0c4a7cdcbb1ce3c53d81bf412f
+EBUILD notify-webhook-0.1.0.ebuild 655 SHA256 6eb5b3bfb7eafa35d8dec67652d8a31079780c31fe2285234e9a9a3b959c4899 SHA512 16ba094c3d211d3551a6296fe9788ccb2f7d61b1d7e1dcd7efba8115da3082e734d75ec706f0801b6c3983b5854b7d2e8babbb58bec1ff4ffd5e00ae4441ea13 WHIRLPOOL c1136937dc225b4ab30ce68eb92d3043d7cecc35dc3069befefab76e8968c182f6ccdfb44a7afa8c7f16dab6c6e580cb7fc82471644cdb9bb7fc37d27e997337
+MISC ChangeLog 2539 SHA256 0ec14376352a33d8345f99274dfeda8a0f8e7777bdcf43bb403d6b43ba52e94e SHA512 c16bf1888fc6730286d2f9f712fdab036a02d47b3eae83a1dab6d4a71f217ffab647d4dca0842ca7b799d76f548916440f44c5e87ca747082dba60b976c96a17 WHIRLPOOL 3fcd969ef3c33fe116dc538714403772602109a5b8e7a15edad705620be91ccbd00941eeb28c2c8811f12a17d7ed7c2109372019c82935248fc28532083ab125
+MISC ChangeLog-2015 598 SHA256 6a038251bbfc41b5a1e86c13a1dc3984386606ee8baef541afc285a6500afd09 SHA512 3719c33fecbf69fdaf22e97a2bae6bdf04753388b0ace7c6b6514e89e51d72c656637b215134f6b653b3c3649e3eef004954f240d3ce36b344cf5bea73c0bea1 WHIRLPOOL d3e8ad4247c1861362f25f51ba62f57c7c8fc604b8929a13f21fcca5e1a990a0a25dd550d234015a17084a139dbf8025d954ebe43eda9c4ca8bcb423a503076e
+MISC metadata.xml 604 SHA256 d77239ce5671e439366a8adff16c92b8e7f54b3fb8e5fdd88e7e7d2821e63ae1 SHA512 6f7c5737772f1d4511d6809f91892b34b2c3153bf06a94ebac1fdc02d0a59623655624d5dd15a8b5b5919cec63bb100f8aa28e3cb75ee8550e9bb4f95269e0b0 WHIRLPOOL 340ed58317379967f62bc9f7e307c34abead0d0f9c69548acc488dbddfbb83cc07406f6010a2a06c1e2f015a53e02341fb7667d708560b3d97afc1021c1ed1bb
diff --git a/dev-vcs/notify-webhook/metadata.xml b/dev-vcs/notify-webhook/metadata.xml
new file mode 100644
index 000000000000..2ac5d4996908
--- /dev/null
+++ b/dev-vcs/notify-webhook/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ notify-webhook is a git post-receive hook script that posts JSON data to a
+ webhook capable server.
+
+ This implements the GitHub Web hooks API as closely as possible. It allows
+ arbitrary git repositories to use webhook capable services.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">metajack/notify-webhook</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild b/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
new file mode 100644
index 000000000000..5b121749659c
--- /dev/null
+++ b/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5} pypy3 )
+
+DESCRIPTION="Git post-receive web hook notifier in Python."
+HOMEPAGE="https://github.com/metajack/notify-webhook"
+#COMMIT='c571160f155122446e97bb01c1150b4d14ea69d6'
+SRC_URI="https://github.com/metajack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/simplejson"
+RDEPEND="${DEPEND}"
+
+#MY_P="${PN}-${COMMIT}"
+#S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc *markdown
+ exeinto /usr/libexec/githook/$PN/
+ doexe notify-webhook.py
+}