summaryrefslogtreecommitdiff
path: root/dev-vcs/hub
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/hub
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/hub')
-rw-r--r--dev-vcs/hub/Manifest3
-rw-r--r--dev-vcs/hub/hub-2.2.9.ebuild46
-rw-r--r--dev-vcs/hub/metadata.xml15
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-vcs/hub/Manifest b/dev-vcs/hub/Manifest
new file mode 100644
index 000000000000..413c4aa3d02e
--- /dev/null
+++ b/dev-vcs/hub/Manifest
@@ -0,0 +1,3 @@
+DIST hub-2.2.9.tar.gz 318275 BLAKE2B 731c3bb4cc4d92082f93bba94a5cc7ba31fc436479655fa19ffa8078416cedd814d2667589af9d6eed59a0be0c8b38963779429838d8dbaab8a628f838a5915c SHA512 69d69683eb5f1c881b15c9b3294878c35edc51f9b7d568a3e0609c3d77cebf5c1be5c7c018b0356bdd68cf3f56691a860381a53f3e016b28b9f95ab0b852d9f9
+EBUILD hub-2.2.9.ebuild 905 BLAKE2B f71ee495cb55cf5a7f64f643f7a8e79a9604f4b7dffeb94226bf3feda1759667e5d93d645239c6ad3a97e3ea2ab1c75be2d3e1aeddda59e400199ec7e37d0208 SHA512 51c336022318210fe0a37615f92f61842da7a2d4d76005c61d5b86ebdc5f0f44dbf47874f2811f6f7870cd592bf118545c48c7e32c02a11dfcd40c26050e45dd
+MISC metadata.xml 459 BLAKE2B ea97b6ea14e01abac1128117c1fd4a3b500e58c7821584de640c32168319a0fbd5c431f139e624a372866e845d3c4c8d09bb4aee68f42103ebe5e174641b1eb8 SHA512 2f87715926a447fc6a3a036a713a054f785d3918b40ef2502940a99afeb8f897402bb7698a05ffa26f1e99704f6dcadac8f41d5bea2b6c7ba41a58b9e4c3dc53
diff --git a/dev-vcs/hub/hub-2.2.9.ebuild b/dev-vcs/hub/hub-2.2.9.ebuild
new file mode 100644
index 000000000000..e05d3627ad9b
--- /dev/null
+++ b/dev-vcs/hub/hub-2.2.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 readme.gentoo-r1
+
+DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.5.1:="
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+
+src_compile() {
+ ./script/build || die
+}
+
+#src_test() {
+# ./script/test || die
+#}
+
+src_install() {
+ readme.gentoo_create_doc
+
+ dobin bin/hub
+
+ doman man/${PN}.1
+ dodoc README.md
+
+ newbashcomp etc/${PN}.bash_completion.sh ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins etc/hub.zsh_completion _${PN}
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/dev-vcs/hub/metadata.xml b/dev-vcs/hub/metadata.xml
new file mode 100644
index 000000000000..a0b5847fbe06
--- /dev/null
+++ b/dev-vcs/hub/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">defunkt/hub</remote-id>
+ </upstream>
+</pkgmetadata>