summaryrefslogtreecommitdiff
path: root/dev-vcs/hub
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /dev-vcs/hub
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'dev-vcs/hub')
-rw-r--r--dev-vcs/hub/Manifest5
-rw-r--r--dev-vcs/hub/hub-2.6.1.ebuild48
-rw-r--r--dev-vcs/hub/metadata.xml4
3 files changed, 54 insertions, 3 deletions
diff --git a/dev-vcs/hub/Manifest b/dev-vcs/hub/Manifest
index dd42703e2339..7a18853e4dcc 100644
--- a/dev-vcs/hub/Manifest
+++ b/dev-vcs/hub/Manifest
@@ -1,3 +1,6 @@
DIST hub-2.2.9.tar.gz 318275 BLAKE2B 731c3bb4cc4d92082f93bba94a5cc7ba31fc436479655fa19ffa8078416cedd814d2667589af9d6eed59a0be0c8b38963779429838d8dbaab8a628f838a5915c SHA512 69d69683eb5f1c881b15c9b3294878c35edc51f9b7d568a3e0609c3d77cebf5c1be5c7c018b0356bdd68cf3f56691a860381a53f3e016b28b9f95ab0b852d9f9
+DIST hub-2.6.1.tar.gz 994752 BLAKE2B 956f497699ecaac996fd3a92e5f7042d8e72050077e1de3b6091fe5e2481d9b8e4c46a8e34a2a95a81079b22b87bf82e2a5adf412e4dfbcbc53bf92f8b7ba2fa SHA512 a3aed611455de88a5b410887717aeb28b8837a74b437848c53903ccc809e758678643471ee7b14903ee147417754b0d443aede63e4f69a0e4b252c6a5ab619e3
+DIST hub-linux-amd64-2.6.1.tgz 4242259 BLAKE2B b68234050982999f103281da974af9c008e85920c0821ecb5582bf97b0a4889f6dd053ab3e6c7c5a0e18d1b09c7093f69d70f46b94254e51b2e6eb217fe3f479 SHA512 e27d9b8037e50b924b7ef663d9f68568f2732ed28e366aa300881eeeb6a2bdd1f50b4e597e3d36eddb07eb9c133df02ab5f889d5c6ec8632824d244148524e9b
EBUILD hub-2.2.9.ebuild 905 BLAKE2B f71ee495cb55cf5a7f64f643f7a8e79a9604f4b7dffeb94226bf3feda1759667e5d93d645239c6ad3a97e3ea2ab1c75be2d3e1aeddda59e400199ec7e37d0208 SHA512 51c336022318210fe0a37615f92f61842da7a2d4d76005c61d5b86ebdc5f0f44dbf47874f2811f6f7870cd592bf118545c48c7e32c02a11dfcd40c26050e45dd
-MISC metadata.xml 339 BLAKE2B 3d41b73f4895b4a644e27d91fe3ca4e4b139a1ed65606feb2bd07e900d82ba2db79a524bbdbcb8f0f3cd701c5b2a49ef38c1492218f9c0ba8ffc84766f30d914 SHA512 9beed675598c4d8591b5f6a18030e84db9e211b445c221fb979fdd2a9c7d6b44de098d03a494fb2633a26bb0f57c8b44a427f34325fd74db39504ef96dacc7c2
+EBUILD hub-2.6.1.ebuild 1097 BLAKE2B 4a3b7f95555f8c5ba8738fc819d2127dde609fb76e2be44d20c38cc316e62a7b30f2363cd7a670b9a92141674d83d9c18ae428538586a731483c8205f97526ad SHA512 b1b9ed74f46176faf65d64c0e69cde33419b2db3a52d9e64d075eaa982f43da44a9fd9fc4b326c0eb896065bb6e04e2848845876de9d5e41adf8720f51088c66
+MISC metadata.xml 334 BLAKE2B c10c297b5f493184b2191daf7c8c8df963054d3bd682aec7c9768784171f2eacb267fec32b817ea93a85d57e1bc248f5454ab8984270b94c997287b4ab983cfd SHA512 448ebf7bab89832d682b7e99a2fde5e04f242c7cca13272f5827f680077a310d670ff1f201073d07d779b8fb1905e066cd0de7b4f82879233ea6f366b0992f7a
diff --git a/dev-vcs/hub/hub-2.6.1.ebuild b/dev-vcs/hub/hub-2.6.1.ebuild
new file mode 100644
index 000000000000..78570a6ffc4e
--- /dev/null
+++ b/dev-vcs/hub/hub-2.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN=github.com/github/hub
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="https://github.com/github/hub/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://${EGO_PN}/releases/download/v${PV}/${PN}-linux-amd64-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.5.1:="
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+QA_FLAGS_IGNORED=".*"
+RESTRICT="strip"
+
+src_prepare() {
+ mkdir -p "${HOME}/go/src/${EGO_PN%/*}" || die "mkdir failed"
+ ln -snf "${S}" "${HOME}/go/src/${EGO_PN}" || die "ln failed"
+ default
+}
+
+src_compile() {
+ ./script/build -o bin/${PN} || die
+}
+
+#src_test() {
+# ./script/test || die
+#}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+ doman ../${PN}-linux-amd64-${PV}/share/man/man1/*.1
+
+ newbashcomp etc/${PN}.bash_completion.sh ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins etc/hub.zsh_completion _${PN}
+}
diff --git a/dev-vcs/hub/metadata.xml b/dev-vcs/hub/metadata.xml
index 6b740fb77166..cfaa84c658f3 100644
--- a/dev-vcs/hub/metadata.xml
+++ b/dev-vcs/hub/metadata.xml
@@ -2,8 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
</maintainer>
<upstream>
<remote-id type="github">defunkt/hub</remote-id>