summaryrefslogtreecommitdiff
path: root/dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 16:36:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 16:36:07 +0100
commitd0041c590ed45bbfeae458ea926e36bc64e41dd7 (patch)
tree9f8a3bcf226736635a558a6d70fcd46b60f90a17 /dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild
parent5067796b074450a155155c782ef4885c885cfb2b (diff)
gentoo auto-resync : 10:09:2023 - 16:36:07
Diffstat (limited to 'dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild b/dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..6cff7305c62b
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-1.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_PV=${PV/_rc/a}
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="https://hg-git.github.io https://pypi.org/project/hg-git/"
+SRC_URI="https://foss.heptapod.net/mercurial/hg-git/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.bz2 https://foss.heptapod.net/mercurial/hg-git/-/commit/9a52223a95e9821b2f2b544ab5a35e06963da3f1.patch -> ${MY_PV}-hg65.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-5.2[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ eapply "${DISTDIR}"/${MY_PV}-hg65.patch
+}