summaryrefslogtreecommitdiff
path: root/dev-vcs/gitsh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/gitsh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/gitsh')
-rw-r--r--dev-vcs/gitsh/Manifest3
-rw-r--r--dev-vcs/gitsh/gitsh-0.11.2.ebuild65
-rw-r--r--dev-vcs/gitsh/metadata.xml8
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-vcs/gitsh/Manifest b/dev-vcs/gitsh/Manifest
new file mode 100644
index 000000000000..1e91b5f11ee5
--- /dev/null
+++ b/dev-vcs/gitsh/Manifest
@@ -0,0 +1,3 @@
+DIST gitsh-0.11.2.tar.gz 101503 BLAKE2B 72a01da8412a680eb0afeab0d31a39261e389b96e528b0d1b5c6821b066f7b1d9244adc407d677c98b5f486cd8788daacf21e2467fc60254592ad9683b7e3ee4 SHA512 e8d473b4a13481722eb9a6b9232eb47174ed40f86af45848f33b9b936f09cf2010f8235036d9897bd637b841f35d051d3e426b56642f247b07c3a0d323e9a968
+EBUILD gitsh-0.11.2.ebuild 1240 BLAKE2B 1d4cd7085540616861eaa1a7658226d2c8679516387a0e996be749138817277b0ccd74f97ff32056f47016a5f27d41980b197f7e16d3e587ab2d4be144849711 SHA512 12c71962cdce3ba6fdff9cee21b0544666d170737ea23d732ea2ecb1bc6a37a508e7369d6015eb24595c240c7412e60ac0d4493ffddf891ef2b8af8f0f0f90ad
+MISC metadata.xml 253 BLAKE2B 1c7e0d89cebb5c7bd8f65377de8222c8e2c23ea8b370326685b763daecfeca18072af431bd6ca061315cae8aa6f0b8e9359659ee60822b48cd9cb94902f07ba9 SHA512 d7442414e86260bf43803d60d20da7d8e74cf4ec6f6c523ad03e091aa9a63c9299f12d29ba03f05792c822e4f4da35782be737b5b797b0c67a550b3d05fb9bd8
diff --git a/dev-vcs/gitsh/gitsh-0.11.2.ebuild b/dev-vcs/gitsh/gitsh-0.11.2.ebuild
new file mode 100644
index 000000000000..85f90bbc053b
--- /dev/null
+++ b/dev-vcs/gitsh/gitsh-0.11.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit autotools ruby-fakegem
+
+DESCRIPTION="An interactive shell for git"
+HOMEPAGE="https://github.com/thoughtbot/gitsh"
+SRC_URI="https://github.com/thoughtbot/gitsh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="test"
+
+RDEPEND+=" sys-libs/readline "
+
+DEPEND+=" test? ( dev-vcs/git ) "
+
+ruby_add_rdepend "
+ dev-ruby/bundler
+ dev-ruby/parslet
+ "
+
+ruby_add_bdepend "test? ( dev-ruby/pry )"
+
+DOCS="README.md"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+
+ # Avoid integration tests that assume they can use /usr/bin/ruby
+ rm -f spec/integration/running_scripts_spec.rb || die
+ # or the TTY
+ sed -i -e '/with valid arguments and no script file/,/^ end/ s:^:#:' spec/units/cli_spec.rb || die
+}
+
+each_ruby_prepare() {
+ eautoreconf
+
+ if use test; then
+ git init . || die
+ fi
+}
+
+each_ruby_configure() {
+ RUBY=${RUBY} default
+}
+
+each_ruby_compile() {
+ default
+}
+
+all_ruby_install() {
+ all_fakegem_install
+ doman "${S}"/man/man1/${PN}.1
+}
diff --git a/dev-vcs/gitsh/metadata.xml b/dev-vcs/gitsh/metadata.xml
new file mode 100644
index 000000000000..faa8f02e9175
--- /dev/null
+++ b/dev-vcs/gitsh/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">thoughtbot/gitsh</remote-id>
+ </upstream>
+</pkgmetadata>