summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-vcs/git/git-9999.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index ce8ae004896d..9d9a24a7ff94 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -51,7 +51,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -99,7 +99,7 @@ RDEPEND="${CDEPEND}
dev-perl/TermReadKey
)
)
- python? ( ${PYTHON_DEPS} )
+ perforce? ( ${PYTHON_DEPS} )
"
# This is how info docs are created with Git:
@@ -133,7 +133,7 @@ REQUIRED_USE="
subversion? ( perl )
webdav? ( curl )
pcre-jit? ( pcre )
- python? ( ${PYTHON_REQUIRED_USE} )
+ perforce? ( ${PYTHON_REQUIRED_USE} )
"
PATCHES=(
@@ -152,7 +152,7 @@ pkg_setup() {
ewarn "with USE=dso, there may be weird crashes in git-svn. You"
ewarn "have been warned."
fi
- if use python ; then
+ if use perforce ; then
python-single-r1_pkg_setup
fi
}
@@ -167,7 +167,7 @@ exportmakeopts() {
$(usex iconv '' NO_ICONV=YesPlease)
$(usex nls '' NO_GETTEXT=YesPlease)
$(usex perl 'INSTALLDIRS=vendor NO_PERL_CPAN_FALLBACKS=YesPlease' NO_PERL=YesPlease)
- $(usex python '' NO_PYTHON=YesPlease)
+ $(usex perforce '' NO_PYTHON=YesPlease)
$(usex subversion '' NO_SVN_TESTS=YesPlease)
$(usex threads '' NO_PTHREAD=YesPlease)
$(usex tk '' NO_TCLTK=YesPlease)
@@ -302,7 +302,7 @@ src_prepare() {
git_emake() {
# bug #320647: PYTHON_PATH
local PYTHON_PATH=""
- use python && PYTHON_PATH="${PYTHON}"
+ use perforce && PYTHON_PATH="${PYTHON}"
emake ${MY_MAKEOPTS} \
prefix="${EPREFIX}"/usr \
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \