summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-vcs/git/git-9999.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild41
1 files changed, 24 insertions, 17 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 65a6d23f6400..c305c57e6449 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
GENTOO_DEPEND_ON_PERL=no
@@ -107,6 +107,9 @@ RDEPEND="${CDEPEND}
# .xml/docbook --(docbook2texi.pl)--> .texi
# .texi --(makeinfo)---------> .info
DEPEND="${CDEPEND}
+ test? ( app-crypt/gnupg )"
+
+BDEPEND="
doc? (
app-text/asciidoc
app-text/docbook2X
@@ -114,11 +117,11 @@ DEPEND="${CDEPEND}
sys-apps/texinfo
)
nls? ( sys-devel/gettext )
- test? ( app-crypt/gnupg )"
+"
# Live ebuild builds man pages and HTML docs, additionally
if [[ ${PV} == *9999 ]]; then
- DEPEND="${DEPEND}
+ BDEPEND="${BDEPEND}
app-text/asciidoc"
fi
@@ -138,7 +141,7 @@ REQUIRED_USE="
PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
- "${FILESDIR}"/git-2.18.0_rc1-optional-cvs.patch
+ "${FILESDIR}"/git-2.22.0_rc0-optional-cvs.patch
"${FILESDIR}"/git-2.2.0-svn-fe-linking.patch
@@ -160,7 +163,9 @@ pkg_setup() {
# This is needed because for some obscure reasons future calls to make don't
# pick up these exports if we export them in src_unpack()
exportmakeopts() {
- local myopts=(
+ local extlibs myopts
+
+ myopts=(
ASCIIDOC_NO_ROFF=YesPlease
$(usex cvs '' NO_CVS=YesPlease)
$(usex elibc_musl NO_REGEX=YesPlease '')
@@ -237,12 +242,14 @@ exportmakeopts() {
NEEDS_LIBICONV=YesPlease
HAVE_CLOCK_MONOTONIC=1
)
- grep -q getdelim "${ROOT%/}"/usr/include/stdio.h && \
+ if grep -q getdelim "${EROOT}"/usr/include/stdio.h ; then
myopts+=( HAVE_GETDELIM=1 )
+ fi
fi
- has_version '>=app-text/asciidoc-8.0' \
- && myopts+=( ASCIIDOC8=YesPlease )
+ if has_version '>=app-text/asciidoc-8.0' ; then
+ myopts+=( ASCIIDOC8=YesPlease )
+ fi
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
@@ -443,7 +450,7 @@ src_install() {
#elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc}
# don't add automatically to the load-path, so the sitefile
# can do a conditional loading
- touch "${ED%/}${SITELISP}/${PN}/compat/.nosearch"
+ touch "${ED}${SITELISP}/${PN}/compat/.nosearch"
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
@@ -532,7 +539,7 @@ src_install() {
for i in "${contrib_objects[@]}" ; do
cp -rf \
"${S}"/contrib/${i} \
- "${ED%/}"/usr/share/${PN}/contrib \
+ "${ED}"/usr/share/${PN}/contrib \
|| die "Failed contrib ${i}"
done
@@ -548,19 +555,19 @@ src_install() {
newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
newdoc "${S}"/gitweb/README README.gitweb
- for d in "${ED%/}"/usr/lib{,64}/perl5/ ; do
+ for d in "${ED}"/usr/lib{,64}/perl5/ ; do
if test -d "${d}" ; then find "${d}" \
-name .packlist \
-delete || die
fi
done
else
- rm -rf "${ED%/}"/usr/share/gitweb
+ rm -rf "${ED}"/usr/share/gitweb
fi
if ! use subversion ; then
- rm -f "${ED%/}"/usr/libexec/git-core/git-svn \
- "${ED%/}"/usr/share/man/man1/git-svn.1*
+ rm -f "${ED}"/usr/libexec/git-core/git-svn \
+ "${ED}"/usr/share/man/man1/git-svn.1*
fi
if use xinetd ; then
@@ -581,8 +588,8 @@ src_install() {
# we could remove sources in src_prepare, but install does not
# handle missing locale dir well
rm_loc() {
- if [[ -e "${ED%/}/usr/share/locale/${1}" ]]; then
- rm -r "${ED%/}/usr/share/locale/${1}" || die
+ if [[ -e "${ED}/usr/share/locale/${1}" ]]; then
+ rm -r "${ED}/usr/share/locale/${1}" || die
fi
}
l10n_for_each_disabled_locale_do rm_loc
@@ -692,7 +699,7 @@ src_test() {
nonfatal git_emake aggregate-results
# And bail if there was a problem
- [ ${rc} -eq 0 ] || die "tests failed. Please file a bug."
+ [[ ${rc} -eq 0 ]] || die "tests failed. Please file a bug."
}
showpkgdeps() {