summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-vcs/git/git-9999.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 202ebcd97b24..fd9fa17c02f6 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
PLOCALES="bg ca de es fr is it ko pt_PT ru sv vi zh_CN"
if [[ ${PV} == *9999 ]]; then
SCM="git-r3"
@@ -69,6 +69,7 @@ CDEPEND="
webdav? ( dev-libs/expat )
)
emacs? ( virtual/emacs )
+ iconv? ( virtual/libiconv )
"
RDEPEND="${CDEPEND}
@@ -164,7 +165,7 @@ exportmakeopts() {
$(usex perl 'INSTALLDIRS=vendor NO_PERL_CPAN_FALLBACKS=YesPlease' NO_PERL=YesPlease)
$(usex python '' NO_PYTHON=YesPlease)
$(usex subversion '' NO_SVN_TESTS=YesPlease)
- $(usex threads THREADED_DELTA_SEARCH=YesPlease NO_PTHREAD=YesPlease)
+ $(usex threads '' NO_PTHREAD=YesPlease)
$(usex tk '' NO_TCLTK=YesPlease)
)
@@ -241,8 +242,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"
@@ -363,9 +366,10 @@ src_compile() {
use iconv && use !elibc_glibc && nlsiconv+=( -liconv )
git_emake EXTLIBS="${EXTLIBS} ${nlsiconv[@]}" \
|| die "emake svn-fe failed"
+ git_emake svn-fe.1 || die "emake svn-fe.1 failed"
if use doc ; then
- git_emake svn-fe.{1,html} \
- || die "emake svn-fe.1 svn-fe.html failed"
+ git_emake svn-fe.html \
+ || die "svn-fe.html failed"
fi
popd &>/dev/null || die
fi
@@ -377,8 +381,8 @@ src_compile() {
fi
pushd contrib/subtree &>/dev/null || die
- git_emake
- use doc && git_emake doc
+ git_emake git-subtree{,.1}
+ use doc && git_emake git-subtree.html
popd &>/dev/null || die
pushd contrib/diff-highlight &>/dev/null || die
@@ -394,9 +398,7 @@ src_compile() {
}
src_install() {
- git_emake \
- install || \
- die "make install failed"
+ git_emake install || die "make install failed"
if [[ ${CHOST} == *-darwin* ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -446,9 +448,9 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install git-subtree"
+ git_emake install install-man || die "Failed to emake install install-man git-subtree"
if use doc ; then
- git_emake install-man install-doc || die "Failed to emake install-doc install-mangit-subtree"
+ git_emake install-html || die "Failed to emake install-html git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -483,9 +485,9 @@ src_install() {
if use subversion ; then
pushd contrib/svn-fe &>/dev/null || die
dobin svn-fe
+ doman svn-fe.1
dodoc svn-fe.txt
if use doc ; then
- doman svn-fe.1
docinto html
dodoc svn-fe.html
fi