summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-18 16:12:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-18 16:12:56 +0100
commitae7f349673c9e013e85bbc65e873d3363467a293 (patch)
tree0ae90623ff8081894ad526c05a94ad9ca84f1ea4 /dev-vcs/git/git-9999.ebuild
parent8ea6e43d2f65acbfda614dbd4635823d7605b6d8 (diff)
gentoo auto-resync : 18:05:2023 - 16:12:55
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index ce146cc61342..867bbd70fc71 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -58,7 +58,7 @@ S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc gnome-keyring +gpg highlight +iconv mediawiki +nls +pcre perforce +perl +safe-directory selinux subversion tk +webdav xinetd cvs test"
+IUSE="+blksha1 +curl cgi doc keyring +gpg highlight +iconv mediawiki +nls +pcre perforce +perl +safe-directory selinux subversion tk +webdav xinetd cvs test"
# Common to both DEPEND and RDEPEND
DEPEND="
@@ -68,7 +68,7 @@ DEPEND="
net-misc/curl
webdav? ( dev-libs/expat )
)
- gnome-keyring? (
+ keyring? (
app-crypt/libsecret
dev-libs/glib:2
)
@@ -120,7 +120,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
- gnome-keyring? ( virtual/pkgconfig )
+ keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -343,7 +343,7 @@ src_compile() {
fi
popd &>/dev/null || die
- if use gnome-keyring ; then
+ if use keyring ; then
git_emake -C contrib/credential/libsecret
fi
@@ -543,7 +543,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use gnome-keyring ; then
+ if use keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
dobin git-credential-libsecret
popd &>/dev/null || die