summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-vcs/git/git-9999.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 4a1d6a07b908..6af4b971bc56 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
GENTOO_DEPEND_ON_PERL=no
@@ -46,7 +46,7 @@ if [[ ${PV} != *9999 ]]; then
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
[[ "${PV}" == *_rc* ]] || \
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -141,7 +141,7 @@ RESTRICT="!test? ( test )"
PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
- "${FILESDIR}"/git-2.22.0_rc0-optional-cvs.patch
+ "${FILESDIR}"/git-2.33.0_rc0-optional-cvs.patch
# Make submodule output quiet
"${FILESDIR}"/git-2.21.0-quiet-submodules-testcase.patch
@@ -319,7 +319,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* ]]; then
+ if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -366,7 +366,7 @@ src_compile() {
src_install() {
git_emake install || die "make install failed"
- if [[ ${CHOST} == *-darwin* ]]; then
+ if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi