summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /dev-vcs/git/git-9999-r3.ebuild
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'dev-vcs/git/git-9999-r3.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 051c0134564e..d691700475c6 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -7,9 +7,12 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit toolchain-funcs elisp-common l10n perl-module bash-completion-r1 python-single-r1 systemd
+
PLOCALES="bg ca de es fr is it ko pt_PT ru sv vi zh_CN"
if [[ ${PV} == *9999 ]]; then
- SCM="git-r3"
+ inherit git-r3
EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
# Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
# See https://git-scm.com/docs/gitworkflows#_graduation
@@ -26,12 +29,10 @@ if [[ ${PV} == *9999 ]]; then
esac
fi
-inherit toolchain-funcs elisp-common l10n perl-module bash-completion-r1 python-single-r1 systemd ${SCM}
-
MY_PV="${PV/_rc/.rc}"
MY_P="${PN}-${MY_PV}"
-DOC_VER=${MY_PV}
+DOC_VER="${MY_PV}"
DESCRIPTION="stupid content tracker: distributed VCS designed for speed and efficiency"
HOMEPAGE="https://www.git-scm.com/"
@@ -44,7 +45,7 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- [[ "${PV}" = *_rc* ]] || \
+ [[ "${PV}" == *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -109,8 +110,8 @@ DEPEND="${CDEPEND}
doc? (
app-text/asciidoc
app-text/docbook2X
- sys-apps/texinfo
app-text/xmlto
+ sys-apps/texinfo
)
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )"
@@ -140,6 +141,9 @@ PATCHES=(
"${FILESDIR}"/git-2.22.0_rc0-optional-cvs.patch
"${FILESDIR}"/git-2.2.0-svn-fe-linking.patch
+
+ # Make submodule output quiet
+ "${FILESDIR}"/git-2.21.0-quiet-submodules-testcase.patch
)
pkg_setup() {
@@ -366,8 +370,10 @@ src_compile() {
use iconv && use !elibc_glibc && nlsiconv+=( -liconv )
git_emake EXTLIBS="${EXTLIBS} ${nlsiconv[@]}" \
|| die "emake svn-fe failed"
- git_emake svn-fe.1 || die "emake svn-fe.1 failed"
if use doc ; then
+ # svn-fe.1 requires the full USE=doc dependency stack
+ git_emake svn-fe.1 \
+ || die "emake svn-fe.1 failed"
git_emake svn-fe.html \
|| die "svn-fe.html failed"
fi
@@ -381,8 +387,9 @@ src_compile() {
fi
pushd contrib/subtree &>/dev/null || die
- git_emake git-subtree{,.1}
- use doc && git_emake git-subtree.html
+ git_emake git-subtree
+ # git-subtree.1 requires the full USE=doc dependency stack
+ use doc && git_emake git-subtree.html git-subtree.1
popd &>/dev/null || die
pushd contrib/diff-highlight &>/dev/null || die
@@ -448,9 +455,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install install-man || die "Failed to emake install install-man git-subtree"
+ git_emake install || die "Failed to emake install for git-subtree"
if use doc ; then
- git_emake install-html || die "Failed to emake install-html git-subtree"
+ # Do not move git subtree install-man outside USE=doc!
+ git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -485,9 +493,10 @@ src_install() {
if use subversion ; then
pushd contrib/svn-fe &>/dev/null || die
dobin svn-fe
- doman svn-fe.1
dodoc svn-fe.txt
if use doc ; then
+ # Do not move svn-fe.1 outside USE=doc!
+ doman svn-fe.1
docinto html
dodoc svn-fe.html
fi