summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-2.32.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-vcs/git/git-2.32.0-r1.ebuild
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-vcs/git/git-2.32.0-r1.ebuild')
-rw-r--r--dev-vcs/git/git-2.32.0-r1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-vcs/git/git-2.32.0-r1.ebuild b/dev-vcs/git/git-2.32.0-r1.ebuild
index 3967c829181e..d9b4b7cd33ed 100644
--- a/dev-vcs/git/git-2.32.0-r1.ebuild
+++ b/dev-vcs/git/git-2.32.0-r1.ebuild
@@ -295,7 +295,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -368,7 +367,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -418,10 +417,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -429,7 +428,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi