summaryrefslogtreecommitdiff
path: root/dev-vcs/git-publish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-vcs/git-publish
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-vcs/git-publish')
-rw-r--r--dev-vcs/git-publish/Manifest3
-rw-r--r--dev-vcs/git-publish/git-publish-1.7.0.ebuild43
-rw-r--r--dev-vcs/git-publish/metadata.xml17
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-vcs/git-publish/Manifest b/dev-vcs/git-publish/Manifest
new file mode 100644
index 000000000000..1131beed3d62
--- /dev/null
+++ b/dev-vcs/git-publish/Manifest
@@ -0,0 +1,3 @@
+DIST git-publish-1.7.0.tar.gz 21569 BLAKE2B 1438e5018ebe7d258fee2527597e56080b574765a87b03d814b6d0d41c68397cba6099866382e9f2c560d8bab58214fb9e5f54f0127433917178337df81ff789 SHA512 dbf343e0284c52edd42ba8d844a9db90810ddd02e7a98bcd1c2af72cd9f5242e9c0a9ea921edf47583bfe05943288286e57a018a7a6b2dcf25bae4f663225025
+EBUILD git-publish-1.7.0.ebuild 913 BLAKE2B 8a95cd61903dd64675c3fcde220b41170aedd9f19e79fd6fd9a435e03c8b887717a0fcb82cf18d599adeaa82feecbf4300c00a5580a392f4469c9978bb8affe0 SHA512 7dbcfd568e2186c352f495ac27d79798df4f0aeb039acb5feb0d6df851ba028e127f636e0befa012db47907778e28a86cc7df278615d1723ed4c1c8e9bcc8bee
+MISC metadata.xml 576 BLAKE2B 1dfa47470c8ff5c1fb852d1e16a8acf4984d08be910e666b8910b95dd693f08bc0507bbd83c885f28af1777838eff713906f33c991a7b08de6ff82ec3f2cec2e SHA512 a342fa5037d547429908fdc3b61b6acd153896a3875164555226bfe8d11d6d4c465c69b217c2c29cc5a6b35504c784f1c706e87fe18bb68f2c5099a4fec1a083
diff --git a/dev-vcs/git-publish/git-publish-1.7.0.ebuild b/dev-vcs/git-publish/git-publish-1.7.0.ebuild
new file mode 100644
index 000000000000..7a000d781109
--- /dev/null
+++ b/dev-vcs/git-publish/git-publish-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit python-single-r1
+
+DESCRIPTION="Tool for preparing and storing patch revisions as git tag"
+HOMEPAGE="https://github.com/stefanha/git-publish"
+SRC_URI="https://github.com/stefanha/git-publish/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+man"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-vcs/git
+"
+BDEPEND="${PYTHON_DEPS}
+ man? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+ python_fix_shebang git-publish
+}
+
+src_compile() {
+ if use man; then
+ pod2man --center "git-publish Documentation" --release "${PV}" \
+ git-publish.pod git-publish.1 || die
+ fi
+}
+
+src_install() {
+ dobin git-publish
+ use man && doman git-publish.1
+ insinto /usr/share/${PN}/hooks
+ doins hooks/pre-publish-send-email.example
+}
diff --git a/dev-vcs/git-publish/metadata.xml b/dev-vcs/git-publish/metadata.xml
new file mode 100644
index 000000000000..b97d2e99f3b7
--- /dev/null
+++ b/dev-vcs/git-publish/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ git-publish prepares patches and stores them as git tags for future reference.
+ It works with individual patches as well as patch series. Revision numbering
+ is handled automatically.
+ </longdescription>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">stefanha/git-publish</remote-id>
+ </upstream>
+</pkgmetadata>