summaryrefslogtreecommitdiff
path: root/dev-vcs/git-machete
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /dev-vcs/git-machete
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'dev-vcs/git-machete')
-rw-r--r--dev-vcs/git-machete/Manifest3
-rw-r--r--dev-vcs/git-machete/git-machete-3.12.0.ebuild41
-rw-r--r--dev-vcs/git-machete/metadata.xml23
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
new file mode 100644
index 000000000000..0443ad8fba5a
--- /dev/null
+++ b/dev-vcs/git-machete/Manifest
@@ -0,0 +1,3 @@
+DIST git-machete-3.12.0.gh.tar.gz 1377199 BLAKE2B 82c4287efe902f6571504a5b2a793aa3c1b61a526db4262456bd617897b16e30ba2713f7900fa8482f7b30b75e6b76257cefaed154ec41e7e54f3097565a60bc SHA512 6a6168c7d8f0fb406b1ddb471f280a31dac4406a058006b62f4a4d8b5f8e1b681e460a59671acd091cf8411c1d3050c175544a4e18f21522297811c89ac9a271
+EBUILD git-machete-3.12.0.ebuild 1137 BLAKE2B 3e7db8596969bf73c0cfb7078200a52d8387db122cee27dd11dda8fca09ae3b1e8b1ea0ab7972640f5a5616aa9f7491aabac3b040331ed2c29c3220ec299230c SHA512 ae6b2d73dfc0edeb16524b9e56f45386436f95ec0566300ad0817f9defc858ea8b89b62250dd43b96c3999e7e5be4f4653d2d599dd6eedced2e434779487903b
+MISC metadata.xml 835 BLAKE2B f59f4070f862a09fb74c57b5ef093e4c8d1394887f71b8f490e49e49f64722b48ab44f15907edb0eff322227f5a97aaf5d2d92512c818b8aa1020e6f735971c8 SHA512 d31266b47abfef805f0f0ae5f13c1f89ec13907fc7e33e126eefee5600087ffadf8f55e48c5c42c295dc7de8d901a3231db0756a79d666651569a150d7016cea
diff --git a/dev-vcs/git-machete/git-machete-3.12.0.ebuild b/dev-vcs/git-machete/git-machete-3.12.0.ebuild
new file mode 100644
index 000000000000..d84db41daa4c
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repository organizer & rebase/merge workflow automation tool you've ever seen"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ >=dev-python/pytest-mock-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+)"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+}
diff --git a/dev-vcs/git-machete/metadata.xml b/dev-vcs/git-machete/metadata.xml
new file mode 100644
index 000000000000..c10080a3b72a
--- /dev/null
+++ b/dev-vcs/git-machete/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ git-machete is a robust tool that simplifies your git workflows.
+
+ The bird's eye view provided by git-machete makes merges/rebases/push/pulls
+ hassle-free even when multiple branches are present in the repository
+ (master/develop, your topic branches, teammate's branches checked out
+ for review, etc.).
+
+ Using this tool, you can maintain small, focused, easy-to-review pull
+ requests with little effort.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">VirtusLab/git-machete</remote-id>
+ <remote-id type="pypi">git-machete</remote-id>
+ </upstream>
+</pkgmetadata>