summaryrefslogtreecommitdiff
path: root/dev-vcs/git-lfs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-vcs/git-lfs
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-vcs/git-lfs')
-rw-r--r--dev-vcs/git-lfs/Manifest4
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.12.1.ebuild62
-rw-r--r--dev-vcs/git-lfs/git-lfs-9999.ebuild26
3 files changed, 78 insertions, 14 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index 6c86fc60f503..7ef7f1807707 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,4 +1,6 @@
DIST git-lfs-2.11.0.tar.gz 2839623 BLAKE2B e9d0e8ea37f19617a4f727abdc93c3c937052ad98b6ac40de27ced6b250789701797d04f1bf795b259e83155e5d8a1ca122dbf8b40503c2c41d6d891a3ecf096 SHA512 2117b425864a36f773c14d34c78999636d836646184cf8d89045ef6de90cbded873d4de4613ecfafb0fa2ea8ae068e11f5ae22eed6af01715b5fac9be70f033b
+DIST git-lfs-2.12.1.tar.gz 2848245 BLAKE2B 745a1ad252b925074a9ddfd9f899098dfca0b672b176178675652d910737f76c2c55aa502d0a544ad36a7eee00a464e12b9bb178ccd1fb118c2a96b362de80d1 SHA512 728bf414910a9a9106ea6769b939aae9ec25976e686399d0612e8ff99131a6571641b4121cb123ad6c32fc6dd59674ca50416a48e4771924b27062326df78ce0
EBUILD git-lfs-2.11.0.ebuild 1392 BLAKE2B d6e33aa99c265dd3e2fd889c5bd9a70b751e15cc9757343e1e1bd7bec432e8015611e7b3009d1cd291eaa6b69e0a6fb7581d50f744f1a164d52936095ee5c03d SHA512 497ae5f9fa85cc412cb1708f13e75acaafc4087c5243aee8bdc9ff4567756cd60602cda6092ea1f98fe560a7ae9a6a05f69ffbb862136d2782b2850d8512ad15
-EBUILD git-lfs-9999.ebuild 1388 BLAKE2B 5ba84f64abbf39b34d4c68498507880b5581d9497a22e1d0fcb5101de896fdfa5ef77f94470a50c42769c1effb9500edcc3d7f304f7e750720f19a104cd99b90 SHA512 e79fb26dd99c369c2877eba3f1d0bd5b4e8797bacd5eba4424a055696a0f3968f481c19b18acd8ff320df8b56901f738b04cdd30d2b0ad313a3495833a9a0462
+EBUILD git-lfs-2.12.1.ebuild 1533 BLAKE2B e946cc14e7954b40e712bc8afeafbd5227f37aa5f2b6b9c1bf966845b914a81212ded0a6d2158ce770f207fc5fcd39280a13cd1a809c2414e2c854bcbb83fd3d SHA512 2a196f4170676e72faadfcb489e4e152a4cdc28ba4bb21c38b2c11f91731d7136f32a511b5abecc32b37d3adbca04ed0c32991232f9d23503363f806bb19f8c7
+EBUILD git-lfs-9999.ebuild 1533 BLAKE2B e946cc14e7954b40e712bc8afeafbd5227f37aa5f2b6b9c1bf966845b914a81212ded0a6d2158ce770f207fc5fcd39280a13cd1a809c2414e2c854bcbb83fd3d SHA512 2a196f4170676e72faadfcb489e4e152a4cdc28ba4bb21c38b2c11f91731d7136f32a511b5abecc32b37d3adbca04ed0c32991232f9d23503363f806bb19f8c7
MISC metadata.xml 558 BLAKE2B 307387b4326dd3982b949f3dc06f69efa31fcd70cbb03b1c68a5557965fdc14bb32f638a644c951ec06bf979baf8046228bf0820c9dac96a3d984c3cec3b32eb SHA512 8ae42faa56a37e9ebbd3c6fba90e4e87b44f8022ffb2bc3fb2eb7128c5bf7c34497c7a13c73252db5b5096135ed153a61c74382a54870c32c36eba7af23f7cbe
diff --git a/dev-vcs/git-lfs/git-lfs-2.12.1.ebuild b/dev-vcs/git-lfs/git-lfs-2.12.1.ebuild
new file mode 100644
index 000000000000..f5a948c8f4fd
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.12.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/git-lfs/git-lfs
+inherit go-module
+
+DESCRIPTION="Command line extension and specification for managing large files with git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+if [[ "${PV}" = 9999* ]]; then
+ EGIT_REPO_URI="https://${EGO_PN}"
+ inherit git-r3
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
+SLOT="0"
+IUSE="doc test"
+
+BDEPEND="doc? ( app-text/ronn )"
+RDEPEND="dev-vcs/git"
+
+RESTRICT+=" !test? ( test )"
+
+src_compile() {
+ # Flags -w, -s: Omit debugging information to reduce binary size,
+ # see https://golang.org/cmd/link/.
+ local mygobuildargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
+ -mod vendor -v -work -x
+ )
+ go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin git-lfs
+ dodoc {CHANGELOG,CODE-OF-CONDUCT,CONTRIBUTING,README}.md
+ use doc && doman docs/man/*.1
+}
+
+src_test() {
+ local mygotestargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
+ -mod vendor
+ )
+ go test "${mygotestargs[@]}" ./... || die
+}
+
+pkg_postinst () {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog ""
+ elog "Run \'git lfs install\' once for each user account manually."
+ elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
+ fi
+}
diff --git a/dev-vcs/git-lfs/git-lfs-9999.ebuild b/dev-vcs/git-lfs/git-lfs-9999.ebuild
index a48a6fe6e6c6..f5a948c8f4fd 100644
--- a/dev-vcs/git-lfs/git-lfs-9999.ebuild
+++ b/dev-vcs/git-lfs/git-lfs-9999.ebuild
@@ -13,7 +13,7 @@ if [[ "${PV}" = 9999* ]]; then
inherit git-r3
else
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
@@ -26,12 +26,13 @@ RDEPEND="dev-vcs/git"
RESTRICT+=" !test? ( test )"
src_compile() {
- set -- go build \
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}" \
- -mod vendor -v -work -x \
- -o git-lfs git-lfs.go
- echo "$@"
- "$@" || die
+ # Flags -w, -s: Omit debugging information to reduce binary size,
+ # see https://golang.org/cmd/link/.
+ local mygobuildargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
+ -mod vendor -v -work -x
+ )
+ go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
if use doc; then
ronn docs/man/*.ronn || die "man building failed"
@@ -45,12 +46,11 @@ src_install() {
}
src_test() {
- set -- go test \
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}" \
- -mod vendor \
- ./...
- echo "$@"
- "$@" || die
+ local mygotestargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
+ -mod vendor
+ )
+ go test "${mygotestargs[@]}" ./... || die
}
pkg_postinst () {