summaryrefslogtreecommitdiff
path: root/dev-vcs/git-lfs/git-lfs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-08 09:27:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-08 09:27:00 +0100
commitafdfa05c5ce824f49340d033a80cdee422ac264a (patch)
treee0d45d2626035a2af2187a8359cd122dd9d4a21b /dev-vcs/git-lfs/git-lfs-9999.ebuild
parent6cefebc8e850c862f7623af22feef1b895a79884 (diff)
gentoo auto-resync : 08:08:2023 - 09:27:00
Diffstat (limited to 'dev-vcs/git-lfs/git-lfs-9999.ebuild')
-rw-r--r--dev-vcs/git-lfs/git-lfs-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-vcs/git-lfs/git-lfs-9999.ebuild b/dev-vcs/git-lfs/git-lfs-9999.ebuild
index 7b98fd42b0f3..10b83717c479 100644
--- a/dev-vcs/git-lfs/git-lfs-9999.ebuild
+++ b/dev-vcs/git-lfs/git-lfs-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
EGO_PN=github.com/git-lfs/git-lfs
# Update the ID as it's included in each build.
-COMMIT_ID="77deabdf9a18f8a07ecfd3e0f4aa572ffbbab8d4"
+COMMIT_ID="d06d6e9efd78ff4f958b072146ce167d87f60285"
inherit go-module
@@ -18,9 +18,15 @@ if [[ "${PV}" = 9999* ]]; then
EGIT_REPO_URI="https://${EGO_PN}"
inherit git-r3
else
- SRC_URI="https://${EGO_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://${EGO_PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
# Add the manually vendored tarball.
- # Compress the tarball with: xz -9kT0 --memlimit-decompress=256M
+ # 1) Create a tar archive optimized to reproduced by other users or devs.
+ # 2) Compress the archive using XZ limiting decompression memory for
+ # pretty constraint systems.
+ # Use something like:
+ # tar cf $P-deps.tar go-mod \
+ # --mtime="1970-01-01" --sort=name --owner=portage --group=portage
+ # xz -k -9eT0 --memlimit-decompress=256M $P-deps.tar
SRC_URI+=" https://files.holgersson.xyz/gentoo/distfiles/golang-pkg-deps/${P}-deps.tar.xz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi