summaryrefslogtreecommitdiff
path: root/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild')
-rw-r--r--dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
new file mode 100644
index 000000000000..321bde43f057
--- /dev/null
+++ b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+inherit distutils-r1
+
+DESCRIPTION="Quickly rewrite git repository history (filter-branch replacement)"
+HOMEPAGE="https://github.com/newren/git-filter-repo/"
+SRC_URI="https://github.com/newren/git-filter-repo/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-vcs/git-$(ver_cut 1-2)
+"
+
+S="${S}/release"
+
+python_prepare_all() {
+ cat > PKG-INFO <<-EOF || die
+ Metadata-Version: 2.1
+ Name: git-filter-repo
+ Version: ${PV}
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ bash t/run_tests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # Points to dead symlink
+ rm "${ED}"/usr/share/doc/${PF}/README.md || die
+ rmdir "${ED}"/usr/share/doc/${PF} || Die
+
+ dodoc "${WORKDIR}"/${P}/README.md
+}