summaryrefslogtreecommitdiff
path: root/dev-vcs/git-extras/git-extras-6.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 19:30:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 19:30:29 +0100
commit541eca7cf7b9950f0adaaf9158f94c76ba0aedc9 (patch)
treeb80d0f20ca0dc04843c819a54cc618cc8baf0479 /dev-vcs/git-extras/git-extras-6.5.0.ebuild
parent4df758340c38fb7f188a6356561aeb4ed2c3f38c (diff)
gentoo auto-resync : 08:10:2022 - 19:30:29
Diffstat (limited to 'dev-vcs/git-extras/git-extras-6.5.0.ebuild')
-rw-r--r--dev-vcs/git-extras/git-extras-6.5.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-vcs/git-extras/git-extras-6.5.0.ebuild b/dev-vcs/git-extras/git-extras-6.5.0.ebuild
new file mode 100644
index 000000000000..876db89e90ea
--- /dev/null
+++ b/dev-vcs/git-extras/git-extras-6.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Git utilities -- repo summary, repl, changelog population, and many more"
+HOMEPAGE="https://github.com/tj/git-extras"
+SRC_URI="https://github.com/tj/git-extras/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos"
+
+RDEPEND="
+ app-shells/bash
+ dev-vcs/git
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.5.0-no-bash-completion-install.patch
+)
+
+src_prepare() {
+ default
+
+ # For now, don't force including the git completion
+ # sed -i -e "1 i source $(get_bashcompdir)\/git" etc/bash_completion.sh || die
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ SYSCONFDIR="${EPREFIX}/etc" \
+ install
+
+ # TODO: Unfortunately, none of the completion seems to
+ # actually work for me yet(?)
+
+ #newbashcomp "${S}"/etc/bash_completion.sh ${PN}
+
+ #insinto /usr/share/zsh/site-functions
+ #newins "${S}"/etc/${PN}-completion.zsh _${PN}
+
+ #insinto /usr/share/fish/vendor_completions.d
+ #doins "${S}"/etc/${PN}.fish
+}