summaryrefslogtreecommitdiff
path: root/dev-vcs/git-deps/git-deps-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-vcs/git-deps/git-deps-9999.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/git-deps/git-deps-9999.ebuild')
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
deleted file mode 100644
index f66f91356572..000000000000
--- a/dev-vcs/git-deps/git-deps-9999.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="https://github.com/aspiers/git-deps"
-EGIT_BRANCH=master
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils git-r3 python-single-r1
-
-DESCRIPTION="git commit dependency analysis tool"
-HOMEPAGE="https://github.com/aspiers/git-deps"
-
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/pygit2[${PYTHON_USEDEP}]
- net-libs/nodejs
- ${PYTHON_DEPS}
- "
-DEPEND="${RDEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-HTML_DOCS="html/."
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_install() {
- python_newscript git-deps.py git-deps
- einstalldocs
-}
-
-pkg_postinst() {
- elog "Notes regarding the '--serve' option:"
- elog "Please run 'npm install browserify' once"
- elog "Copy the html sources:"
- elog "rsync -av ${EROOT}/usr/share/${PN}/html ~/git-deps-html"
- elog "cd ~/git-deps-html"
- elog "npm install"
- elog "browserify -t coffeeify -d js/git-deps-graph.coffee -o js/bundle.js"
-}