summaryrefslogtreecommitdiff
path: root/dev-vcs/git-cola
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-vcs/git-cola
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/Manifest2
-rw-r--r--dev-vcs/git-cola/git-cola-3.2.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-vcs/git-cola/Manifest b/dev-vcs/git-cola/Manifest
index 0d4967208572..c09b056726b5 100644
--- a/dev-vcs/git-cola/Manifest
+++ b/dev-vcs/git-cola/Manifest
@@ -2,5 +2,7 @@ AUX README.gentoo 227 BLAKE2B 828266fe46d9eb866250b57921df446055c7835cce3c3d1701
AUX git-cola-2.10-disable-live-tests.patch 827 BLAKE2B f7778c373b4e7b2c09daeeeab5c15c09870a70f8d490d2bd16d2e1b62f0c96c4bec6517cc99fa8d0a65daeb1551993d4e367f39f60099afdf31597847762ee39 SHA512 86f7410ce711db2dc19d4348047285dbd1a3c078512d13b589ef898dfd870a4f459371319965c697d8654dd4550a358e67e5d6b74c0317820422c3e98b7084a9
AUX index.html 355 BLAKE2B 24c532f3882744fe3be55fbef8eb35410849124baeffc56659fa6200140ec7059bfee2323443a5ea62481b6b4c43b6fcc1e116acf8f67082ade03b2a8a23aed1 SHA512 a3e66bb220ae05c2f49a75ce413c5aeefb9ced26f7e8b2175b32ade83663153fab94f8601b1d0182d1eeb907edc6c1bef3ad96d84b1e6c00ca4d5a816be79bac
DIST git-cola-2.11.tar.gz 1179769 BLAKE2B db2926b8137b2bb11cc9698b37156d8b0c8f72068061d7d1598b2e3237e44764c2914923103aaaa704babe26cf7a7c16bbe28a61770d98954f776b8ce955658a SHA512 99b865d7a49dcb041e54811141d242386642b5ed6fc12fa7a03431eb9b905cb88d88c4892dc432dd59e8ae3c85f20cc40f4bfb9b6ff002f4e5a4cfc0bdc4c72c
+DIST git-cola-3.2.tar.gz 1208723 BLAKE2B e0375502c7b760a35217c48708e34ba061934f968e6720c3560603b5a76c9474a3a8426f2120ee853a9ac475fc9cbc33ee6ee9a946336e1f28a89d541785c535 SHA512 ca171549dad692088e337efad6f480103a41a1a94f57ae66c15fab3d69e3b18ecc28ac1178886fedd6d969f783e8d5feb4922539c1739ce52c0c0ac59dc941ee
EBUILD git-cola-2.11.ebuild 2446 BLAKE2B 47be464f83286b7f1c341b762abaf7fb05e787fb178dc2b0f565dbb77294a3c564adf1159e1276d05ee99ee0933ca386792828215b5531bb0e4144d053a770e0 SHA512 b73a4b57ec6e843ff2ea2e0cc5a86020653fbc097259fc3058f6c809f6c6986d4b4a77eb97e90de4206c9ae2c53c30b4c3a3198e99c87ab23ada5dfaadb7910a
+EBUILD git-cola-3.2.ebuild 2326 BLAKE2B c765e3f1c4d9dc07bb2e10c6c001330718bf24b23542fa2acb5c75918d776a8a69deaa5749410b2409b9edbe299c5fa29ad3130f21a36546bd1efc9add5c8e0c SHA512 00c63f9819b0f76804f38268e907e9679139f347a4a7b536812747245ae4427c2537320e4fed6e94a9023a9dd09069612c2be60f80219ce114b16aa20a96045e
MISC metadata.xml 342 BLAKE2B 3c25a34b0009e31ea7a125733b8105d40be8d818106b7051d6b4180a8f4c39e16ce46eada9acef2cb5424d3fdc36965bdddb3f048c07b6920593a57d6ffff001 SHA512 9ef75fe8465b602db4d9645535f9ce228af6afffac7309c5f3e7dbe266fe5c89a08e96bc53c2fb4a364a8c3ec6c3d87579eb076d6ba005499f0f4f07316caecb
diff --git a/dev-vcs/git-cola/git-cola-3.2.ebuild b/dev-vcs/git-cola/git-cola-3.2.ebuild
new file mode 100644
index 000000000000..02897b8b6a98
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-3.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 readme.gentoo-r1 virtualx
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="https://git-cola.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/QtPy[gui,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ python_targets_python2_7? ( dev-python/sphinxtogithub[$(python_gen_usedep 'python2*')] )
+ )
+ test? (
+ ${VIRTUALX_DEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # make sure that tests also use the system provided QtPy
+ rm -r qtpy || die
+
+ rm share/git-cola/bin/*askpass* || die
+
+ # don't install docs into wrong location
+ sed -i -e '/doc/d' setup.py || die
+
+ # fix doc directory reference
+ sed -i \
+ -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
+ cola/resources.py || die
+
+ # fix ssh-askpass directory reference
+ sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=( --no-vendor-libs )
+}
+
+python_compile_all() {
+ cd share/doc/${PN}/ || die
+ if use doc ; then
+ emake all
+ else
+ sed \
+ -e '/^install:/s:install-html::g' \
+ -e '/^install:/s:install-man::g' \
+ -i Makefile || die
+ fi
+}
+
+python_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="en_US.utf8" \
+ virtx nosetests --verbose --with-id --with-doctest \
+ --exclude=sphinxtogithub
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+python_install_all() {
+ cd share/doc/${PN}/ || die
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase" "${ED}"/usr/bin/git-cola
+ python_optimize "${ED}/usr/share/git-cola/lib/cola"
+
+ use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
+
+ distutils-r1_python_install_all
+ readme.gentoo_create_doc
+}