summaryrefslogtreecommitdiff
path: root/dev-vcs/git-cola
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/git-cola
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/Manifest6
-rw-r--r--dev-vcs/git-cola/files/README.gentoo3
-rw-r--r--dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch24
-rw-r--r--dev-vcs/git-cola/files/index.html15
-rw-r--r--dev-vcs/git-cola/git-cola-2.11.ebuild104
-rw-r--r--dev-vcs/git-cola/metadata.xml11
6 files changed, 163 insertions, 0 deletions
diff --git a/dev-vcs/git-cola/Manifest b/dev-vcs/git-cola/Manifest
new file mode 100644
index 000000000000..0d4967208572
--- /dev/null
+++ b/dev-vcs/git-cola/Manifest
@@ -0,0 +1,6 @@
+AUX README.gentoo 227 BLAKE2B 828266fe46d9eb866250b57921df446055c7835cce3c3d17014563451acfc100f0e3ade6805514d620852273f011c12a8dd581ad90ffa135e5ab168a87790d46 SHA512 9e8b672fe6998a255dea761e186d5a9031895e8ec0eb14d4942c81a462a238ef1eec0431671da8be3ee4bbacd7f81cec6ec1f9e75e2f4429c3472faad5ba2c2d
+AUX git-cola-2.10-disable-live-tests.patch 827 BLAKE2B f7778c373b4e7b2c09daeeeab5c15c09870a70f8d490d2bd16d2e1b62f0c96c4bec6517cc99fa8d0a65daeb1551993d4e367f39f60099afdf31597847762ee39 SHA512 86f7410ce711db2dc19d4348047285dbd1a3c078512d13b589ef898dfd870a4f459371319965c697d8654dd4550a358e67e5d6b74c0317820422c3e98b7084a9
+AUX index.html 355 BLAKE2B 24c532f3882744fe3be55fbef8eb35410849124baeffc56659fa6200140ec7059bfee2323443a5ea62481b6b4c43b6fcc1e116acf8f67082ade03b2a8a23aed1 SHA512 a3e66bb220ae05c2f49a75ce413c5aeefb9ced26f7e8b2175b32ade83663153fab94f8601b1d0182d1eeb907edc6c1bef3ad96d84b1e6c00ca4d5a816be79bac
+DIST git-cola-2.11.tar.gz 1179769 BLAKE2B db2926b8137b2bb11cc9698b37156d8b0c8f72068061d7d1598b2e3237e44764c2914923103aaaa704babe26cf7a7c16bbe28a61770d98954f776b8ce955658a SHA512 99b865d7a49dcb041e54811141d242386642b5ed6fc12fa7a03431eb9b905cb88d88c4892dc432dd59e8ae3c85f20cc40f4bfb9b6ff002f4e5a4cfc0bdc4c72c
+EBUILD git-cola-2.11.ebuild 2446 BLAKE2B 47be464f83286b7f1c341b762abaf7fb05e787fb178dc2b0f565dbb77294a3c564adf1159e1276d05ee99ee0933ca386792828215b5531bb0e4144d053a770e0 SHA512 b73a4b57ec6e843ff2ea2e0cc5a86020653fbc097259fc3058f6c809f6c6986d4b4a77eb97e90de4206c9ae2c53c30b4c3a3198e99c87ab23ada5dfaadb7910a
+MISC metadata.xml 342 BLAKE2B 3c25a34b0009e31ea7a125733b8105d40be8d818106b7051d6b4180a8f4c39e16ce46eada9acef2cb5424d3fdc36965bdddb3f048c07b6920593a57d6ffff001 SHA512 9ef75fe8465b602db4d9645535f9ce228af6afffac7309c5f3e7dbe266fe5c89a08e96bc53c2fb4a364a8c3ec6c3d87579eb076d6ba005499f0f4f07316caecb
diff --git a/dev-vcs/git-cola/files/README.gentoo b/dev-vcs/git-cola/files/README.gentoo
new file mode 100644
index 000000000000..0f4af85d5ccc
--- /dev/null
+++ b/dev-vcs/git-cola/files/README.gentoo
@@ -0,0 +1,3 @@
+Please make sure you have either a SSH key management installed and activated or
+installed a SSH askpass app like net-misc/x11-ssh-askpass.
+Otherwise git-cola may hang when pushing/pulling from remote git repositories via SSH.
diff --git a/dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch b/dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch
new file mode 100644
index 000000000000..1f58ea0eddb6
--- /dev/null
+++ b/dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch
@@ -0,0 +1,24 @@
+diff --git a/test/git_test.py b/test/git_test.py
+index 9f812b2..ff7da24 100644
+--- a/test/git_test.py
++++ b/test/git_test.py
+@@ -53,19 +53,6 @@ class GitCommandTest(unittest.TestCase):
+ version = self.git.version()[STDOUT]
+ self.failUnless(version.startswith('git version'))
+
+- def test_tag(self):
+- """Test running 'git tag'"""
+- tags = self.git.tag()[STDOUT].splitlines()
+- if os.getenv('GIT_COLA_NO_HISTORY', False):
+- return
+- self.failUnless('v1.0.0' in tags)
+-
+- def test_show(self):
+- """Test running 'git show'"""
+- oid = 'HEAD'
+- content = self.git.show(oid)[STDOUT]
+- self.failUnless(content.startswith('commit '))
+-
+ def test_stdout(self):
+ """Test overflowing the stdout buffer"""
+ # Write to stdout only
diff --git a/dev-vcs/git-cola/files/index.html b/dev-vcs/git-cola/files/index.html
new file mode 100644
index 000000000000..7f1e814a0b51
--- /dev/null
+++ b/dev-vcs/git-cola/files/index.html
@@ -0,0 +1,15 @@
+<html>
+<head>
+ <title>Missing documentation</title>
+</head>
+<body>
+<div style="border: 4px double red; padding: 2em; margin: 4em; top: 4em; width: 20em;">
+ This documentation is missing. Please reinstall dev-util/cola with the 'doc' useflag enabled.
+
+ <p style="text-align: right;">
+ Sincerely,<br/>
+ your package maintainer.
+ </p>
+</div>
+</body>
+</html>
diff --git a/dev-vcs/git-cola/git-cola-2.11.ebuild b/dev-vcs/git-cola/git-cola-2.11.ebuild
new file mode 100644
index 000000000000..2eb369d1340a
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-2.11.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 readme.gentoo-r1 virtualx
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="https://git-cola.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# Since PyQt5 is preferred at runtime if installed, depend on that
+RDEPEND="
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,network,widgets,${PYTHON_USEDEP}]
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ python_targets_python2_7? ( dev-python/sphinxtogithub[$(python_gen_usedep 'python2*')] )
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] ${VIRTUALX_DEPEND} )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.10-disable-live-tests.patch
+)
+
+python_prepare_all() {
+ # Use system QtPy
+ rm -r qtpy || die
+
+ rm share/git-cola/bin/*askpass* || die
+
+ # remove broken tests
+ rm test/i18n_test.py || die
+
+ # don't install docs into wrong location
+ sed -i -e '/doc/d' setup.py || die
+
+ # fix doc directory reference
+ sed -i \
+ -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
+ cola/resources.py || die
+
+ # fix ssh-askpass directory reference
+ sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=( --no-vendor-libs )
+}
+
+python_compile_all() {
+ cd share/doc/${PN}/ || die
+ if use doc; then
+ emake all
+ else
+ sed \
+ -e '/^install:/s:install-html::g' \
+ -e '/^install:/s:install-man::g' \
+ -i Makefile || die
+ fi
+}
+
+python_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
+ virtx nosetests --verbose --with-id --with-doctest \
+ --exclude=sphinxtogithub
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+python_install_all() {
+ cd share/doc/${PN}/ || die
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase" "${ED}"/usr/bin/git-cola
+ python_optimize "${ED}/usr/share/git-cola/lib/cola"
+
+ use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
+
+ distutils-r1_python_install_all
+ readme.gentoo_create_doc
+}
diff --git a/dev-vcs/git-cola/metadata.xml b/dev-vcs/git-cola/metadata.xml
new file mode 100644
index 000000000000..a9e87ceda54e
--- /dev/null
+++ b/dev-vcs/git-cola/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">git-cola/git-cola</remote-id>
+ </upstream>
+</pkgmetadata>