summaryrefslogtreecommitdiff
path: root/dev-vcs/git-cola
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-vcs/git-cola
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/Manifest2
-rw-r--r--dev-vcs/git-cola/git-cola-3.9.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/dev-vcs/git-cola/Manifest b/dev-vcs/git-cola/Manifest
index b9d315d9b5df..579ed4b41cd9 100644
--- a/dev-vcs/git-cola/Manifest
+++ b/dev-vcs/git-cola/Manifest
@@ -3,6 +3,8 @@ AUX git-cola-3.5-py3.8-line-buffering.patch 1342 BLAKE2B e13e576a8e4d88975b59e3f
AUX index.html 355 BLAKE2B 24c532f3882744fe3be55fbef8eb35410849124baeffc56659fa6200140ec7059bfee2323443a5ea62481b6b4c43b6fcc1e116acf8f67082ade03b2a8a23aed1 SHA512 a3e66bb220ae05c2f49a75ce413c5aeefb9ced26f7e8b2175b32ade83663153fab94f8601b1d0182d1eeb907edc6c1bef3ad96d84b1e6c00ca4d5a816be79bac
DIST git-cola-3.5.tar.gz 970155 BLAKE2B ae602d4de0e6fac9d2817100bee8923d8f550d0bb83ddafd806ccdfbd0a77c65bfb60ff03a9399c6b60d5d4683eb6d46ee41eaa43faf2e2ac092b34c9151c999 SHA512 532e24092a72486171345aeb0e7610eb49c4062b64395988c6c4965cac6e9ffaed1268c30a0a525d4d99404f626d9e505a4be148d376994d4326e3ca873e2793
DIST git-cola-3.8.tar.gz 980190 BLAKE2B 0502701c63f370b304a83094b2154757d1810216e82882472c7eac9633ac26eaa75974af05c32c18203d03b67a027655ea85c0e335915f204f668fcc86ed9c3f SHA512 9ae04dfef3b5bc64452a8df43e7afa93091f282097447208dadbd17522b62e5c43f7afce3eecc59fc4e38863496cdb41ac8b0453bbf327121629fbde20e45bb0
+DIST git-cola-3.9.tar.gz 992335 BLAKE2B ab591d953173aa69773a82eb91ebcc6fa5bc5e31efa78ad27f3e1e57e22c4222d70914f059dffb0b05b2b366d3208e127ad123ccfeb1b4c1b648daae0bf53352 SHA512 91f4bb40c166669e05136985920113d7482a396a46adf45fcf05e8ee56677fee7ebfb6a793face79737a17be42aa5e32b216a30847e8e4a5b8dc5b3b4eba5395
EBUILD git-cola-3.5-r1.ebuild 2706 BLAKE2B ae347bfb42eef709c9620900f8dae3e215fcffdf2e6a2bd6eadb9eb9054cbfbef814b08be395a1dcb8bdfa77ce9fa17510b65219a0e728a523730271b9d30dd3 SHA512 83765a40e7217641dd6a6819f1dfe72d829ee2652398e249a6b40c5c7d874567d5d49027340aef999e3ef9935ba797eae2e1b9eab178583a072a1197949f9bb3
EBUILD git-cola-3.8.ebuild 2525 BLAKE2B 141b9770a44592c08ca6da7ffa26e96fc078b7510a21a14e4a2a573ccd483c916e0b725f5e2aafdf43d05f0ede948afe328be4b61dbbdc747c336c8ae06e15bb SHA512 2e60b40364b5b336bbf349937eec3cce2e521c5ce8631b70520bfc6dab52b7bccb4afc1a2c9f5535bd6f7185f8d9f11fb89da499d195fb1c86ce341738755a17
+EBUILD git-cola-3.9.ebuild 2485 BLAKE2B d38134cc923f23c0f83a0d93688d5216f56ad9948318e709e1f6a6bfd70d1dd274c0855e3f3e95816c177150b50ae781eea47508ff498216922bb851d2114582 SHA512 d5a6fedca17d935ab671358fbbac0b8ccd27fba133af3011c4ce3b74f45f4e7768079d6bd985d609b22487709658c8b380288eaca5fcf880035b069924fb4548
MISC metadata.xml 550 BLAKE2B 65feeb544a556d9202adda4f760b622c21bc03e04ae40428a49f3c53f253065cb923bbdf70c10187935895d5afc47ed9e49d8789d616503963689fdac06e860c SHA512 92a636e729d3d000e04773b2debb015b399f0b87f32a14c259c915975864e1d40114e68c7434fbe055913fbdc9f73c3f1d400807c25e83cf0b49f354b302e657
diff --git a/dev-vcs/git-cola/git-cola-3.9.ebuild b/dev-vcs/git-cola/git-cola-3.9.ebuild
new file mode 100644
index 000000000000..11cb88f55b7f
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-3.9.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1 readme.gentoo-r1 virtualx xdg-utils
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="https://git-cola.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[network,${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-vcs/git
+"
+BDEPEND="sys-devel/gettext
+ $(python_gen_cond_dep "
+ doc? ( dev-python/sphinx[\${PYTHON_MULTI_USEDEP}] )
+ test? (
+ ${VIRTUALX_DEPEND}
+ dev-python/mock[\${PYTHON_MULTI_USEDEP}]
+ dev-python/nose[\${PYTHON_MULTI_USEDEP}]
+ dev-python/pytest[\${PYTHON_MULTI_USEDEP}]
+ )
+ ")
+"
+
+python_prepare_all() {
+ # make sure that tests also use the system provided QtPy
+ rm -r qtpy || die
+
+ rm share/git-cola/bin/*askpass* || die
+
+ # don't install docs into wrong location
+ sed -i -e '/doc/d' setup.py || die
+
+ # fix doc directory reference
+ sed -i \
+ -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
+ cola/resources.py || die
+
+ # fix ssh-askpass directory reference
+ sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=( --no-vendor-libs --no-private-libs )
+}
+
+python_compile_all() {
+ cd share/doc/${PN}/ || die
+ if use doc ; then
+ emake all
+ else
+ sed \
+ -e '/^install:/s:install-html::g' \
+ -e '/^install:/s:install-man::g' \
+ -i Makefile || die
+ fi
+}
+
+python_test() {
+ GIT_CONFIG_NOSYSTEM=true \
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C.utf8" \
+ virtx nosetests --verbose --with-id --with-doctest \
+ --exclude=sphinxtogithub
+}
+
+python_install_all() {
+ cd share/doc/${PN}/ || die
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ # remove empty bin folder
+ rm -R "${ED}"/usr/share/git-cola/bin || die
+
+ use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
+
+ distutils-r1_python_install_all
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}