summaryrefslogtreecommitdiff
path: root/dev-vcs/git-bz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/git-bz
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/git-bz')
-rw-r--r--dev-vcs/git-bz/Manifest4
-rw-r--r--dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild39
-rw-r--r--dev-vcs/git-bz/git-bz-9999.ebuild47
-rw-r--r--dev-vcs/git-bz/metadata.xml8
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-vcs/git-bz/Manifest b/dev-vcs/git-bz/Manifest
new file mode 100644
index 000000000000..8e91f2d50687
--- /dev/null
+++ b/dev-vcs/git-bz/Manifest
@@ -0,0 +1,4 @@
+DIST git-bz-0.2015.09.08.tar.bz2 46980 BLAKE2B c5aae20c4c3946b01620f0cdd33248a67ffc3a3e8fb84bab6bb6ccda778ac82e7fb7fb6bbe463fb13733e5b8bf5ba95d0e316b0dbcee3ef30c5003c353521ce5 SHA512 8a468183f23d182ea566ceb524b05028c483e5eecc0c8babec42d67e99b8779af430d18373e130dcc13c8c58135ac62faf0a700c2731320617b47b00f5678133
+EBUILD git-bz-0.2015.09.08.ebuild 811 BLAKE2B 43ba5f07c93baacec1f9d037ce96058db16f5be01eabd74a0eb6144c981b5bfcd048310caf796fe44bcee42cb26632099cdbfdc0658555ab65635ffa90b4fc15 SHA512 c931c0150d646365849c9c94eef7a9a2bd3baf94716968e7323bfdc46b49be1d3d92c3b96ff702e790a1e6237201e3abf9a7b9a0a3b7c907e426a62e0d29975f
+EBUILD git-bz-9999.ebuild 917 BLAKE2B 1f04d51d95c47964ea4b4cbae0a7460b548dc8a055f1ec87a39b25bce40514aae98402d9a132a3b36507d1120a057e65812c749e5c618cf64a805cc8a93b8ee9 SHA512 00cbd04377fb76e55fdf5414b612f767923e3cff339617a43e33ca5cd30069a1b23d588c76d90c3948b0dec3074586f3e01cb0b411d7311f23df340c85a972c7
+MISC metadata.xml 247 BLAKE2B 1750cec57189e711ca5eba89a78e1d317f0839fa53564fbd39b4e955c28d98f4ae04caf9069afc20a18536cdc92b30fe7b15eb086767c742bad07d9980cfd24b SHA512 d6e2ea8a9d74791bcbf3d6311a66bafc20b8f4db3a576d9a8d54b86d7afb231122b8d87f71f3f46360980adf8d815c633b6d5041f9a30fc8656e8fb66057a282
diff --git a/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild b/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild
new file mode 100644
index 000000000000..44eacb2a7a3e
--- /dev/null
+++ b/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE='sqlite'
+
+inherit python-single-r1
+
+DESCRIPTION="Bugzilla subcommand for git"
+HOMEPAGE="http://www.fishsoup.net/software/git-bz/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-vcs/git
+ ${PYTHON_DEPS}"
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED%/}"/usr/bin/${PN}
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/pycrypto; then
+ elog "For Chrome/-ium cookie decryption support, please install:"
+ elog " dev-python/pycrypto"
+ fi
+}
diff --git a/dev-vcs/git-bz/git-bz-9999.ebuild b/dev-vcs/git-bz/git-bz-9999.ebuild
new file mode 100644
index 000000000000..c8f2c69685ef
--- /dev/null
+++ b/dev-vcs/git-bz/git-bz-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE='sqlite'
+
+EGIT_REPO_URI="git://git.fishsoup.net/${PN}
+ http://git.fishsoup.net/cgit/${PN}"
+inherit git-r3 python-single-r1
+
+DESCRIPTION="Bugzilla subcommand for git"
+HOMEPAGE="http://www.fishsoup.net/software/git-bz/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-vcs/git
+ ${PYTHON_DEPS}"
+DEPEND="app-text/asciidoc
+ app-text/xmlto"
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake ${PN}.1
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED%/}"/usr/bin/${PN}
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/pycrypto; then
+ elog "For Chrome/-ium cookie decryption support, please install:"
+ elog " dev-python/pycrypto"
+ fi
+}
diff --git a/dev-vcs/git-bz/metadata.xml b/dev-vcs/git-bz/metadata.xml
new file mode 100644
index 000000000000..0319eec4c8be
--- /dev/null
+++ b/dev-vcs/git-bz/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>